开始使用

开始使用 Next

开始使用

客户端是在线交易系统的一部分。 此终端软件安装在交易者的电脑上，具有如下功能：

  • 获得实时的报价和新闻。
  • 准备和执行交易指令。
  • 监控和管理开仓头寸和挂单指令。
  • 进行技术分析。
  • 创建智能交易系统、用户自定义技术指标和MQL4语言脚本。
  • 交易策略的测试和优化。

交易者为了决定在金融市场上是否进行交易，需要实时和可靠的信息。正因为如此，此终端软件具有接收在线实时报价和新闻功能 。实时报价服务和使用技术分析指标是分析市场的基础，终端软件上的智能交易系统能够自动的监视市场状态和个人的头寸。 此外，可设置多种类型指令灵活地管理头寸。

此程序能在Microsoft Windows XP(SP3)/2003/Vista/2008/7/8/10下运行。也需要支持SSE2指令集的处理器用来操作。硬件需求由操作系统决定。

© 2000-2015, MetaQuotes Software Corp.


????

开始使用 / 开始

开始

这部分包含启动客户端时您需要知道的基本信息：

  • 终端安装
  • 终端开始
  • 开立账户
  • 认证身份
  • OTP
  • 自动更新


???? ? ????

开始使用 / 开始 / 终端安装

终端安装

对于安装客户终端需下载相应的程序并开启它。选择文件目录进行安装。终端安装完成后将会自行运作。

同样终端可以覆盖安装在原有的版本上。另外, 所有终端保有原有设置。 例外存在于: DEFAULT 数据图表和模板， 常规 MQL4 programs进入分配设置程序。 所以提醒改变其模板和数据图表,创建MQL4程序名称。

如果需要同时运行几个账户，终端的信息总量必须安装在不同的文件目录内。 另外, 每个终端都拥有自己的属性，除注册细节 语言界面外其他会被记录。


在Mac OS上安装

开始使用 / 开始 / 在Mac OS上安装

在Mac OS上安装程序端

客户端可以使用Wine安装和运行在Mac OS计算机上。Wine 是一个免费软件，允许用户在基于Unix的系统上运行Microsoft Windows系统开发的应用程序。在所有的Wine版本中，有一个是为Mac OS准备的。

需要注意的是Wine不是一个完全稳定的应用程序。因此，在其下启动的应用程序中的某些功能可能无法正常工作或不工作。

对于在Mac OS上安装，我们推荐您使用免费的应用程序 PlayOnMac。PlayOnMac 一种基于Wine的软件，易于在Mac OS上安装Windows 应用程序。

PlayOnMac 的安装

要安装PlayOnMac，打开该产品的官方网站，移动到下载部分，然后点击链接下载最新版本。

下载DMG包后，从您系统的下载部分启动它：

PlayOnMac第一个启动窗口将出现。点击“下一步”后，安装程序将开始检查和安装工作所需的各种组件。

第一个必要的组成部分是XQuartz。这是用来在Mac OS上使用X Window 系统 的软件。X Window 系统为在类似Unix操作系统中建造图形用户界面而提供标准的工具和协议。

如果您已经安装了XQuartz或想要安装它以后，分别选择“此刻不安装 XQuartz”或“我自己下载文件”。

XQuartz安装在几个阶段进行。首先，你应该阅读的重要信息（自述文件），接受许可条件。

在安装之前，Mac OS安全系统将要求您输入您的帐户的密码：

等待安装完成。为使更改生效，你应该重新启动您的电脑。

重启系统后，从下载文件夹的安装文件再次启动PlayOnMac。第一个启动窗口将再次出现。这个时候，为了正确操作，安装程序会提供安装MS Windows的必要字体。

接受许可协议的条件，并等待直到安装完成。在那之后，准备使用PlayOnMac。它的主窗口将出现：

更新Wine

Wine v. 1.4 与PlayOnMac一同安装。Wine 1.4.1 是目前最新的稳定版本。Wine 1.5.21 beta版发布包含了许多改进，也可以下载。然而，它可能不太稳定。建议安装最新版本的Wine。

若要升级到最新版本的Wine，打开PlayOnMac上一级菜单，并选择管理Wine 版本：

可用于安装的Wine版本窗口将会打开。选择最新的版本（此刻是1.5.21 ）。

移动最新的Wine版本到窗口的右侧。开始安装。

安装完成后，新版本的Wine将出现在 PlayOnMac Wine版本管理窗口的左侧部分。然后，您可以关闭该窗口，并安装交易程序端。

程序端安装

要安装程序端，下载安装程序"mt5setup.exe"。下载完成后，启动安装文件。PlayOnMac将自动将其打开。

全部阶段的标准程序端安装进程将会开始：

当安装完成后，PlayOnMac会为您提供创建程序端组件的快捷方式 - 客户程序端本身和MetaEditor。

创建必要快捷方式后，您就可以开始使用客户程序端。在PlayOnMac窗口双击它启动程序端。

已知问题

正如上面已经提到的，Wine不是一个完全稳定的软件。因此，程序端的一些功能可能会工作不正常。目前发现以下问题：

  • 市场 不可用

除上述问题外，您可以在Mac OS上享受客户程序端的全部功能。

程序端数据目录

PlayOnMac创建一个单独的虚拟逻辑驱动器，其中带有每个已安装程序的必要环境。已安装程序端的数据文件夹的默认路径如下：

Library\PlayOnMac\WinePrefix\Client_Terminal_\Drive C\Program Files\Client Terminal


在Linux上安装

开始使用 / 开始 / 在Linux上安装

在Linux上安装程序端

Linux 是一个免费开源软件开发及分销的模式下组装的类似Unix的计算机操作系统。Linux系统被广泛应用于智能手机和服务器硬件。许多家庭PC用户喜欢它更甚于MS Windows系列。

Linux的特点之一是缺乏一个统一的分发包。不同组的开发人员使用多种Linux版本，包括Debian，Mint，Ubuntu，OpenSUSE，Gentoo等。在这篇文章中，我们会考虑一个最流行的分发包 - Ubuntu。

客户端可以使用Wine安装和运行在Linux计算机上。Wine 是一个免费软件，允许用户在基于Unix的系统上运行Microsoft Windows系统开发的应用程序。在所有的Wine版本中，有一个是为Ubuntu的。

需要注意的是Wine不是一个完全稳定的应用程序。因此，在其下启动的应用程序中的某些功能可能无法正常工作或不工作。

在安装前，应进行初步设置。从包含在资料库的软件包中，所有应用程序都安装在Ubuntu上。WineHQ PPA资料库的路径应该添加到安装Wine。打开Ubuntu软件中心并执行"编辑"菜单中的"软件源"命令。

在新的窗口中点击"添加"。

下面的数据应被指定在АРТ（高级包管理工具）线：ppa:ubuntu-wine/ppa。点击"添加源"。这样就完成了前期准备。

要安装Wine，打开其官方网站 http://www.winehq.org，去下载部分，选择Ubuntu的分发包。点击相应的链接安装最新的Wine版本。目前，最新的稳定版本是Wine 1.4.1。您也可以下载测试版Wine 1.5.21，其中有许多改进，但可能会出现不太稳定。系统会提示您通过Ubuntu软件中心打开链接。同意的话，软件中心将提示启动Wine安装：

点击"安装"并且等待安装完成。一旦安装完成后，它已经可以在Ubuntu中运行Microsoft Windows可执行文件。

从命令行安装Wine

您可以使用命令行（在Ubuntu中被称为"程序端" ）安装Wine而不使用Ubuntu GUI。

执行下面的命令来添加WineHQ PPA资料库，Wine将被由此安装：

sudo add-apt-repository ppa:ubuntu-wine/ppa

执行后，使用下面的命令更新APT数据包：

sudo apt-get update

执行后，您就可以开始Wine安装。执行下面的命令：

sudo apt-get install wine1.5

安装Wine1.5。执行后，Wine就可以使用了。

启动客户程序端

要安装程序端，下载安装程序"mt5setup.exe"。下载完成后，启动安装文件。系统会自动判断您正在试图运行一个专为微软Windows设计的文件，并会提供以Wine打开它。选择此选项并点击"OK"。

启动客户程序端安装程序。完成所有安装步骤：

安装完成后，您可以通过运行它的terminal.exe文件开始使用程序端。

在Ubuntu开始使用交易程序端的另一种方式是复制以前安装在Microsoft Windows的客户程序端的整个文件夹：

复制完成后，只需运行程序端的terminal.exe文件。将自动使用Wine打开该文件。

已知问题

正如上面已经提到的，Wine不是一个完全稳定的软件。因此，客户程序端的一些功能可能会工作不正常。目前发现以下问题：

  • 市场 不可用

除上述问题外，您可以在Ubuntu上享受交易程序端的全部功能。

程序端数据目录

Wine创建了一个虚拟的逻辑驱动器，其中带有安装程序的必要环境。已安装程序端的数据文件夹的默认路径如下：

Home\.wine\drive_c\Program Files\Client Terminal


???? ? ????

开始使用 / 开始 / 终端开始

终端开始

程序安装完成后，客户端的程序会在"开始"菜单中创建， 程序的快捷方式会添加显示在桌面上。 方便客户端的使用。

注意: 客户端不能够在一个目录里同时运行两个复本。 要同时运行几个终端，需要在不同的目录内安装 相应的程序。

从build 600开始，客户端就以新的客户端文件结构和位置为特点。 现在，MQL4 应用根据程序类型分别放在单独的目录（EA交易，指标或脚本）。在大部分情况下，程序端数据现在存储在独立于程序端安装位置的专用数据文件夹。在本文中，我们将详细描述数据如何转移，以及引进新存储系统的原因。

为什么要实施新数据存储系统

13年前发布的Microsoft Windows XP 允许应用程序在其安装位置编写自己的数据，即使后来以Program Files系统文件夹代替。用户只有拥有管理员权限才能向任意文件夹编写数据。

当64位系统工作时，32位和64位程序提供独立的安装目录：Program Files 和 Program Files (x86)。文章中描述的操作功能适用于这两个目录。

从Windows Vista开始，Microsoft 引入了限制编写Program Files目录。如果 用户账户控制(UAC)系统被启用，不允许程序在 Program Files 文件夹存储它们的数据。全部数据应该都放在独立的用户目录。这种限制的引进是为了保护用户免受恶意程序攻击和防止一个用户帐户下的应用程序改变或损坏另一个用户帐户所需要的相同程序的数据。自那时起，Microsoft操作系统的安全要求已进一步收紧。特别是，从Windows 8开始，UAC系统不能禁用，即使在其设置中选择“从不通知”选项。

微软已经实施虚拟化进程为了使用UAC时提供与旧应用程序的兼容性。如果某个程序试图将其数据保存到Program Files目录，数据实际上是（物理）保存到具有以下一样的一个单独的文件夹 - C:\Users\<user-name>\AppData\Local\VirtualStore\Program Files，而Windows文件搜索显示文件，就好像它们被保存在安装目录。Microsoft声称，这种模式只为兼容性提供并可稍后删除。

为了符合微软的建议，从build 600开始，程序端的数据存储结构已经发生了变化。现在，程序端也将其数据存储在用户目录。

用户数据目录

在新版本中，使用程序端某个副本工作的某个用户的所有数据都存储在一个称为程序端数据文件夹的专门地方。此文件夹沿以下路径可在系统盘（安装Windows操作系统的磁盘）中找到：

C:\Users\User_account_name\AppData\Roaming\MetaQuotes\Terminal\Instance_id

其中：

  • С： - 系统盘的名称。
  • User_account_name — Windows工作的用户帐户。
  • Instance_id — 使用程序端某个副本的所有用户数据存储的文件夹的唯一名称。 唯一名称由16个字符组成。这个名称是基于程序端安装目录的路径产生的，因为程序端安装目录的路径不能明确地用作文件夹名称。唯一名称的显著长度由程序端的多个副本可以在一台PC机上安装的事实来解释的。

程序端文件菜单中的“打开数据文件夹”命令允许搜索和打开数据文件夹。

每个程序端的数据文件夹的根目录下还包含origin.txt文件，在这里您可以找到这些数据涉及的程序端安装文件夹的路径。这允许用户对每个程序端数据文件夹匹配某个程序端的安装目录，例如，如果一个用户安装多个程序端副本。当数据文件夹与安装文件夹分离时，这种程序端的工作类型就是主要模式。

为了更加方便，每次程序端启动时，包含数据文件夹路径的条目会记录在程序端日志中。例如：

2014.02.10 12:48:28.477 Data Folder: C:\Users\JohnSmith\AppData\Roaming\MetaQuotes\Terminal\9F86138A4E27C7218E9EC98A5F8D8CA1

更新程序端到Build600和更高版本时复制MQL4应用程序文件

当新的更新程序端启动时，它会检查数据文件夹是否存在。如果数据文件夹不存在，那么它就会被创建。如果该文件夹不同于安装文件夹，程序端的常规数据会(标准MQL4程序，历史数据，配置文件，模板等等)复制到它。程序端操作期间没有改变的文件(可执行文件，mql.dll编译器，声音文件等)留在安装目录。程序端数据文件夹在下列情况下不同于安装文件夹：

  • 启用UAC系统。唯一例外是当程序端安装在便携设备上时(外部硬盘驱动器，usb闪存驱动器等等)。
  • 当前PC用户写入数据到安装目录的权限有限。
  • 用户正在通过远程连接(RDP)工作。

如果以上条件都不满足，程序端数据会存储在安装目录。

然后，用户文件移动到数据文件夹。在这个阶段，确定程序端用户数据存储的目录。如果数据被存储在程序端的安装文件夹，它们会按以下方式复制：

安装目录中的源文件夹 | 目录 | 程序端数据目录的目标文件夹
\experts | EA交易（自动交易） 注意：只有\experts根目录的文件被复制。不复制子目录，因为无法可靠地确定它们的内容 | \MQL4\Experts
\experts\indicators | 自定义指标 | \MQL4\Indicators
\experts\scripts | 脚本（单独运行在图表上的MQL4应用程序） | \MQL4\Scripts
\experts\include | 实施在其他程序中的源代码MQH 和 MQ4文件 | \MQL4\Include
\experts\libraries | MQ4 源代码和由此编译的EX4可执行文件格式的程序库它们用于其他MQL4程序包含的函数的动态调用 | \MQL4\Libraries
\experts\files | 特殊的“文件沙箱”MQL4应用程序只允许在这个目录内执行文件操作 | \MQL4\Files
\experts\logs | MQL4应用程序的日志文件 | \MQL4\Logs
\experts\presets | MQL4应用程序的预置文件 | \MQL4\Presets
\experts\images | 资源中使用的图像文件 | \MQL4\Images

接着，检查该客户端是否在虚拟目录存储数据（上述操作系统的虚拟存储）。如果程序端已经安装在Program Files目录和操作系统是Windows Vista或以上版本时，程序端数据最有可能存储在该目录中。如果找到该数据，根据上面表格进行复制。

这些文件在迁移过程中复制而不移动。复制的文件不会从源文件夹中删除。

在迁移过程中，包含复制文件的源路径和目标路径的条目记录在程序端的日志。要查看所有日志，打开程序端窗口的日志选项卡，并在上下文菜单中执行打开命令。包含程序端日志文件的文件夹将打开。

如果迁移已成功完成对当前程序端的复制，那么在随后的程序端更新中就不会再重复。如果数据文件夹不同于安装文件夹，在迁移过程中自定义MQL4应用程序连同标准文件一起复制，则会出现以下对话框窗口：

便携模​​式

便携启动模式提供用于便携设备的程序端操作和非系统目录，以及Windows XP的工作。在此模式推出时，程序端尝试在安装文件夹保存其数据。然而，使用便携模式并不能保证操作系统将允许在安装文件夹存储数据（例如，如果程序端安装在Program Files目录和启用UAC系统）。

为了便携模式工作应该满足下列情况：

安装目录 | 操作系统 | 要求
Program Files或其他系统目录（例如，Windows） | Windows XP | 写入到安装文件夹的权限
另一个非系统目录 | Windows XP | 写入到安装文件夹的权限
外部硬盘驱动器，usb闪存驱动器等等 | Windows XP | 程序端将始终以便携模式启动。
Program Files或其他系统目录（例如，Windows） | Windows Vista\Windows 7 | 作为管理员启动程序端和禁用UAC
另一个非系统目录 | Windows Vista\Windows 7 | 写入到安装文件夹的权限
外部硬盘驱动器，usb闪存驱动器等等 | Windows Vista\Windows 7 | 程序端将始终以便携模式启动。
Program Files或其他系统目录（例如，Windows） | Windows 8及以上 | 无法使用便携模式，因为UAC系统不能禁用
另一个非系统目录 | Windows 8及以上 | 写入到安装文件夹的权限
外部硬盘驱动器，usb闪存驱动器等等 | Windows 8及以上 | 程序端将始终以便携模式启动。
  • 如果您使用的是Windows Vista或更高版本，并且程序端安装在Program Files，不建议使用便携模式。此模式提供适用于便携设备和Windows XP的程序端操作。
  • 如果您已经更新了程序端并且所有的数据已复制到一个单独的用户数据文件夹，也不建议切换到便携模式。
  • 您应该手动将数据复制到安装文件夹，以便在复制用户数据文件夹中的数据后，使用便携模式。在便携模式启动程序端不从数据文件夹复制数据到安装文件夹。

若要在便携模式启动程序端，使用"/portable" 键。欲了解更多的便利性，您可以在桌面上创建一个具有合适名称的额外的程序端快捷启动，并直接添加密钥到快捷方式：


???? ?????

开始使用 / 开始 / 开立账户

开立账户

用户端能够运行两种类型的帐户： 模拟账户和 真实账户。模拟帐户可以不用投入真正的资金来进行交易训练，来测试自己交易策略的品质。 模拟帐户和真实帐户非常相似，只有一点不同，那就是这些模拟帐户的开户不需要资金，因此，也不能希望从账户上获得利润。

开设模拟账户

开设模拟账户可以选择菜单中"文件— [image] 开设账户"执行或选择 "导航—账户" 窗口 。 此外，当第一次启动程序时，将会被建议开启一个模拟帐户。

开立账户分成几个步骤：

选择服务器

开立账户的第一步就是选择连接的服务器。可用服务器地址，它们的名字和ping都列在那里。最可取的是具有最低ping的服务器。要执行额外的ping检查，您应该按下“扫描”按钮。在这以后，ping信息就会刷新。

此外，在此窗口中，您可以添加一个连接的新服务器。要做到这一点，按下“ 添加新服务器 添加新服务器”按钮或“插入”键。可以以不同的方式来指定服务器：

  • 用冒号分隔编写地址和端口。例如，192.168.0.100:443；
  • 用冒号分隔编写域名和端口。例如，mt.company.com:443；
  • 写一个交易商公司的准确名称。

您指定服务器后，按“Enter”。要删除服务器，请选择它，然后按“删除”键。

账户类型

在这一步用户可以指定现有交易账户的详情或开始创建一个新账户。

该窗口包括三个选项：

  • 现有交易账户 - 如果选择此选项，就必须填写“登录名”和“密码”字段和相应账户的详细信息。上一步选择的服务器会显示在这些字段下面。只要您按下“完成”按钮，您将被授权在指定的服务器使用指定的帐户。
  • 新建模拟账户 — 如果选择此选项并按下“下一步”按钮，您将转到创建新模拟账户。
  • 新建真实账户 — 如果选择此选项，您将转到指定个人信息，用来发送开立真实账户的请求。

个人详细资料

开立账户的下一阶段就是指定个人详细资料：

您需要填写如下数据：

  • 名称 — 用户的姓名。
  • 国家 — 居住的国家。
  • 州/省 — —居住的州/省(地区，行政区等)。
  • 城市 — 居住的城市。
  • 邮编 — 邮政编码。
  • 地址 — 居住的地址（街道和门牌号)。
  • 电话 — 联系电话。
  • Email — 电子邮件地址。
  • 帐户类型 — 模拟帐户组别所代理的中介公司。
  • 通货种类 — 盈亏计算的基准货币。
  • 交易倍数 — 信用交易倍数。
  • 存款额 — 初始存款额。

然后选择"下一步"按钮继续进行注册，你必须选中 "我同意订阅你们的新闻简报"。

注册成功完成后，会出现一个窗口，其中包含有关开立帐户的信息：“登录名” - 账号，“密码” - 访问密码，“只读” - 只读密码（连接模式，它是可以检查帐户状态，分析价格动态，等等，但不允许交易）。

如果注册成功，将会出现一个包含新的模拟帐户资料的窗口： "登陆" — 用户帐户， "密码" — 访问密码， "投资人" — 投资人密码(连接状态会检验账户， 分析价格等等，但不允许交易。). 注册后，新帐户将会出现在"导航 — 账户" 窗口中， 并准备开始工作。而且，服务器会发送到终端邮件包含新帐户的登陆和密码。 可以在"终端 —邮箱" 窗口找到。另外， 账户成功注册后，它将会自动 验明证身。

注意: 如果注册过程中出现任何技术问题，请寻求经济公司帮助。

开设真实帐户

真实帐户与模拟帐户不同，不能直接从终端软件中开立。 他们只能通过经纪公司审核后才开立。. 使用真实账户时，需要通过服务窗口的"导航— 账户"窗口。 开始使用必须经过 授权。


???? ?????

开始使用 / 开始 / 认证身份

认证身份

认证身份是通过运用登陆和密码开启终端服务器的连接.它允许经营一个交易账户. 对于账户在终端内存在两种形式: 基本密码和投资密码. 使用基本密码授权, 能够得到充足的权利在终端内工作. 投资授权允许查看账户的状态, 价位分析, 和咨询专家顾问. 但不能够交易. 投资形式对于账户交易的演示已成为便利的工具.

对于授权, 需要通过账户上下文的命令实行" [image] 登陆" 在"导航" 窗口 或者"文件" 目录. 然后, 账户号码, 其中的一个密码(基本密码和投资密码)可以在窗口中显示, 同时服务器关闭. 在所有数据被接收后, "登陆".

注意: 如果 "保存个人设置和数据启动",这时终端将会自动授权下一位用户帐号. "保存个人设置和数据启动" 选择终端设置 发挥同样的作用.


OTP

开始使用 / 开始 / OTP

OTP — Authorization Using One-Time Password

Use of OTP (One Time Password) provides an additional level of security when working with trading accounts. The user is required to enter a unique one-time password every time to connect to an account.

  • The use of the OTP should be enabled on a trade server.
  • The use of the OTP can be forced on a trade server.

One-time passwords are generated in the mobile terminal for iPhone and the mobile terminal for Android soon.

How to enable OTP

To start using one-time passwords, you should bind your trading account with the password generator, which are the mobile terminals for iPhone and Android.

Go to the Settings of your mobile terminal and select OTP. For security reasons, when you first open this section, you will be required to set a four-digit password. The password must be entered every time you access the password generator.

Set a password to access the OTP generator

In the window that opens, select "Bind to account".

Bind the account to the OTP generator

Next, specify the name of the server on which the trading account was opened, the account number and the master password to it. The "Bind" should be kept enabled. It must be disabled, if you are going to unbind the specified account from the generator and stop using one-time passwords.

After you tap the "Bind" button located in the upper part of the window, your trading account will be bound to the generator, and an appropriate message will appear.

Likewise, you can bind an unlimited number of accounts to the generator.

The one-time password is displayed at the top of the OTP section. Underneath, a blue bar visualizes the password lifetime. Once the password expires, it is no longer valid, and a new password will be generated.

Additional Commands:

  • Change Password — change the generator password.
  • Synchronize Time — synchronize the time of the mobile device with the reference server. Accuracy requirement is connected with the fact that the one-time password is bound with the current time interval, and this time should be the same on the client terminal and the server side.

How to Use OTP in the Desktop Terminal

After binding a trading account to the generator, a one-time password will be additionally requested when connecting to it from the desktop terminal:

Authorization using OTP


?????????

开始使用 / 开始 / 自动更新

实时更新

自动更新系统内置在程序端中。它允许即时通知和安装程序新版本。这个系统是永久可用的，无法禁止。

更新进程

程序端当连接服务器时会检查程序新版本。如果发现任何程序端组件有新版本，会以后台模式自动下载。然后，在程序端日志将会显示下面条目：

10:13:37.730 LiveUpdate: new version 4.00 build 563 is available

默认情况下，更新会下载到下面的文件夹（取决于使用的操作系统）：

Microsoft Windows XP：

  • C:\Documents and Settings\username\Application Data\MetaQuotes\WebInstall

Microsoft Windows Vista 及更高版本：

  • C:\Users\username\AppData\Roaming\MetaQuotes\WebInstall

这里“C”是一个本地磁盘字母，即操作系统安装的磁盘，“用户名”是操作系统中的账户，它安装在程序端下。下载可用于所有程序端的更新，更新不能重新下载为其他程序端的实例。

全部更新下载后，下面条目会出现在程序端日志中：

10:14:17.180 LiveUpdate: finished

要使用更新，程序端应该重新启动。

UAC启用来进行更新

如果计算机上启用UAC（用户账户控制）系统或用户在操作系统没有足够的权限，那么请求确认/提高用户权限的窗口将会在试图更新时显示。

Microsoft Windows XP

在MS Windows XP更新

这种情况下必须指定管理员账户信息，该账户在程序端安装目录拥有写入文件的足够权限。

Microsoft Windows Vista

在 MS Windows Vista更新

取决于 MS Windows Vista的用户权限，既需要允许操作（如果用户是管理员）也需要指定管理员账户信息。


?????

开始使用 / 客户端设定

客户端设定

通常客户端设定窗口可以应用"工具 — 属性"操作或按快捷键Ctrl+O。 所有设置按属性分组如下：

  • 服务器 — 设定服务器连接的参数，代理服务器和数据中心的配置。
  • 图表 — 显示价位图表的通常设置。即时时间分离器，要价水平位，OHLC线将会显现。 另外，在图表内可以限定储存和显示总量。
  • 对象属性 — 设定对象参数。 创建后选中对象，立即限定参数。
  • 交易 — 新定单的参数设定默认值。包括：金融工具，份额总量和离差总量。
  • 智能交易 — 所有交易的通用属性。包括：智能交易业务锁定， 从DLL资料输入功能和顾问。
  • 通知 — 设置从客户端发送推送通知到移动设备。
  • Email — 设定email参数。如果有需要从终端发送信息，邮箱的参数必须设定。
  • 公开页 — —在互联网中设定公开报告。终端允许在互联网上即时发送有关帐户状态的报告。 通过ftp建立连接。
  • 提醒页 — 设定事件系统的信号。. 关于无效连接的信号，新闻和其他。
  • Community — 用于订阅交易信号的MQL5.community账户详情。
  • 信号 — 在客户端设置“信号”服务。


????? ????

开始使用 / 客户端设定 / 服务器

服务器

在终端业务中服务器起到决定性的作用。服务器若出现变故将会有棘手的麻烦出现。 客户端的连接状态和常用业务。所以，建议轻易不要改变此窗口的参数。

"服务器 — 设置;"窗口，包含以下内容：

  • 选择连接服务器。
  • 代理器配置。
  • 变更密码。
  • 启动DDE服务器。
  • 启动新闻。

服务器

客户端的运行是以连续从服务器进入的数据（新闻和开价）为基础的。 如果客户端不能接收到开价，将无法正常交易。在一些模式下，终端允许应用指示器，画线分析和智能交易测试分析现存数据。

连接客户端到服务器，需要知道IP地址或服务器名和它的通信端口。程序被安装好后，所有数据会被指定，通常情况下无须改变设置。 尽管，在其他情况下需要连接其他服务器，它的地址和端口会在"服务器" 区域给出。 字段应按照如下格式"[服务器地址]：[端口号]"。 例如: "192.168.0.1:443"的地址，是 "192.168.0.1"的服务器地址和"443"端口数字。 输入数据后，按"确定"键执行。

新的服务器地址和端口数字会储存到硬盘上。 直到开启新帐户，这些数据不会影响客户端的交易业务。 给出的地址和端口数字会立即在终端上运行。 新的服务器的地址会添加到 注册账户的列表中。 如果成功建立连接，新帐户打开。否则，建议检查全部设置重新连接。

注意: 错误的连接服务器设置将不会开启新帐户。

代理服务器

通过代理服务器连接到互联网可以是服务器无法连接的另一个原因。代理服务器是交易人电脑和交易服务器之间的媒介。它主要由因特网提供商或者本地网络来使用。如果出现连接问题，您应该联系您的系统管理员或者因特网提供商。如果使用代理服务器，程序端也以同样的方式设置。设置“启用代理服务器”复选框将启用代理服务器的支持，并启动“代理...”按钮。按下此按钮将打开指定代理服务器参数的窗口（这些数据可以由系统管理员或互联网提供商给予）：

  • 服务器 — 代理服务器的地址和类型(HTTP，SOCKS5，或SOCKS4)。
  • 登陆 — 代理服务器的访问权。如果不需要密码，空下此区域。
  • 密码 — 代理服务器密码。如果不需要密码，空下此区域。

参数被指定后，建议按"测试"按钮检测设定。 如果测试成功，按 "确定"键执行设定。若收到错误信息意味着代理服务器设置错误。这时需检验系统并重新连接。

账户与登陆

客户端能够连接到服务器和应用账户运作。 在客户端内存在登陆（账户数字），投资密码和验证密码。验证身份需要输入账户数字，投资密码和验证密码。

账户被打开后，如果选择开启"保持个人设置和启动数据"，它的数据（账户数字，投资密码和验证密码）会保存到硬盘内。 在程序重新开启之后，数据将会与账户自动连接。 如果禁止此项功能，终端重新开启后，密码需要手动进入。

在"登陆"和 "密码"的区域账户数字和密码是被指定的。其他账户的数据可以输入此区域，然后按"确定 "键，终端会自行验证。如果验证出现错误，将会重新自行验证。若仍然没有帮助则寻求技术服务中心解答。

点击"更改"键，可以在显示窗口修改密码。这样做必须知道当前密码。 在注册模拟账户后可以从服务器上查找信箱。 新密码会在相应的区域输入。如果允许 "改变验证(真实)密码"，验证密码将会改变。

启动DDE服务器

允许/禁止实时报价通过DDE协议（动态数据交换）输出，用户终端的目录下 有一个有效的输出为MS Excel的例子，文件名为DDE-Sample.xls。 详细信息查看行情输出部分。

新闻

在终端连接到服务器之后，终端可以及时接收相关新闻 终端连接失败时禁止任何新闻进入。 "允许新闻"的进入。可以在"终端"窗口, "新闻" 显现的窗口中开启。

注意: 如果 "允许新闻"开启，但没有任何新闻出入，"新闻" 表不会在 "终端"窗口显示。


????? ? ??

开始使用 / 客户端设定 / 图表

图表

图表是一种将价位直观化的工具。 在这里图表设定和历史数据参数被分组。

参数的改变将不会促使终端内业务总量发生改变。

  • 显示交易范围
    如果选中此选项，图表将显示如下范围：开仓头寸， 挂单指令 ，止损和止赢定单的止损和止赢位置； 这一选项能够记录交易者的工作及纠正情感化的错误。 允许这选项的进入，需要开启 "显示交易范围" 。然后，按 "确定"键。随后，相应的信息将会显现在图表上。 当然，如果没有定单则不会显示交易范围。只有在开仓的情况下这个功能才会运行。
  • 使用"Alt" 键拖拽交易水平
    实施该选项用于方便管理图表上的挂单 和 止损水平。默认情况下，随着该选项的禁用，使用鼠标移动订单和止损水平(drag'n'drop)。如果图表中附加许多对象 ，您可以偶尔移动其中一个替代交易水平。这种情况下，启用该选项。之后，您仍然能够使用鼠标移动交易水平，但您需要按住"Alt"键。
  • 显示开盘收盘最高最低价OHLC
    此内容显示在图表的左上角，除了工具名之外，还有最新棒图的开盘收盘价，最高价和最低价。此选项还与技术指标窗口相关。
  • 显示买价线
    建立和显示只针对买入价的程序端柱。然而，对于买入持仓和平仓卖出持仓，却始终使用卖出价。但是它不以任何方式显示在图表中，无法看到它。要更加用心地去管理人们的交易活动，可以启用“显示买价线”参数。此命令执行后，与最新柱的买价相符的额外水平线将会出现在图表中。
  • 显示时间间隔
    在每个图表的水平轴上都会显示日期和时间。 可以选择成交量的时间段。 "显示时间间隔"是以垂直线的形式附加到图表上的。所以， 对于图表的时间段从一分钟到一小时，每日都需要调整。 四小时— 一星期，一天 — 一个月， W1 和MN1 —一年。
  • 彩色打印
    彩色打印。此选项可以让用户不再是黑白打印，而是彩色打印。如果打印机支持，用户可以执行菜单 "文件—打印"来打印图表。也可以在图表的右键菜单中选择相同的"打印"命令。
  • 保存删除的图表便于再次打开
    终端允许从目录中还原已删除的图表模板 。如果 "保存删除的图表便于再次打开"选项开启，它的 模板 会保存到 /DELETED文件夹中。 随后，打开"文件 —打开删除" 菜单操作，图表将被再次打开。 例如，恢复已经删除四小时的图表EURUSD。恢复后它的所有属性将与四小时前相同（指标，画线分析）。
  • 历史数据中最多蜡烛数
    可以设置保存在历史文件中的最多蜡烛数容量，而且，此历史数据可以被用来测试智能交易系统。 当指标和数据同时运行时，计算机可以提供足够的资源(中心处理器和RAM)能够快速运行。为了避免不必要的问题， 数据的总值可以独立现实在图表中。这样必须从pop-up列表中选择适当的成交量，在"图表中最多蜡烛数"手动操作。 最多蜡烛数会存储在硬盘中的 "历史数据中最多蜡烛数"。 将来，成交量将会应用到 智能交易测试中。

注意:

  • 在关闭图表的情况下，最多蜡烛数的储存量不能超过给定的 "历史数据中最多蜡烛"。
  • 在打开图表的情况下，最多蜡烛数的下载量不能超过给定的 "图表中最多蜡烛数" 。 但在图表中最多蜡烛数可以超过交易的成交量。
  • "显示交易信息", "显示开盘收盘最高最低价OHLC"和 "显示时间间隔"的指定成交量为默认值。 这些参数可以在设定窗口独立设置。
  • "显示交易范围", "彩色打印"和"保存删除的图表便于再次打开" 的指定成交量会影响所有图表，电击 "确定"后立即生效。


??????????

开始使用 / 客户端设定 / 对象

对象

运用 画线分析工具和 "插入"菜单工具图解对象。 由以下部分组成: 技术指标 (包括客户指标)， 画线分析，几何图形，文字和光标。 该选项卡收集的参数便于图形对象的工作，不会引起程序端操作的危险变化。

  • 新建后显示属性
    所有图解对象拥有自己的属性。例如，趋势线的颜色和薄厚度，指示器的时段信号线等等。 更多的交易者运用图解对象的常规属性，但有时需要单独设定。 要求"新建后显示属性"允许立即设定对象。可以选择对象在图表中拥有独立设置。
  • 新建后选择对象
    与指标不同，对象的画线分析，文字，光标和几何图形在图表中可以调动。 例如，趋势线精确表达位置。 这样做需选定对象。要求"新建后选择对象" 允许立即设定对象。
  • 单击鼠标选择对象
    在终端内选定图解对象单击或双击鼠标左键。 如果此项开启，单击选中全部对象。 另外，双击对象打开属性窗口。如果此选项禁止，需双击选中所有对象。
  • 灵敏度
    灵敏度是指对象离棒图的最近价位（开盘价、最高价、最低价、收盘价）有多少象素。 "灵敏度" 的像素是被限定的。 例如，如果指定的成交量为10 ，灵敏度对象离棒图的最近价位(OHLC)为10像素。 禁止此选项，需要输入数据参数为0。


?????? ??

开始使用 / 客户端设定 / 交易

交易

用来新建订单的设置集中在这个标签中。

参数的输入使定单的开始简单化，但不能改变其交易业务。

  • 默认商品
    当交易仓执行操作时在"定单"窗口 "默认商品" 选项可以自动设定商品成交量。 使用"默认商品"时，在未选中的下拉框中选择需要的商品名。用户设置初始的偏差值与此方法相同， 标志"上次使用的值"允许使用上次交易的值，反之标志"默认的偏差值"来设置永久的偏差值。
  • 默认份额
    同样的交易份额的总量是被限定的("默认份额" ): 标志"上次使用的值"允许使用上次交易的值，"默认值"是一个手动设置的常量。
  • 默认的偏差值
    商品的价位会随着定单时段而改变。若出现所准备的定单与市场的价位不协调，就会平仓。 "默认的偏差值"可以避免它的发生。 在这个区域里会给出定单的最大偏差值。如果当前价位不协调，这个程序会自行在新仓位修改定单。
  • 单击交易 — 特别条款和条件 应该被接受使用此选项。“单击交易”选项允许单击鼠标执行交易操作，不需要交易人的额外确认（没有显示 交易对话框窗口）。单击交易功能在程序端的以下部分实施：
  • 图表上的快速交易面板。
  • 交易水平 在图表上。
  • 交易命令 在图表快捷菜单。
  • “程序端”窗口中的 “交易” 标签。

使用单击交易功能的条款和条件

当第一次使用“单击交易”选项时，使用此功能的条款条件会展示给用户。

免责声明

您将要激活单击交易模式。通过点击下面的“我接受这些合同条款”，您会承认您已经阅读并理解以下合同条款，您同意特此遵守。您当前的程序端版本使您在下面的订单提交模式间选择。您同意遵守本规定的条款和条件，有关这样的模式。

1. 订单提交的默认模式是两步处理法。使用默认模式，您先调用一个新订单窗口。然后您需要选择一个合适的订单类型，它的参数并且根据您选定的具体订单类型和您的交易意愿，通过点击买入，卖出，下单，更改或关闭按钮，确认您订单的提交。使用默认模式，您的订单将直到您完成前面提到的两个步骤才会提交。

2. 订单提交的单击交易模式（“单击交易”）是一步处理法。使用单击模式，您的订单将会被提交当您：

- 单击卖(SELL)或买(BUY)价格按钮时：

- 在市场报价窗口的交易标签上时

- 图表的单击交易面板上时

- 在程序端窗口的交易标签上平仓挂单或删除止损

不会有后续确认提示您点击。一旦您点击，您将无法撤销或更改您的订单。在正常市场条件和系统性能下，提交后市场订单会立即填写并且您将会输入一个绑定交易。

您可以在程序端选项窗口的交易标签上激活或停用单击交易模式。

通过选择单击交易模式，您了解到您的订单将根据您点击卖或买价进行提交，没有后续订单确认。您同意接受与使用您选定的订单提交模式相关的全部风险，包括，但不限于，过失风险，提交订单时发生的失误。

您同意完全赔偿和使#company#在由您，您的交易经理或任何代表您进行交易的人，造成的任何错误，遗漏或失误而导致的结果引起的各种损失，成本和费用上免受损失。

如果您同意这些条件，勾选“我接受这些条款条件”选项并点击“OK”。如果您不接受这些条件，点击“取消”，则不使用“单击交易”功能。


?????? ????

开始使用 / 客户端设定 / 智能交易

智能交易

EA交易工作的设置集中在这个标签中。

智能交易 是在终端内写入MetaQuotes Language 4的一种程序语言，允许自动分析以及自动买卖(自动交易)。 相关的创建智能交易，描述和应用可以在 "自动交易" 部分查看。 在此页中设置基本智能交易系统的参数：

  • 允许自动交易 — 该选项允许启用或禁用通过EA交易 和 脚本执行交易操作。如果被禁用，脚本和EA交易可以工作，但它们不能进行交易。该限制对于在实时模式下测试EA的分析能力可以非常有用（不要混淆历史数据上EA的测试）。自动交易也能被允许或禁止使用 自动交易 按钮在工具栏上。
  • 账户更改时禁用自动交易 — 该选项代表了保护机制，当账户更改时不启用EA和脚本交易。它很有用，例如，当把模拟账户变成真实账户的时候。
  • 当个人资料已经更改时不启用自动交易 — 有关工作区所有图表当前设置的大量信息存储在个人资料里。特别是，个人资料包含了附加的EA信息。个人资料包含的EA交易当新订单号进来时将会开始工作。 启用这个选项后，当个人资料更改时，您可以通过EA启动阻碍交易。
  • 当图表交易品种或周期更改时禁用自动交易 --- 如果启用了这个选项，那么当一个图表的周期或交易品种改变时附加的EA交易，将自动禁止执行交易操作。
  • 允许导入动态连接库 (potentially dangerous, enable only for trusted applications)
    为了增加运作功能，可以运用DLLs (dynamic-links libraries). 如果此选项开启，交易时将不受任何限制。如果禁止此选项进入，没有交易可以运用外部DLLs。 当运行不清楚的智能交易系统时，建议禁止此功能。
  • 允许WebRequest用于所列URL
    MQL4的WebRequest() 函数用于使用GET和POST请求接收和发送信息到网站。要允许MQL4应用程序发送这种请求，启用该选项并手动明确指定URL的可信网站。出于安全考虑，该选项默认禁用。

注意：在该窗口指定的“允许自动交易”，“允许DLL导入（有潜在风险，只对可信的应用启用）”和“允许WebRequest用于所列URL”的值是MQL4新附加的默认参数。它们不会影响已经运行的EA，自定义指标和脚本的操作。


通知

开始使用 / 客户端设定 / 通知

通知

客户端支持使用推送通知功能，发送各种事件的通知到iOS 和 Android 系统的移动设备。通过此项功能，交易人可以跟踪全部更新。

推送通知是最多255字符的短消息。这样的通知立即送达，并决不会丢失。

从客户端发送推送通知的方式有两种：

通过MQL4应用程序

MQL4的语言提供一种特殊的SendNotification功能，它允许MQL5程序发送推送通知到程序端设置中指定的一个MetaQuotes ID 。

通过信号功能

客户端允许您创建信号，来提醒您在市场上的事件。该功能可以在程序端窗口的 信号标签中找到。事件通知类型之一就是推送通知。

  • 推送通知也被用来获取MQL5.community网站上的更新信息。为此，要在“联系”标签的用户个人资料中，指定您的MetaQuotes ID。
  • 可以发送的信息数量有个限制：每0.5秒不要多于一条消息，每分钟不要多于10条消息。

通知设置窗口包括以下选项：

  • 启用推送通知 — 要允许客户端发送通知，则启用该选项。
  • 通知交易操作 — 如果启用该选项，客户端将会自动发送成功交易操作的通知到指定的MetaQuotes ID。有关失败操作的通知（例如，由于参数不正确订单被拒绝）不会发送。

设置选项后，输入一个或多个MetaQuotes IDs，以逗号分隔。您最多可以指定4个MetaQuotes IDs；通知将被同时发送到全部设备。

要找到您的MetaQuotes ID，打开您的移动程序端，进入设置 -> 信息。iPhone程序端的该页面如下所示：

为了测试通知发送的功能，点击测试。如果您的通知成功发送，您会看到一条相应的信息，并且通知将会到达您的移动设备。

要安装程序端的移动版本，使用下面的链接：

  • iPhone移动端
  • Android移动端


??????电子邮件

开始使用 / 客户端设定 / 电子邮件

电子邮件

在这里可以对邮箱进行设定。随后，将会应用 智能交易 或开启警报发送消息。

开始设定邮箱，必须完整填写以下内容：

  • SMTP服务器 — SMTP服务器的地址的应用和转换。 给定的服务器将用来发送信息。必须以以下格式进入"[internet address-server address] : [port number]"。例如，"email_provider_domain_name.com:25"的位置 是"email_provider_domain_name.com"服务器的地址，和"25"转换数字。
  • SMTP 登录名 — 交易服务器授权的登录名。通常情况下，是电子邮箱。例如：your_name@your_email_provider.com。
  • SMTP 密码 — 授权密码（邮箱访问密码）。
  • 来自 — 电子邮箱地址，从这里发送信息。在这个字段中，将使用SMTP的邮箱服务器上一定要有名字和邮箱地址。名字通常符合电子地址的第一部分，但名字可以省略。例如：your_name, your_name@your_email_provider.com。
  • 发送到 — 信息发送的目的地邮箱地址。地址的“您的名字”部分可以省略。一般情况，在“发送到”字段，可以指定任何真实存在的邮箱。例如：any_name, your_name@your_email_provider.com。

注意: 只可以指定一封邮件"来自" "发送到"。 一些邮件带有或不带有分离器将不被接收。

"测试"指定设置正常运行。设定后按 "确定"按钮。如果测试成功，建议检查所有设定和重新发送测试消息。


?????????

账户报告公布属性设置

在互联网中终端允许自动公开帐户状态报告。可以通过 FTP (File Transfer Protocol)设定互联网的连接参数。 可以在"公开"页中执行:

该标签提供以下参数：

  • FTP服务器 — 发送报告的FTP服务器地址。例如：ftp.your_domain_name.com。
  • FTP 端口 — FTP服务器的端口名称；按照此路径发送报告。
  • FTP 登陆 — FTP服务器的登录帐号。
  • FTP 密码 — FTP服务器的登录密码。
  • 被动模式 — 在被动和主动的模式下切换数据。
    在积极的模式下， 客户端连接到网络传送数据时将被将分配到空闲端口(动态范围从1024 到65535) 应用TCP20端口将FTP服务器连接到客户端传输数据。 在被动的模式下，服务器传输TCP 端口数字到客户 (动态范围从1024 到65535) 客户可以建立数据连接。
    积极FTP模式和被动FTP模式的主要区别是开通连接的传送数据。 在积极的模式下，客户可以接受从FTP服务器连接。在被动的模式下，客户发起连接，服务器接收。
  • 允许 — 允许公开报告。如果禁止，其他页不受影响。
  • 账户 — 账户的数字允许公开。
  • 更新 — 按周期发送报告到网络服务器(每分)。

注意: 账户的报告可以公开。如果账户数字在此也中与当前的相符，报告将不会公开。

"测试" 按钮使用上述设置发送一个账户报告，验证以上设置。 如果成功测试后，按 "确定"键即可执行以上设置。如果测试失败，建议检查设置并重新检验。

客户端默认发布常规报告。若要发布详细报告，您应该重命名位于/TEMPLATES目录的"StatementDetailed.htm"文件为"Statement.htm"。


?????? ??

开始使用 / 客户端设定 / 提醒

提醒

可以在终端内设定提醒系统信号(不能与 警报混淆)。 这是一个非常便利的工具，随时传达终端状态的变换信息。 设定信号，可以使用"开启" 选项 另外，系统事件的列表与相应的动作连接。

系统事件包括：

  • 连接 — 连接服务器。成功连接服务器的信号。
  • 断开连接 — 断开服务器。断开服务器的信号。
  • 邮件通知 — 收到电子邮件。如果信号已开启，建议检验 "终端 — 邮箱"窗口。
  • 超时 — 交易超时或遇到错误。
  • OK — 交易业务成功执行。在当前交易执行过程中没有错误发生。
  • 新闻 — 收到新闻。 如果信号已开启，建议检验 "终端—新闻" 窗口。
  • EA交易 — 当智能交易交易业务执行时开启信号。
  • 警告 — 智能交易系统进行报警。
  • 重新报价 — 在交易业务准备过程中改变价位。
  • 追踪止损 — 开启停止追踪。

如果没有运行信号，需要在同名图表处双击鼠标左键。信号开启后，相应的提醒信息会运行。在文件同名处双击可以改变文件。 双击后可以显现提醒文件列表。选中任意文件按Enter键，相应信息会显现。确认改变模式按"确定"键即可。

注意:事实上业务系统中的任何文件都会分配在提醒页中。


Community

开始使用 / 客户端设定 / Community

Community

MQL5.community 提供独特的服务给交易人和MQL4/MQL5开发者，包括订阅专业交易人提供的交易信号 的可能性。

指定您的MQL5.community账户来订阅交易信号：

  • 登录名 —您的MQL5.community账户。
  • 密码 — 指定账户的密码。
  • 密码以加密的形式保存在硬盘上。
  • 如果您没有MQL5.community账户，请注册并获得独一无二的机会。

"注册" 链接打开MQL5.community的账户快速注册的窗口。

在该窗口指定您账户所需的登录名和电子邮件地址。"注册"一旦点击，则账户即被创建并且包含账户密码的信息将会发送到指定的邮箱。


信号

开始使用 / 客户端设定 / 信号

信号

使用此选项配置“信号”服务在客户端。

信号服务是交易程序端与MQL5.community 网站集成的部分。它允许任意人成为供应商，出售交易信号或提交给它们，和遵循一个有经验的交易人的策略。

任何交易人都可以订阅另一个有经验的交易人的信号（供应商）来复制他或她的交易操作。

找出更多的服务在 信号 部分。

您当前订阅 的信号名称显示在该标签的顶部。如果没有订阅，下面设置不可编辑。

  • 同意使用信号服务的条款 — 同意开始使用服务的条款。请仔细阅读规则。如果您同意，请勾选选项旁边的方框。如果您不同意规则，请不要使用信号服务。
  • 启用实时信号订阅 — 只在该选项启用后，交易操作才将被复制到您的账户。 如果禁用此选项，没有操作可以复制到账户。只有启用该选项，下面设置才可以编辑。
  • 复制止损和获利水平 — 置于供应商账户的止损 和获利 也将置于您的交易账户上，如果启用该选项。这些订单以交易商身份实施。它意味着无论客户端是否启动，它们都可以实施。此外，实施可以在完全不同的经纪公司进行（如果订阅人和供应商有不同的交易商）。
    因此，这会保证当复制止损订单时进行平仓，如果到达指定损益水平的情况下。
  • 无确认的同步持仓 — 没有确认请求的自动同步。当订阅信号时，订阅人和供应商的账户的交易状态是周期性 同步 的。这可以成为一个激活订阅时的初始同步或检测到订阅人和供应商账户之间有差异时的定期同步。
    如果同步过程中在订阅人帐户检测到挂单或无信号持仓(手动或通过EA交易打开)，会显示提供平仓和删除订单的对话框。如果同步过程中在供应商账户检测到获利持仓，而订阅人账户却没有（例如，由于网络连接丢失或程序端关闭），那么请求确认复制此持仓的对话框会展示给用户。在这两种情况下，不会执行同步化并且会停止信号复制直到用户点击相应的对话框按钮作出决定。
    如果程序端没有持续的外部控制而昼夜不停地工作（例如，在VPS启动程序端），执行同步的手动确认请求则无应答并且因此可以防止信号被复制。当启用该选项时，同步总是自动执行而不需要订阅人的确认。< / t7 >
  • 使用不超过[A] % — 您入金的百分比值，可以用于下面供应商的信号。例如，如果您的结余是10 000 USD，这里指定90%，那么9 000 USD将用于下面的信号。当遵循信号时，这会影响进行交易的交易量的计算。交易量按比例计算。见“信号订阅人” 部分获取更多信息。
  • 如果净值少于[B]停止 — 该参数允许您限制损失，当使用交易信号时。如果净值低于指定水平，将会自动终止交易信号的复制，全部平仓和移除所有挂单。0 表示没有限制。
  • 偏差/滑移[C]点差 — 此设置类似于偏差设置当从程序端下单 时。这是当复制交易操作时，来自客户端请求初始价的已实施订单价的允许偏差值。该值的显示，作为交易操作中使用的交易品种的当前点差的一部分。
    如果偏差小于或等于指定参数，则该订单被执行。如果偏差超过规定值时，那么程序端将增加0.5点差可接受的偏差，并再次尝试执行交易操作。如果再次收到重新报价，那么订阅人和供应商的账户将变得不同步。之后，程序端将会尝试再次同步。


????

开始使用 / 使用界面

使用界面

用户终端界面包括以下几个部分：

  • 主窗口标题
    软件的标题栏显示当前的帐号，软件名称和当前激活的图表窗口的标题及其分析周期（时间段）。
  • 主菜单
    主菜单包含用户终端能操作的所有指令和功能。主菜单包含以下几个模块： "文件", "查看", "插入", "图表", "工具", "Window", "Help".
    更加详细的信息请查看"主菜单"部分。
  • 工具栏
    终端软件包含四种类型的工具栏： "常规", "图表", "画线分析",和 "属性"。 这些工具栏与主菜单中的一些指令和功能相同，然而，这些工具栏是可以灵活调整，这些功能在操作过程中会频繁使用。
    更加详细的信息请查看 "工具"部分。
  • 市场报价
    这个窗口显示金融品种。这个窗口的指令能够操作交易头寸和图表。
    更加详细的信息请查看"市场报价" 部分。
  • 市场深度
    市场深度表示交易品种的当前市场。该工具提供快速轻松订单管理的可能性。
    更多信息可以找到在 “市场深度”部分。
  • 数据窗口
    这个窗口显示报价数据，技术分析指标和交易系统的数值。这是一个信息窗口不提供其他的操作。
    更加详细的信息请查看"数据窗口"部分。
  • 导航
    导航窗口包括帐户，技术指标，智能交易系统，自定义指标和脚本，"导航"窗口能够帮助快速的管理这些对象。
    更加详细的信息请查看 "导航"部分。
  • 终端
    终端窗口是一个多功能窗口，包含新闻，帐户历史，警报，邮箱，日志。此外， 终端窗口还可以帮助我们去打开和修改不同的定单和管理交易头寸。
    更加详细的信息请查看"终端"部分。
  • Tester
    智能交易的测试窗口。可以测试或查看多样的报道，交易参数。
    更加详细的信息请查看"测试"部分。
  • 报价图表
    报价图表是数据分析的基础。除了动态的报价以外，图表包含不同类型的分析方法：画线分析， 技术分析和用户自定义指标，文字标签和图形对象。
    更加详细的信息请查看 "工作图表"部分。
  • 状态栏
    终端上的状态栏显示额外的信息。状态栏中有一个指示器显示连接服务器的状态，同时显示当前的模板和图表夹 名字及命令提示和报价数值。
  • 快速导航
    通过热键，快捷键和快速导航线能够快速操作终端软件。这些键能够非常高效的执行不同的程序指令， 并且快速导航线能够沿着时间轴精确地移动图表，去改变图表分析周期。这些和它们的指令操作是相同的。
    更加详细的信息请查看 "快速导航"


????????

开始使用 / 使用界面 / 主菜单

主菜单

终端软件的主菜单在主窗口标题下面，含有一系列子菜单。

主菜单包含用户终端能操作的所有指令和功能 主菜单由以下部分组成:

  • 文件
    管理图表，打印，历史数据储存和数据图表储存。
  • 查看
    工具属性，窗口管理 ("市场报价", "数据窗口", "导航", "终端", "测试")和程序语言界面。
  • 插入
    管理终端指示器，曲线研究和其他对象。
  • 图表
    显示柱状属性，比例，图表属性，网格，对象管理。
  • 工具
    客户终端，历史数据中心，综合变量和 MetaEditor (MetaQuotes Language 4 editor)属性。
  • 窗口
    打开窗口的列表和当前位置。
  • 帮助
    有关程序的信息和指南。


??????

开始使用 / 使用界面 / 主菜单 / 文件

文件

管理图表，打印，历史数据储存和数据图表储存。

由以下部分组成:

  • 新图表 — 打开金融品种的图表窗口。此指令会列出可提供金融品种的列表。 可以从列表中选中一个金融品种打开一个新的图表窗口。
    可以使用 新图表 "常规" 工具。
  • 打开历史离线数据 — 打开离线的图表。这个指令能够选择所需的存放历史数据的文件。这种模式下， 最新的报价没有保存在历史文件中；打开离线图表有益于 智能交易测试。
  • 打开删除 — 还原删除图表。 删除图表能够被还原如果保存到"保存删除的图表便于再次打开" 在终端设定内打开。所有删除图表保存在 /DELETED 文件夹。
  • 数据图表 — 打开管理数据图表的子目录。数据图表可以在子目录中保存或删除。下载后被当即保存。
    可以使用"常规" 工具 配置文件管理的调用菜单 操作。
    更多细节查看 "数据图表和模板" 窗口。
  • 关闭 — 关闭当前图表。
  • 保存为 — 以"CSV", "PRN",或"HTM" 格式保存历史数据。
  • 保存为图片 — 以"BMP" 或"GIF"格式保存。
    在图表窗口执行，功能相同。
  • 开设模拟帐户 — 开设一个新模拟帐户。 开设模拟账户无需任何资金担保，测试交易系统。
    开设账户需执行选择 "导航—账户" 窗口或按插入键。
  • Login to Trade Account — 认证身份。 连接终端到服务器上，选中账户。成功验明身份后。报价和新闻会自动输入，能够自动交易。
    认证身份可以 "登陆"窗口 "导航—账户"窗口或双击账户名。
  • 登录MQL5.community — 打开交易平台的设置 登录到 MQL5.community并获取其他服务。
  • 打印设置 — 打印参数简要设置； —打印服务，纸张尺寸和简介。
  • 打印预览 — 打印图表之前预览。
    可以使用 Chart Preview "常规" 工具操作或在图表中执行，功能相同。
  • 打印 — 打印图表。如果"彩色打印"选择开启程序， 图表将会以彩色模式打印出。
    可以使用 Chart Print "常规" 工具, 快捷键Ctrl+P执行或在图表中点击 "打印"
  • 退出 — 退出用户端软件。

注意: 如果终端被关闭， 智能交易和 追踪停止将不会执行。


??????

开始使用 / 使用界面 / 主菜单 / 查看

查看

执行管理品种窗口，工具条，程序语言界面。

可以使用 "常规" 工具操作。 包含以下功能：

  • 语言 — 通过子菜单控制用户端显示的语言。当程序重启后语言转换才能生效。
  • 工具栏 — 控制子菜单来决定显示的工具栏。 在窗口中安装的工具栏前被标记。
    "定制" 指令能够让用户自定义工具栏； "插入" 和"删除"允许添加和删除； "上翻" 和 "下翻" 改变现有位置。 复位工具栏需按 "复位"按钮。
  • 状态栏 — 打开/关闭终端窗口下面的状态栏。这个数据栏包括(从左到右): 菜单管理数据图表, 所选的时间，所选价位和收入/开支的总量。 按当前图表的名称即可开启管理 数据图表。 下载后可以立即贮存，也可以在这个菜单中删除。
    也可以使用"文件— 数据图表" 目录 执行。
  • 图表工具栏 — 打开/关闭在图表工作区下面的状态栏。
  • 市场参考报价 — 打开/关闭当前公开报价窗口"市场报价" .
    可以选择按Ctrl+M 或使用 Market Watch "常规" 工具。
  • 数据窗口 — 打开/关闭"数据窗口"。 在这个窗口内价位和相关知识其德信息是被公开的。
    可以选择按Ctrl+D 或使用 Data Window "常规"工具.
  • 导航 — 打开/关闭"导航"窗口。 在这个窗口内可以知道开启账户列表，技术指示器， 交易，客户指示器和脚本的方位。
    可以选择按Ctrl+N或使用 导航 "常规" 工具。
  • 终端 — 打开/关闭"终端" 窗口。在这个窗口可以管理定单和品种， 查阅帐户历史，新闻，邮件，和智能交易的日志。
    可以选择按Ctrl+T 或使用 Terminal "常规" 工具。
  • 测试战略 — 打开/关闭 "测试" 窗口。 这个窗口是对智能交易的测试和利用
    可以选择按Ctrl+R 或使用 策略测试器 "常规"工具。
  • 全屏 — 打开/关闭全屏模式。 在全屏模式下工具栏，状态栏和所有服务窗口都将关闭，屏幕中只显示用户终端主窗口标题、主菜单、图表工作区和图表窗口的标签。 在重复操作此指令，则屏幕回到原来的状态。
    可以选择按F11或使用 Full Screen "常规" 工具。


??? ? ??

开始使用 / 使用界面 / 主菜单 / 插入

插入目录

利用"插入"目录将其对象收入图表内。

目录包含曲线分析 和 技术指示器, 图形对象是指能够使用几何图形、箭头和文本对图表进行解释说明。 所有画线分析分组在各自的子菜单中："线"—不同类型的线型，"通道"—不同的通道， "江恩"—江恩工具，"斐波纳奇"—基于斐波纳奇线的多种工具。此外，"安德鲁分叉线" 和"循环周期线"不属于任何一组，被放在列表的最下面。更加详细的信息请查看"画线分析"部分。

另外，图形部分包括：

  • 图形 — 使用几何体（矩形、三角形、椭圆形）在报价图表中标明不同的区域。
  • 箭头 — 使用符号（箭头、测试和停止符号）在报价图表中突出标明重要的事件。
  • 文字 — 文字用于在图表中进行注释。它会随着图表而滚动。
  • 文字标记 — 文字标记被附加在另一窗口，不存在于图表中。图表滚动时，文字标记将不会移动。

注意: 执行"插入" 目录，除管理指示器的子目录，存在于 "曲线分析" 工具条.


??? ? ??

图表目录

执行管理图表，利用技术指示器收集到"图表" 目录。

由以下部分组成:

  • 指示器列表 — 利用指示器管理已激活的窗口。完整的指示器列表 (包括客户指示器) 显示在窗口内。可以选择从图表中删除。
    相同功能可以在同名菜单执行或按Ctrl+I。
  • 对象 — 利用子菜单管理对象。 以下是可运用的子菜单:
  • 对象列表 — 对象监控窗口。对象包括曲线研究，品种，形状和相关文章。 所选对象能够修改("编辑" 按钮) 或删除。 另外， "显示"移动图表到可利用位置。
  • 删除最近对象 — 在图表窗口删除最近的对象
    也可以按Backspace键进行同样的操作。
  • 删除选中对象 — 在图表窗口删除所有选中的对象
    也可以按Delete键进行同样的操作。
  • 删除所有符号 — 在图表窗口删除所有的对象
  • 未选对象 — 在图表窗口利用未选对象。
  • 还原 — 还原删除对象。
    也可以按Ctrl+Z键进行同样的操作。
  • 柱状图 — 显示柱状图，也叫竹线图或美国线。
    也可以使用 柱状图 "图表" 中工具条 或快捷键Alt+1。
  • 阴阳烛 — 显示日本"蜡烛图"。
    也可以使用 蜡烛图 "图表" 中工具条或按快捷键Alt+2。
  • 折线图 — 显示用收盘价连接在一起的曲线。
    可以使用 线型图 "图表"中工具条 或按快捷键 Alt+3。
  • 图表前置 — 使图表"前置". 如果这个功能被激活，那么所有分析对象 (技术指示器和图解对象) 放置；"在图表的后面"。
  • 时段 — 图表的时间周期。
    时间周期可以改变通过工具条的"时段" 。
  • 模板 — 显示模板控制菜单。"保存模板"指令能够将当前激活的图表窗口保存为模板， "删除模板"—删除以前保存的模板。
    更多相关信息查看"数据图表和模板"。
    控制模板可以使用 Profiles 工具条 "图表" 或选择 图表控制。

注意:DEFAULT模板不能删除。
  • 刷新 — 重新更新历史价格数据。既然这样，在可提供的历史数据范围之内将更新所有丢失的数据。 也可以在图表窗口的右键菜单使用同样的指令操作。

注意:存在于历史界限以外的数据不能添加。
  • 网格 — 显示/隐藏图表窗口的网格。
    能够在图表控制 中执行或按快捷键Ctrl+G。
  • 成交量 — 显示/隐藏图表中的成交量。
    能够在图表控制执行 或按快捷键Ctrl+L。
  • 自动滚动 — 在新的价位到来时，启动/关闭图表自动向左滚动。
    也可以使用"图表"中工具条 [image] 。
  • 图表平移 — 从窗口左部边缘平移到图表中。可以应用鼠标平移图表到10 到50%窗口大小中。
    可以使用 "图表" 中工具条 “图表平移”功能 。
  • 放大 — 放大图表。
    可以使用"+"键或 "图表" 中工具条 放大 操作，或者按住鼠标左键，沿着水平轴向右移动光标指针。
  • 缩小 — 缩小图表。
    可以使用"-" 键或"图表"中工具条 缩小 操作，或者按住鼠标左键， 沿着水平轴向左移动光标指针。
  • 步长 — 每次向左移动一格图表。
    也可以按F12进行同样的操作。
  • 属性 — 显示图表属性窗口。 可以在 图表设置窗口显示。
    也可以按热键F8进行同样的操作。

注意: 大多数"图表"在 工具条 中存在副本，查看 图表控制。


???? ??

工具目录

命令管理和终端设置收在"工具" 目录里。

包括以下:

  • 新定单 — 显示新定单的窗口。 更多细节可以查看定单窗口。
    "定单"窗口可以在"市场报价"和 "终端 — 交易"窗口显示，用鼠标双击"市场报价" 窗口， 按 F9或按 新订单 "常规" 工具操作。
  • 历史数据中心 — 显示历史数据控制窗口。扩展名为"HST"的存档文件包含了显示在图表中的金融品种的数据，能够进行编辑。
    这个窗口也能通过热键F2显示 。
  • 综合变量 — 在激活的图表窗口中显示智能交易系统的全局变量窗口； 通常情况下综合变量是对 智能交易，客户指示器，和 脚本而言。更多相关细节查看同名文件。
    这个窗口也能通过热键F3显示 。
  • MQ语言编辑器 — 打开智能交易的MetaEditor 。应用MetaEditor， 可以创建和编辑 交易， 客户指示器和脚本。 更多运用MetaEditor细节查看 同名文件。
    MetaEditor窗口也能通过热键F3显示 。
  • 选项 — 显示用户终端设定. 在这个窗口中用户可以自定义连接、交易过程、图表、智能交易系统等的参数。 详细信息查看 "用户终端设定" 。
    选项窗口可以按Ctrl+O显示。


??????

开始使用 / 使用界面 / 主菜单 / 窗口

窗口目录

对图表窗口进行管理。

在工作空间内安排图表，可以从这里选择或开启新图表：

  • 新窗口 — 创建一个新窗口。 打开金融品种的图表窗口。
    打开新窗口可以按 新图表 "常规" 工具 或选择 "文件— 新图表" 目录。
  • 平铺窗口 - 平铺排列图表窗口。同样的动作可以通过按下Alt + R组合键来执行；
  • 层叠 — 设置图表为层叠。
  • 平铺 — 平铺图表窗口。
  • 纵列 — 纵向安排图表窗口。
  • 排列图标 — 在最小化窗口排列图标。

在这个菜单的底线列出所有打开的图表窗口。当前激活的窗口被选中。


??????

开始使用 / 使用界面 / 主菜单 / 帮助

帮助目录

"帮助"目录是辅助的。

在这里操作不会影响到终端内的任何业务。 由以下部分组成：

  • 帮助目录 — 显示帮助主题"使用界面"所有客户端的特性，功能和相关描述都会显示。
    按F1可以执行。
  • 技术分析 — 转到MQL4.community描述技术分析。
  • 自动交易锦标赛 — 转到自动交易锦标赛网站。
  • 移动交易 — 打开子菜单链接到下载移动程序端 iOS 和 Android 设备。
  • MQL4.community — 打开链接子菜单连接社区网站 MQL4 程序开发人员： “书籍”，“文档”， “文章”，“代码库”，“工作”，“论坛”，“市场” 和 “信号”。
  • MQL5.Community — 打开链接子菜单链接社区网站 MQL5 程序开发人员：“文档”，“文章”，“代码库”，“工作”，“论坛”， “市场” 和“信号”。
  • 关于 — 打开"关于"窗口，可以找到相关信息，它的相关细节和终端版本。


????? ???

开始使用 / 使用界面 / 工具条

工具条

是一个可调的窗口，放置了一套经常被使用命令的固定键。软件终端中包括4种工具条。 所有的工具条都是浮动窗 口，能够放置在终端工作区的任何地方。通常情况下，工具条放置在主菜单的下面。主菜单命令 "查看— 工具条" 能够显示/隐藏工具条。为了设置工具条，可以使用各自工具条右键菜单中的"定制"命令来操作。

按照功能分为以下部分:

  • 常规 — 常规的终端管理。
  • 图表 — 对图表进行管理。
  • 曲线研究 — 对图表中的曲线管理。
  • 时间周期 — 管理图表的时间周期。


??? ???

开始使用 / 使用界面 / 工具条 / 常规

常规工具条

常规工具条管理终端内的内容如下：

  • 新图表 — 打开金融品种的图表。 Th这个命令打开金融品种列表，选择需要的品种打开一个新的窗口。
    可以在"文件 — 新图表" 和 "窗口—新窗口" 中进行操作， 或者是 "市场报价—图表窗口" 执行。
  • Profiles — 图表夹控制菜单。 运行图表夹也可以执行主菜单命令文件—图表夹。详细的信息请查看" 模板和图表夹" 部分。
    使用模板，可以使用"文件— 模板" 操作。

注意: DEFAULT 模板不能删除。
  • "Market Watch" window — 打开/关闭 "市场报价" 窗口。所有商品报价被公布于此。窗口可以打开商品图表和放置定单。 更多相关细节请查看 "市场报价" 部分。
    可以使用 "查看 — 市场报价" 操作或按快捷键Ctrl+M打开/关闭窗口。
  • "Market Watch" window — 打开/关闭 "数据"窗口。有关价格和指标的信息被公布这个窗口内。更多相关细节可以查看 "数据窗口" 部分。
    可以使用"查看 —数据窗口" 操作或按快捷键Ctrl+D打开/关闭窗口。
  • "Navigator" window —打开/关闭 "导航"窗口。所有开账户，可用交易，技术指标和脚本都被放置于此。更多相关细节请查看 "导航"部分。
    可以使用"查看 —导航" 操作或按快捷键Ctrl+N 打开/关闭窗口。
  • “程序端”窗口 —打开/关闭 "终端"窗口。在这个窗口内放置交易定单，查看历史账户，事实新闻和其他。 更多相关细节请查看 " 终端"部分。
    可以使用"查看 —终端" 操作或按快捷键Ctrl+T打开/关闭窗口。
  • "Tester" window —打开/关闭 "测试"窗口。这是智能交易测试和优化的窗口。更多相关细节请查看 "策略测试" 部分。
    可以使用"查看 —策略测试"操作或按快捷键Ctrl+R打开/关闭窗口。
  • 新订单 — 显示新定单窗口。 打开这个窗口可以设置市场定单，止损，获利和挂单交易的参数。More details can be found in the "Trading" section。

这个窗口也能通过主菜单 "工具 —新定单" 打开，或者在“市场报价”窗口右键菜单" 市场报价 — 新定单" 窗口或终端窗口交易”标签的右键菜单 "终端 —交易 —新定单" 窗口 ，或者使用快捷键F9 。

  • MetaEditor — 启动MetaEditor 。IDE修改 智能交易系统的源代码 客户指标， 脚本和 MQL4 资料库。 更加详细的信息请查看 "MetaEditor" 部分。 同样可以使用主菜单命令"工具 — MetaQuotes语言编辑器"和快捷键F4完成同样操作。
  • Enable/disable expert advisors — 启用/禁用通过 EA交易 和 脚本执行交易操作。该按钮的功能类似于 “EA交易” 标签中的选项。
  • Terminal Settings — 显示终端设定窗口。包含所有终端内的基本设置。 更多相关细节请查看客户端设定部分同样可以使用主菜单命令 "工具 — 选项"或快捷键Ctrl＋O完成同样的操作。
  • Full screen mode — 打开/关闭全屏模式。当打开全屏模式时，工具条和状态栏隐藏，所有服务窗口关闭。 客户端名称，主菜单，工作界面（图表）和图表标签窗口会在屏幕中保持原位。 反复执行这个命令会导致返回初始状态。
    可以按快捷键F11或可以使用 "查看—全屏"操作。
  • Chart Print — 打印图表。如果在 程序设定中"彩色打印"被开启， 图表会以彩色形式打开。
    可以使用"文件 —打印"操作或 背景目录操作，功效相同。
  • 打印预览 — 打印图表预览。由于，为了确保打印出的图表数据完整。可以预先查看。
    可以使用"文件 —打印预览" 或背景目录操作，功效相同。
  • 帮助 — 显示帮助主题。 在窗口使用界面内点击需要帮助文件，即可显示相应信息。
    也可以使用"帮助 —帮助主题" 操作或按快捷键 F1。


??????

开始使用 / 使用界面 / 工具条 / 图表

图表工具条

图表和技术指标的命令管理。包括以下内容：

  • 柱状图 — 显示图表为柱状图（或转换图表为柱状图）。
    同样可以使用主菜单命令 "图表 —柱状图" 完成同样的操作或按快捷键Alt+1。
  • 蜡烛图 — 显示图表为日本阴阳烛图（或转换图表为日本阴阳烛图）。
    同样可以使用主菜单命令"图表 —阴阳柱" 完成同样的操作或Alt+2。
  • 线型图 — 显示图表为折线图（或转换图表为折线图）。
    同样可以使用主菜单命令"图表 —折线图"完成同样的操作或Alt+3。
  • 放大 — 大图表窗口范围 。
    同样可以使用主菜单命令"图表—放大" 或图表右键窗口中的图表背景菜单完成同样的操作或按"+" 键。
  • 缩小 — 缩小图表窗口范围。
    同样可以使用主菜单命令 " 图表—缩小" 或图表右键窗口中的 图表背景菜单完成同样的操作或按"-"键。
  • Tile Windows — arrange chart windows as a tile.
    The same action can be performed by the "Window — Tile Windows" menu command or by pressing "Alt+R" key combination;
  • Auto Scroll — 自动移动最新的棒图。
    同样可以使用主菜单命令 "图表— 自动滚动" 完成同样的操作。
  • Chart Shift — 从图表窗口的右边移动最新的棒图 。图表可以应用鼠标平移窗口10 到50% 。
    同样可以使用主菜单命令"图表— 图表平移" 完成同样的操作。
  • 指标 — 显示技术指标控制窗口。所有技术指标在这里分组。 更加详细的信息请查看"技术指标"部分。
    同样的活动可以应用 "插入 —指标" 操作。
  • 周期 — 更改图表周期的子菜单。当在子菜单选定一个周期时，在活动图表中将出现相应的改变。。
    图表周期的切换可以通过 "图表 - 周期" 菜单 命令，相应的图表快捷菜单 命令，或 "周期" 工具栏的相应按钮来执行。
  • Template — 显示模板控制子菜单。同样可以使用主菜单命令 "图表 — 模板" 或图表窗口右键菜单 中的相同命令完成同样的操作； 更加详细的信息请查看" 模板和图表夹" 部分。

注意: "图表"工具条的命令更多被公布在 图表目录中和图表控制。


??? ?????

开始使用 / 使用界面 / 工具条 / 画线分析

画线分析工具条

画线分析 工具条由一些用于分析目的的画线分析工具组成，同时也包含一些在图表中使用的几何图形、 符号和文本这样的图形对象。工具条中的这些命令（除了"十字星线"和"标准光标"） 同样出现在"插入"菜单中 。画线分析的操作在 画线分析部分各自部分详细的描述。 其他的工具条用来图形对象的操作和改变光标的模式：

  • Ellipse —画一个椭圆形 。 在图表中图形可以帮助选择多种范围。 更多相关部分请查看 图解对象部分。
    在"插入 —图形—椭圆形"可以进行操作。
  • Triangle — 画一个三角形。 在图表中图形可以帮助选择多种范围。 更多相关部分请查看 图解对象部分。
    在"插入 — 图形—三角形"可以进行操作。
  • Rectangle —画一个长方形。 在图表中图形可以帮助选择多种范围。 更多相关部分请查看 图解对象部分。
    在 "插入— 图形—长方形" 可以进行操作。
  • Text Label — 增加一个文本标记。 按增加键后，新增的文本会放置到图表窗口内。与文本的描述不同，不添加在图表内，而是添加到图表窗口内。 当图表滚动时，文本标签不会移动。
    在"插入 —文本标记" 可以添加执行。
  • Text —增加一个文本的描述。 帮助直观了解图表。当图表滚动时，相关的文本也会同时移动。.
    在"插入 —文本" 可以执行操作。
  • Symbols — 显示图表箭头的子菜单。 这个子菜单能够在图表窗口中增加各种箭头和删除所有箭头。
    在"插入 — 箭头" 可以操作执行。
  • Crosshair — 十字星线。在这种光标模式下， 能够在图表窗口或技术分析窗口显示被选中点相对应的内容。此光标只有在图表区域（工作区域）才有效。 以以下形态显现[amount of bars between two points] / [amount of points between two points] / [the current price value in the second point]。 这个工具被称作电动直尺。
    可以按快捷键Ctrl+F或鼠标的第三键操作执行。
  • Cursor —标准模式（选择模式）。 这种模式下，光标在图表窗口能够选择不同的对象。


????????

开始使用 / 使用界面 / 工具条 / 时间周期

时间周期工具条

在激活的图表窗口按工具条对应的时间周期按钮，能够改变图表的时间周期。


?????????

开始使用 / 使用界面 / 市场报价

市场报价窗口

在"市场报价"窗口区域按鼠标右键，则显示出右键菜单。

"显示所有商品"命令可以显示所有可提供的品种列表。 在抬头"买价""卖价""日期"中显示的报价开始从这些品种接收过来。"市场报价" 按Ctrl+M键打开/关闭或者使用"查看—市场报价"目录执行， 或者选择 从“标准”工具栏打开“市场报价”窗口 "常规"工具。

这个窗口可以分类市场和待定定单，打开新图表。 在"市场报价"窗口区域按鼠标右键，则显示出右键菜单。能够显示以下部分：

  • 新定单 — 打开"新定单"在窗口内可以把待定定单放置到窗口内。 准备定单，可以指定止损和赢利 的水平位。 详细信息查看 "交易寸头"。
    "新定单"窗口可以在"市场报价"窗口双击 "工具 — 新定单" 目录显示，也可以使用 "终端 — 交易—新定单" 窗口执行，或选择 新订单 "常规" 工具，或按快捷键F9。
  • 图表窗口 — 打开所选窗口。详细信息查看 同名文件。
    可以使用 "文件 —新图表" 打开和 "窗口—新窗口" 操作 ， 或者按 新图表 "常规"工具。
  • 核对图表 — 打开所选核对图表。与常规图表不同，核对图表被直接锁定在 "市场报价"窗口。核对图表可以选择在同名图表内查看。
  • 隐藏 —从列表中删除（隐藏）商品。 减少交易，建议在交易窗口隐藏不可用的保证金或者按删除。

注意: 如果对于商品的交易寸头 或 待定定单， 或它的图表处于开启状态，商品不能被删除。
  • 隐藏全部 — 删除列表中所有商品。
  • 显示全部 — 显示所有可用保证金列表。
  • 商品 — 显示所有可用商品列表。 商品依据它们的类型分组。 在"显示商品"可以添加商品，在"隐藏商品" —窗口可以删除它。 在"属性"窗口可以查看商品参数。
  • 设定 — 打开管理商品的子菜单。当前商品设定会保存在这个窗口内。 对于不同类型商品的管理比较方便。
  • 最高/最低成交量 — 在报价处显示添加每日价位最高和最低的成交量。
  • 时间 — 显示报价时间。
  • 自动排放 —当窗口大小发生改变时自动排放文字。
    也可以按A开启。
  • 网格 — 显示/隐藏网格分离的文字。
    按 G 可以显示网格。
  • 价格线图 — 打开一个添加的交易窗口。这个窗口中的商品列表与 "市场报价"窗口相同。这意味着在 "市场报价" 窗口改变商品列表将不会影响 "价格线图s"。 它是一个信息窗口，但交易也可以在这里执行。需要在要求保证金上双击鼠标左键。可以执行设置显示数据参数，开启全屏模式， 锁定窗口等等。


市场深度

开始使用 / 使用界面 / 市场深度

市场深度

市场深度展示交易品种的当前市场。该工具提供快速轻松订单管理的可能性。

要打开金融工具的市场深度窗口，要点击“ 市场深度 市场深度”在市场报价的快捷菜单。

价位列表

价位列表占据着DOM的主要部分。上边（红色部分）显示买价，而下面（蓝色部分） 显示卖价。最佳市场深度价格就是交易品种的当前卖价和买价。考虑到交易品种的止损级别，下一级别就是设置为允许下买入限价和卖出限价订单的最接近级别。进一步级别根据交易品种的价格步伐而设置。

交易栏展示交易人当前的交易请求和止损水平 (止损 或 获利)。例如：

  • BL 10 — 10手买入限价订单；
  • SL 5 — 5手卖出限价订单；
  • BS 1 — 1手买入止损订单；
  • SS 3 — 3手卖出止损订单；
  • sl 1 — 1手止损水平；
  • tp 2 — 2手获利水平；

交易命令

交易人可以发送市价单和挂单。

挂单

下挂单的按钮位于交易栏的右侧。随着按下按钮的价格下单。

  • 设置买入限价/买入止损 — 如果在卖价区按下按钮，会以指定价格下买入限价订单；如果在买价区按键，将会下买入止损订单；
  • 设置卖出限价/卖出止损 — 如果该按钮在买价区按下，将会下指定价格的卖出限价订单；如果在卖价区按键，将会下卖出止损订单。

交易设置

DOM的下部包括交易操作设置：

  • sl — 用于设置下限价订单的止损水平。从当前价格点指定该参数；
  • vol — 创建市场交易量和限价订单手数；
  • tp — 用于设置下限价订单的获利水平。从当前价格点指定该参数；

市价单

市价单命令位于下面：

  • 卖出 — 在最合适的价格根据“vol”字段指定的大小，做卖出交易；
  • 关闭 — 只有在选定金融工具有持仓时才会启用该按钮。它允许您在最合适的价格关闭整个持仓。
  • 买入 — 在最合适的价格根据“vol”字段指定的大小，做买入交易。

快捷菜单

市场深度有自动匹配的快捷菜单。命令的设置根据调用的地方而不同。

  • 买入限价/卖出限价 — 在调用上下文菜单的价格点，下买入限价或卖出限价订单。如果您打开卖出区的菜单，菜单会显示卖出限价命令，在买入区，它会显示买入限价命令。
  • 卖出止损/买入止损 — 在调用上下文菜单的价格点，下卖出止损或买入止损订单。如果您打开卖出区的菜单，菜单会显示买入止损命令，在买入区，它会显示卖出止损命令。
  • 获利 — 如果用户有一个选定交易品种的持仓并且设置了那个持仓的赢利，则会出现这个命令。使用该命令，赢利会移动到命令调用的价格。
  • 止损 — 如果用户有一个选定交易品种的持仓并且设置了那个持仓的止损，则会出现这个命令。使用该命令，止损会移动到命令调用的价格。
  • 警告 — 为选定价格创建一个警告 。如果在卖出区调用上下文菜单，会创建“买价>选定价格”警告，在买入区，创建“卖价<选定价格”警告。市场深度创建的警告会自动设置一小时 截止 。

如果在限价订单，止损或获利行，打开快捷菜单，会出现额外的命令：

  • 修改 — 打开选定订单的修改窗口；
  • 删除/取消 — 取消选定订单。


快速交易

开始使用 / 使用界面 / 市场深度 / 快速交易

来自市场深度的快速交易

市场深度允许用户快速管理止损水平（止损和获利）以及持仓的挂单。为此，在客户端设置中启用"单击交易" 。交易请求从市场深度即时发送，而不显示交易对话框。

移动停止水平

持仓的停止水平展示在交易栏的TP（获利）和SL（止损）。这些水平可以通过鼠标移动：

将水平移动到所需的线，来马上改变水平。

删除停止水平

停止水平可以从市场深度删除：

鼠标光标悬停在按钮上 设置卖出限价/卖出止损 （或 设置买入限价/买入止损 ）到水平的右侧或左侧并点击平移。按钮样子将会变成 删除水平 。点击按钮以删除水平。

下单

下挂单 ，使用按钮 设置买入限价/买入止损 和 设置卖出限价/卖出止损 以所需价格：

  • 下买入限价订单，点击 设置买入限价 在卖价区。
  • 下买入止损订单，点击 设置买入止损 在买价区。
  • 下卖出限价订单，点击 设置卖出限价 在买价区。
  • 下卖出止损订单，点击 设置卖出止损 在卖价区。

然后，将会在指定价格下单。它将分别有"vol"字段设置的交易量，以及"sl"和 "tp" 字段指定的止损和获利水平。

改变订单

市场深度允许用户轻松改变之前设置的订单价格。

移动挂单到所需的价格线。订单价格会马上改变。如果订单设置了止损和获利水平，这些水平将会随着价格同距移动。

如果我们拖拽限价订单通过买价/卖价边界，它会变成一个止损订单（买入限价由买入止损所取代，而卖出限价-变成卖出止损）。

如果几个同价格的订单被下单，它们不能在市场深度中移动。

删除订单

要从市场深度删除订单，需要悬停鼠标 设置卖出限价 （或 设置买入限价 ）按钮到右侧并点击平移。按钮样子将会变成 删除水平 。点击按钮删除订单。

如果几个同价格的订单被下单，最早的那个首先移除。


?????????

开始使用 / 使用界面 / 数据窗口

数据窗口

这个窗口可以用来显示价位（开高低收价）、棒图数据、棒图的时间和技术指标数值 (包括客户指示器)应用. "数据窗口"是一个信息窗口，不能进行任何其他的操作。 在这个窗口中，可以快速得到需要的信息。

在这个窗口中可以执行以下：

  • 复制 — 可以拷贝出窗口内的信息用作其他用途。
    复制操作需要按快捷键 Ctrl+C。
  • 最近数据 — 显示/隐藏最近数据。另外,新添加的数列将会融合到最近数列中显示在窗口内。
  • 自动变化 — 当窗口的大小变化时，设置数列自动变化尺寸。
  • 网格 — 显示/隐藏二级窗口的网格。
  • 显示 — 显示/隐藏信息栏。价位（开高低收价）, 日期或成交量。 如果信息未被校对，将不会显示。

注意: 任何指示器能够(在"直观"图表窗口的属性)设置这种形式，这样数据将不会显示窗口内。


????? ??

开始使用 / 使用界面 / 导航

导航窗口

导航是对于终端多样特性最快速的通道。 可以选择按快捷键Ctrl+N打开/关闭窗口，可以使用"查看 — 导航" 操作， 或者按 "导航" 窗口 - "常规" 工具。

功能列表被列为树状，包含五组：“账户”，“指标”，“EA交易”，“自定义指标”和“脚本”。

账户

“帐户”组包括开立账户的列表。使用上下文菜单，可以开立一个新的模拟账户或删除旧的。

  • 开立账户 — 从程序端可以开立无限数量的模拟账户。要做到这一点，就必须执行“开立账户”上下文菜单命令或按下Insert按钮。关于开立账户的更多详情可以在 相应部分找到。
  • 登录交易账户 — 要授权一个现有帐户（无论模拟亦或真实账户），就必须执行“登录交易账户”命令，或者用鼠标左键双击所需的帐户行。
  • 登录MQL5.community — 打开交易平台的设置 登录到 MQL5.community并获取其他服务。
  • 更改密码 — 打开更改交易账户密码的窗口。
  • 删除 — 删除选定账户。同样的动作可以通过按下Delete键来执行。
  • 添加至收藏夹 — 添加选定账户到 收藏夹。
  • 注册信号 — 注册一个选定的账户在 “信号”服务选定的帐户。执行此命令后，您会转到MQL5.community的信号注册页面。选定的账户和正确的交易商服务器将会在注册表中自动确定。

注意： 真实账户不能在终端内开启，只能通过中介公司开启。

指标

该组包含指标 — 分析价格动态的主要工具：

  • 内置技术指标 分成四类：趋势指标，振荡器指标，交易量，比尔威廉姆斯。
  • 指标从 MQL5.community源代码库下载。显示在下载的子分类里。
  • 从市场购买的指标 — 交易平台的应用程序商店。展示在市场的子分类里。
  • 内置源代码的指标示例。展示在示例的子分类里。
  • 自定义指标 位于 /MQL4/Indicators 文件夹；根据它们存储的子文件夹结构进行显示。

导航只显示可执行的指标文件 (*.EX4)。

如果程序图标右下角的菱形是灰色的（例如， 没有源代码/不能被编译 ），则意味着该程序没有源代码文件或者可能不会被编译。

下列命令可以在快捷菜单中执行：

  • 附加到图表 — 所选指标应用于活跃的图表。同样的动作可以通过点击指标来完成。此外，用拖拽方式可以将分析工具应用于任何图表或已附加指标的子窗口。
  • 修改 — 在MetaEditor打开所选指标的源代码文件(*.MQ4) 。同样的动作可以通过选择指标并按下Enter键来执行。
  • 删除 — 删除所选的自定义指标。该动作可以删除其可执行文件 (*.EX4) 和源代码文件(*.MQ4)的两种文件。同样的动作可以通过点击Delete键来执行。
  • 从市场购买 — 转到市场 — 交易平台的应用商店。
  • 订购您自己的程序 — 转到订购开发一款MQL4程序在MQL5.community的“自由职业者服务”。
  • 在MetaEditor创建 — 转到创建自定义指标。执行该命令在创建指标的MetaEditor 中打开MQL4向导。同样的动作可以通过点击Insert 键来执行。
  • 添加至收藏夹 — 添加选定指标到收藏夹。
  • 设置热键 — 为所选指标分配一个热键 。
  • 刷新 — 从硬盘重读现有已编译的指标的信息。当复制已编译文件到客户端相应文件夹时需要执行该命令。
  • 在线程序库 — 转到“代码库”部分，这里您可以轻松地下载相应部分发布的程序在 MQL5.community网站。

EA交易

"智能交易系统" 列出所能提供智能交易。 在终端系统内智能交易允许自行分析和执行交易。创建和修改智能交易可以使用 MetaEditor操作。 详细创建细节查看 "自动交易"部分。

右键菜单"创建智能交易系统"能够开始创建一个新的智能交易系统。。"修改"用来修改已有的智能交易系统， "删除"用来删除智能交易系统。在选中的智能交易系统上通过双击鼠标左键或使用右键菜单中的"附加到图表" 命令能够在图表上加上该智能交易系统。 还可以用鼠标将选中的智能交易系统拖拽到任何一个图表中。

热键

热键可以起到辅助 "导航"窗口的作用， 除"账户"外。

设定热键，可以选择"热键设定"操作。热键更便于执行操作。例如，按Ctrl+O 显示 终端属性窗口。 如果这个组合键显示水平成交量指标，终端属性窗口将不会显示。

收藏夹

这可以快速访问经常使用的对象。

例如，在这个标签内可以仅仅放置需要的账号技术指标，脚本, 智能交易 这样就能够加快交易员的工作速度，尤其在需要高效操作的时候。 对象到"收藏夹"，需要运行右键菜单中的"添加到收藏夹"命令。如果在收藏夹中的一些对象不再需要， 您可能使用右键菜单中的"从收藏夹删除"命令从标签中删除。

注意: 在"收藏夹"中的所有对象能够没有任何限制的执行它们的功能


图表切换

开始使用 / 使用界面 / 图表切换

图表切换

这是包含当前可以在程序端打开的图表的标签的专栏。它位于图表窗口的下部：

该栏是用于通过单击其标签，在当前程序端打开的图表之间进行切换。除了金融安全的名义以外，标签还显示了图表的周期。您可以在图表标签，通过鼠标滑轮点击来关闭图表。

标签栏的上下文菜单包含以下命令：

  • 关闭 - 关闭选定的图表。同样的动作可以通过在图表标签按下鼠标中键来进行；
  • 最大化 - 最大化活动图表窗口到整个可查看区域；
  • 最小化 - 最小化活动图表。在这种情况下，只有图表窗口的标题将保留在查看区域；
  • 恢复 - 窗口模式显示活动图表；
  • 窗口 - 调用图表管理窗口。同样的动作可以通过按下Alt + W组合键来执行；
  • 平铺窗口 - 平铺排列图表窗口。同样的动作可以通过按下Alt + R组合键来执行。

图表管理窗口

这个窗口可以管理打开图表。

该窗口包含当前打开的图表列表。若要移动到其中一个图表，应该在列表中双击它，或者选中它，然后按“激活”按钮。“关闭”按钮用于关闭在列表中选择图表。


???? ? ??

开始使用 / 使用界面 / 终端

终端窗口

" 终端" —是一个多功能窗口，它能够控制交易活动， 查看 新闻和历史账户， 设置警报，同时也可以使用internal邮箱 和 系统日志。 打开这个窗口需要选择主菜单"查看—终端" 操作，按快捷键Ctrl+T, 或者or 电击"常规"工具中 “程序端”窗口 按钮 以下是终端中的所有标签：

  • 交易标签 — 在该标签，人们可以查看持仓 和 挂单的状态，以及管理全部交易活动。此外，全部持仓的总金融结果会发布在该标签。
  • 展示 — 这个标签包括所有持仓资产的概要。
  • 历史账户标签 —所有历史交易的信息会在这里公开。 估测所有交易活动功效并在这里公布结果。
  • 新闻标签 — 标签内含有引入的新闻。这些及时引入的信息是必要的分析基础。
  • 警报标签 — 可以设置和查看多样的警报。 所有在交易业务内执行的信息会被警报系统查验。
  • 邮箱标签 — 所有由终端进入的信息会保存到邮箱内。 电子邮件也是从这里发出的。
  • 公司 — 该标签为交易人展示一个有用的网页。
  • 市场 — 从MQL5.community的MQL4应用市场购买或下载应用程序。
  • 信号 — 该 标签显示了“信号” 服务的交易信号，其可供订阅。
  • 代码库 — 这里您可以下载MQL5.community 网站的“代码库”部分发布的任何应用程序。。
  • 搜索 — 该选项卡显示通过客户端搜索 的结果。
  • 智能交易标签 — 附加在交易上的所有功能信息，包括开仓/平仓， 修改定单，交易的自身信息等等都会在这里显示。
  • 日志标签 — 标签中包含有关交易人员所有动作的信息和客户终端。

注意: "终端" 窗口内的一些标签可能不存在。这表示此时标签为空。例如， "智能交易"标签会隐藏直到从MQL4 程序进入信息。


?? ???

开始使用 / 使用界面 / 终端 / 交易

交易

"交易"包含当前账户状态信息 开仓记录和被列出的定单情况。

所有持仓可以通过任何字段排序。此外有一行帐户结余和持仓的金融结果，其次是挂单列表。挂单触动时，将会打开一个新持仓，而挂单行将被新持仓所替换。

交易操作

在其右键菜单中可以提供一下命令（从左到右）：

  • 定单 — 一张定单。在定单管理窗口显示此命令。
  • 时间 — 开仓的时间。。以YYYY.MM.DD HH:MM (年.月.日 小时:分钟)格式显示。当开仓时时间会显示。
  • 类型 — 交易仓类型。这里可以显示以下交易仓的类型: "买" —看涨仓位和"卖" —卖空仓位， 挂单交易名称Sell Stop, Sell Limit, Buy Stop, 和Buy Limit。
  • 份额 — 仓位中的份额总数。仓位中的最小交易份额由经济公司指定，而最大交易份额则由存款数额限定。
  • 商品 — 显示仓位中的证券名称。
  • 价格 — 开价。这个价格必须在开仓时给出。
  • S/L —放置止损定单水平位。如果没有放置定单，价值显示为零。
    更多相关细节查看 止损部分。
  • T/P — 放置 赢利定单 水平位。 如果没有放置定单，价值显示为零。
    更多相关细节查看 赢利部分。
  • 价格 — 当前证券价格(不要与开仓价混淆)。
  • 授权 — 授权经济公司在这个标签内记录交易仓。
  • 交换 — 交换价钱会保存在这个标签内。
  • 赢利 — 金融的结果会记录在这个标签内。肯定的数字表示盈利，否定的数字表示瑕疵。
  • 注解 — 交易仓内注解保存在这个标签内。注解只有在开仓或放置定单时可以输入。 当仓位或定单修改时注解不能改变。另外，交易仓的注解不能有经济公司输入。

交易

这个标签不仅仅可以查看开仓和定单放置，也可以管理交易活动。在这里可以执行以下交易活动： 开新仓位，放置挂单，修改或删除定单和平仓。可以在背景菜单中操作：

  • 新定单 — 一张新定单。在定单管理窗口显示此命令； 新定单的打开和挂单都放置于此。另外，以下内容必须指定：保证金，份额总量，定单类型(市场定单或挂单), 止损和赢利水平位。 更多相关定单放置细节查看"检测交易仓"部分。
  • 终止定单 — 平仓。 管理定单的背景菜单。这个窗口不仅显示"卖" 和"买"按钮， "终止#XXXXXXX ..."按钮也会在这里显示。另外，操作终止定单可以选择对象结束即可。 更多平仓细节查看平仓部分。
  • 修改或删除定单 — 在开仓和挂单交易中改变"止损" 和 "赢利" 价值。 如果止损和赢利价位被指定为当前终止价格，窗口中会显示错误报告，说明水平位没有放置。 所以止损和赢利的价值必须重新设定。更多相关细节查看 修改或删除定单e部分。
  • 移动止损 — 改变 "移动止损" 的位置。选择菜单中的移动止损的数值有可能按照定单中对应的参数触发定单。命令"无"指屏蔽此功能。 "删除所有"命令用来禁止所有的移动止损。更多相关细节查看 "移动止损"部分。

如果交易商一方禁用该功能，“追踪止损”命令在快捷菜单中可能缺失。
  • 获利 — 显示获利（损失）的点数，可以用基础货币或者交易后的货币计算；如果 "显示获利"参数已被选定 (当前开价) 。 例如， USDJPY开仓, 获利会显示在 Japanese Yens。
  • 手续费 — 显示/隐藏将显示每笔已执行交易操作的手续费的“手续费”栏。
  • 税 — 显示/隐藏将显示每笔交易操作税费的“税”栏。
  • 注解 — 显示/隐藏"注释"栏。 交易仓内注解保存在这个标签内。 注解只有在开仓或放置定单时可以输入。另外，经济公司可以在交易仓内写注解。
  • 自动排列 — 通过改变窗口的尺寸自动排列栏目的尺寸。
  • 网格 — 显示/隐藏分隔栏目的网格。

当使用键盘进行交易操作时，快捷键 Ctrl+F9 能够切换到"终端—交易"窗口。在键盘无法工作的情况下这个操作是非常有用的。

单击交易

该选项卡提供通过单击鼠标 平仓 和 删除挂单 的可能性。若满足以下条件该函数可用：

  • “单击交易” 选项在程序端设置中启动。
  • 执行类型 — "立即" 或 "市场"。

每个持仓的“利润”栏并且交易订单有按钮 平仓/删除订单 。如果您点击按钮用于持仓，它会立即平仓而无需额外确认。如果您点击按钮用于挂单，它则立即移除而没有额外确认。

  • 如果无法执行单击交易（“单击交易”选项禁用或交易品种使用了 "请求" 执行模式 ），则点击按钮 平仓/删除订单 将会指向标准 平仓 或订单删除 对话框。
  • 当获得重新报价时，相应的信息会写入 程序端日志 并且会播放重新报价的声音 。


展示

开始使用 / 使用界面 / 终端 / 展示

展示

“展示”标签包括所有持仓资产状态信息概要。

信息以包括以下部分的表格形式显示出来：

  • 资产 — 货币或者交易品种名称；
  • 交易量 — 依据考虑杠杆的订单和交易品种的客户订单（单位计算）的交易量；
  • 速率 — 对于入金货币的货币或者交易品种比率；
  • 入金货币 — 显示买/卖货币或者交易品种实际花费的入金货币（不考虑杠杆）；
  • 图表 — 入金货币的客户仓位的图表显示（买入订单显示为蓝条，卖出订单显示为红条）。

入金账户资产作为可用保证金而显示。

图表

可以用图表的形式查看买入和卖出订单的信息。点击图表的名字或者使用快捷键，就可以在图表中切换。

快捷菜单

这个标签的快捷菜单允许执行以下命令：

  • 图表 — 打开图表管理子菜单：
  • 买入订单 — 依据买入订单显示图表；
  • 卖出订单 — 依据卖出订单显示图表；
  • 隐藏 —隐藏图表
  • 复制 — 将挑选出来的线复制到剪贴板上；
  • 网格 — 显示/隐藏分隔表格区的网格；
  • 自动排列 — 允许随着窗口大小的改变自动调整列的大小。


?? ?????

开始使用 / 使用界面 / 终端 / 账户历史

账户历史标签

包含所选时间段的账户历史信息保存在 "账户历史"标签内。

其右键菜单可以提供以下的命令（从左到右）：

  • 定单 — 证券数字。 它是交易业务中唯一的数字。
  • 时间 — 开仓的时间。以YYYY.MM.DD HH:MM (年.月.日 小时:分钟)格式显示。当开仓时时间会显示。
  • 类型 — 交易仓类型。只存在三种交易类型: " 标准" — 账户储备基金，"买" —看涨仓位和"卖" —卖空仓位。
  • 份额 — 仓位中的份额总数。
  • 商品 — 显示仓位中的证券名称。
  • 价格 — 开价。这个价格必须在开仓时给出。
  • S/L — 放置止损定单水平位。如果交易仓按照止损定单平仓，它的相应部分会以 红色显示。 "[s/l]" 会显示在标签内。如果没有放置定单，价值显示为零。 另一方面，如果没有放置价值，但没有开启，它的价值仍会显示在标签中。 另外，相应部分没有颜色，即没有"[s/l]"输出信息。 更多相关细节查看 止损部分。
  • T/P — 放置 赢利定单 水平位。 如果交易仓按照赢利定单平仓， 它的相应部分会以 绿色显示。 "[t/p]" 会显示在标签内。如果没有放置定单，价值显示为零。 另一方面，如果没有放置价值，但没有开启，它的价值仍会显示在标签中。 另外，相应部分没有颜色，即没有"[t/p]" 输出信息。 更多相关细节查看 赢利部分。
  • 时间 — 平仓时间。以YYYY.MM.DD HH:MM (年.月.日 小时:分钟)格式显示 当平仓时时间会显示。
  • 价格 — 平仓价。平仓之前的最后价格。
  • 手续费 — 交易商公司执行交易操作收取的手续费写在这个字段。
  • 税 — 执行交易操作时，收取的税费都写在这个字段。
  • 交换 — 交换价钱会保存在这个标签内。
  • 赢利 — 金融的结果会记录在这个标签内。肯定的数字表示盈利，否定的数字表示瑕疵。 赢利只会显示在当前存款内与它在 "交易"标签不同。
  • 注解 — 交易仓内注解保存在这个标签内。注解只有在开仓或放置定单时可以输入。 当仓位或定单修改时注解不能改变。另外，交易仓的注解不能有经济公司输入。

您可以轻松地在图表上显示进行交易的历史。要做到这一点，您只需通过鼠标在图表上拖动必要的交易。与直线连接的交易进入和退出点，将用箭头来显示。如果您按住Shift键的同时拖动一个交易，交易的整个历史将被置于图表上。

背景菜单

用于管理历史执行数据和范围，分为以下几组：

  • 所有历史 — 显示整个账户历史。 执行后全部的账户历史会按时间显示在屏幕上。
  • 最近3个月 — 显示最近3个月的账户历史。
  • 最近1月 — 显示最近1月的账户历史。
  • 客户周期 — 显示选择的历史周期。命令执行后，所管理的历史范围会显现"起始于From" 和"截止到"。
  • 存为报告帐户历史保存为报告在HTML文件的形式。就这样，允许选择保存文件的路径的窗口将出现。
  • 存为详述报告 — 以HTML文件的格式保存账户历史为报告。一份详细的报告不同于正常的额外参数集。该命令被执行后，允许选择保存文件的路径的窗口将出现。
  • 手续费 - 显示/隐藏“手续费”一栏。
  • 税 - 显示/隐藏“税”栏。
  • 注释 — 显示/隐藏"注释"栏。 交易仓内注解保存在这个标签内。 注解只有在开仓或放置定单时可以输入。另外，经济公司可以在交易仓内写注解。
  • 自动排列 — 通过改变窗口的尺寸自动排列栏目的尺寸。
  • 网格 — 显示/隐藏分隔栏目的网格。

报告

该报告的上半部分包含有关账户的一般信息。然后，交易详情被分为平仓交易（已关闭交易），未平仓交易（持仓交易）和挂单（工作订单）。显示的字段数量取决于所选择（普通或详尽）的报告类型。

  • 单号 - 交易持仓的单号。
  • 持仓时间 - 持仓时间。
  • 类型 - 交易类型（卖出，买入，S / L，T / P，修改，止损关闭等）。
  • 大小 - 交易手数。
  • 商品 — 已交易证券。
  • 价格 — 交易持仓的价格。
  • S/L — 止损值。
  • T/P — 获利值。
  • 平仓时间 — 平仓时间。
  • 价格 — 平仓价格。
  • 手续费 — 交易商公司执行交易操作收取的手续费。
  • 税 — 执行交易操作时收取的税费。
  • 库存费 — 收取的库存费。
  • 利润 — 交易的金融结果。

对于挂单，会出现另外的一栏，”市场价格“。生成报告的当前市场价格在其中指定。

账户金融执行的汇总位于下面（汇总）：

  • 入金/出金 — 有关账户入金和出金的信息。
  • 信贷设施 — 有关账户信贷资金的信息。
  • 平仓交易 P/L — 账户全部平仓交易的总利润/亏损。
  • 浮动P/L — 账户全部持仓交易的当前利润/亏损。
  • 结余 — 账户的结余。
  • 净值 — 账户净值。
  • 预付款 — 持仓交易的账户预付款。
  • 可用预付款 — 账户可用预付款。

报告还包括结余图和账户的统计信息：

  • 总净利润 — 全部交易的金融结果。该指数表示“毛利”和“毛损”之间的差异。
  • 毛利 — 所有获利交易的货币总和。
  • 毛损 — 所有不获利的交易的货币总和。
  • 利润因子 —毛利和毛损间的百分率。值1表示利润与亏损相等。
  • 期望收益 — 期望收益。这个统计计算的指数代表了交易的平均利润/亏损因子。它也可以被认为代表下次交易的期望利润/亏损因子。
  • 绝对跌幅 — 最大亏损低于初始入金值。
  • 最大跌幅 — 入金货币和入金百分比局部最大值的最多亏损。
  • 相对跌幅 - 最大亏损，最大结余值及其对应的货币值的百分比。
  • 总交易 - 交易持仓总额。
  • 卖出持仓（％） - 卖出持仓额和赢得的百分比。
  • 买入持仓（％） - 买入持仓额和赢得的百分比。
  • 获利交易（占总数的百分比） - 获利持仓数量及其占总交易的比例。
  • 亏损交易（占总数的百分比） - 亏损持仓数量及其占总交易的比例。
  • 最大赢利交易 - 所有盈利持仓中的最大利润。
  • 最大亏损交易 - 所有不盈利持仓中的最大亏损。
  • 平均赢利交易 - 交易的平均利润值（利润总和除以盈利交易数）。
  • 平均亏损交易 - 交易的平均亏损值（亏损总额除以不盈利交易数）。
  • 最大连赢（$） - 盈利交易持仓及其获胜总和的最长系列。
  • 最大连亏（$） - 无利交易持仓和他们亏损总和的最长系列。
  • 最大连赢（计数） - 一盈利交易和对应的盈利交易额的系列的最大获利。
  • 最大连亏（计数） - 一无利交易和对应的无利交易的系列的最大亏损。
  • 平均连胜 - 连续获利系列的获利持仓的平均额。
  • 平均连亏 - 连续无利系列的无利持仓的平均额。


?????

开始使用 / 使用界面 / 终端 / 新闻

新闻标签

进入的新闻列表会储存在"新闻"标签内。

新闻的顺序会按照进入的时间排列。 新闻进入的时间，它的题目和范畴都会显示在标签内。新闻列表会自动刷新和替换。

在其右键菜单中可以提供一下命令 ：

  • 查看 — 查看选择的新闻。新闻也能够通过鼠标双击标题来阅读内文。
  • 复制 — 复制新闻到写字板。
  • 范畴 — 显示/隐藏"范畴"栏。
  • 自动排列 — 通过改变窗口的尺寸自动排列栏目的尺寸。
  • 网格 — 显示/隐藏分隔栏目的网格。

注意:

  • 如果在"终端" 窗口没有"新闻"，就是说没有新闻进入。
  • 如果"允许新闻"选项显示在 终端设定窗口，说明新闻没有进入。
  • 如果给出的账户没有专属权，这也可能是新闻不能进入或查看的原因。


?????

开始使用 / 使用界面 / 终端 / 警报

警报标签

标签包含创建的报警信号信息。

T在创建报警信号后，当指定的事件执行时，客户终端可能通过声音信号发出通知而不是显示器显示。

其右键菜单包含以下一些命令：

  • 商品 —在特定条件下应用检验的证券数据。 如果"Time=" 参数作为条件被选中，商品没有那么重要了。
  • 条件 — 开启警报的条件。以下内容均可作为条件：
  • Bid> — 开价高出指定价值。如果当前价位超出给出的价值，警报会开启。
  • Bid< — 开价低于指定价值。如果当前价位低于给出的价值，警报会开启。
  • Ask> — 要价高出指定价值。如果当前价位超出给出的价值，警报会开启。
  • Ask< — 要价低于指定价值。如果当前价位低于给出的价值，警报会开启。
  • Time= — 时间等于指定价值。 时间越快将会开启警报。
  • 计数器 — 警报开启的总数。
  • 限定 — 最大警报开启总数。若超出警报总数，警报会自动停止开启。
  • 超时 — 报警重复的时间周期。
  • 截止期 — 该字段显示警告的使用期。在指定时间，警告将会自动删除。本地计算机时间应该在这里显示。
  • 事件 — 所执行的活动。可能是音频信号，在交易仓内的执行文件，邮箱信息。

警报管理

以下是警报管理所包含的内容：

  • 创建 — 创建一个新的报警。 创造一个新的警报事件。
  • 修改 — 编辑警报。可以在警报名称内双击进入修改。
  • 删除 — 删除报警。可以用删除键执行。
  • 允许开/关 — 允许/禁止报警；当禁止时警报不能删除，但可以停止开启。 稍候会开启。

注意: 可以用键盘管理警报，激活窗口。需要在窗口单击左键。

在警报信息栏双击鼠标左键可以修改警报。"修改"和 "创建"的编辑器会在窗口显现：

  • 启用 — 允许/禁止报警；当警报关闭时，不能被删除，但可以停止功能。 启用"允许/禁止报警"可以按空格键。
  • 行动 — 事件发生时，执行行动：
  • 声音 — 播放声音文件。
  • 文件 — 运行可执行文件。
  • 电邮 — 通过内部邮件系统发送邮件。
  • 通知 — 发送 推送通知到移动设备。发送推送通知需要在程序端设置中指定MetaQuotes ID 。MetaQuotes ID 是唯一的识别方式，它在安装在一台设备上时，分配给每个移动程序端。推送通知是有效的事件通知方式，它们可以立即交付到移动设备而不会丢失。信息文本在“源”标签中指定 。
  • 截止期— 该字段，您可以指定警告的使用期。在指定时间，警告将会自动删除。本地计算机时间应该在这里显示。
  • 交易品种 — 将用来检验条件的证券数据。
  • 条件 — 条件 ("Time="， "Bid<"， "Bid>"， "Ask<"， "Ask>")。
  • 值 — 检查条件的值。如果商品价值等于这个值，警报会开启。
  • 源 — 根据事件发生时执行的行为类型，下面其中一项会在这里指明：
  • *.wav，*.mp3 或 *.wma的声音文件。
  • *.exe，*.vbs或*.bat 格式的可执行文件。
  • 电邮模板。如果您选择“电子邮件”，点击该字段会打开一个窗口，用于编写电邮模板，发送到程序端设置中指定的地址。您也可以按“电邮主题\n电邮文本”的格式，只是编写邮件文本信息。
  • 推送信息文本。信息最长255个字符。
  • 超时 — 时间周期，报警重复的时间周期。
  • 最多重复次数 — 报警重复的最多次数。

"测试"键可以检验所选中的警报。为了得到一定的效果影响必须按"确定"按钮。

注意: 发送发生的事件，必须在 程序设定内设定邮箱参数。

创建图表警告

警告可以直接在图表上快速创建。为此，执行图表快捷菜单的“ 警告 警告”命令：

如果菜单高于当前价格被打开，警告会按照“卖价>选定价格”来创建，低于当前价格- “卖价<选定价格”。从图表创建的警告自动设置到到期。截止时间取决于图表的时间表：

  • 分钟时间表截止期用小时设置。在时间表中小时数对应分钟数。例如，M1时间表的截止期将设置1小时，那么M5时间表是5小时，M30时间表是30小时，等等。
  • 小时时间表用天设置截止期。时间表中天数对应小时数。例如，H1时间表的截止期将设置1天，那么H2时间表则是2天，H4时间表是6天，等等。
  • 日时间表上截止期将设置24天。
  • 周时间表截止期设置为2周。
  • 月时间表截止期设置为2个月。

警告通过相应工具的图表右侧的红箭头显示：

警告价格水平可以直接在图表上更改。只是用鼠标拖拽警告箭头。

要在图表上展示警告，启用客户端设置中的 “显示交易水平 选项。


?? ? ??

开始使用 / 使用界面 / 终端 / 邮箱

邮箱标签

"邮箱"标签用于操作内部邮箱。

这个标签中包含了终端接收到的所有邮件。 会以以下格式呈现:

  • 时间 — 信息进入的时间。
  • 来自 — 发送者名称。
  • 题头 — 信息的题头。

通过在选中标题上双击鼠标左键可以查看被选中邮件的内容，或者通过右键菜单"显示"命令。使用右键菜单中的"删除"命令可以 删除信息。除此以外， 您可以通过这个标签发信给系统管理员和技术支持部门，这需要在右键菜单中运行"创建"命令。 然后，选中发送人，写下题头和内容按"发送"按钮即可。

注意: 所有在邮箱系统内发出的信息不能请求任何附加设置。如果应用邮箱是发生任何问题，建议寻求技术服务。


公司

开始使用 / 使用界面 / 终端 / 公司

公司

根据交易商的决定，此标签可以为交易人显示一个有用的网页，例如，技术支持页面。

此网页上的任何链接都可以在您浏览器的单独窗口打开。

您交易商的决定可能没有此标签。


市场

开始使用 / 使用界面 / 终端 / 市场

市场

市场标签连接了客户端的用户与MQL5.community的MQL4程序商店。在这里他们可以为程序端下载免费或购买自动交易，指标和其他应用程序。商店也包括有关交易和金融的杂志和书籍。

Discover in 10 Minutes: Video on Market

Watch the below tutorial videos to learn about the Market. Click on the video image to watch it.

Watch video: How to purchase a robot or an indicator in Market? Watch video: How to search and choose applications Watch video: Free-of-charge testing of Expert Advisors and Indicators before purchase Watch video: How to update, renew the rental period and reinstall products

Find more about how to use the store of application in Market section.

基本信息

  • 使用市场服务之前请仔细阅读规则。这些规则发表于MQL5.community网站。
  • 要使用“市场”服务，您应该有一个有效帐户在MQL5.community网站。帐户数据可以在程序端设置指定。如果设置中没有指定数据，那么您每次下载/购买产品时都会要求提供。
  • 所有计算均使用MQL5.community内部支付系统。
  • 每个产品都绑定购自于的PC机的配置。购买产品后对于买家在其他PC机上有效的产品激活数由卖家决定。这种激活最少为4次。

购买应用程序之前，你可以下载它的演示版。演示版本有一定的局限性：

  • 演示版本的EA交易 不能在客户端的在线图表上启用。其交易部分只能在策略测试中测试。
  • 演示版本的指标 不能启用和看见于在线图表上。它的行为只能在 策略测试的可视化测试模式中看到。

应用程序分类和搜索

Watch video: How to search and choose applications

Watch video: How to search and choose applications

The Market features a well-developed product filtration and sorting systems. Each product has a detailed description and screenshots. Moreover, robots and indicators have demo versions, while books have previews. Watch our video to know how to use all that functions and make the right choice.

标签上部是为通过类型和分类搜索应用程序而设计。

  • 主要 — 所有应用程序，书籍和杂志。
  • 应用程序 — 只有交易程序端的应用程序。
  • 杂志 — 有关交易和金融的杂志。
  • 书籍 — 有关交易和金融的书籍。
  • 购买 — 产品列表 由用户购买/下载。
  • 积分 — 当前账户结余在 MQL5.community。如果程序端设置中没有指定MQL5.community账户，那么注册链接会代替结余而显现。

当用户移动到确定的分类时（应用程序，书籍或杂志）其他搜索工具会出现在标签的上部：

  • 分类 — 在这里您可以选择其他类别过滤应用程序（专家，指标，程序库等）。
  • 搜索 —搜索应用程序的字段，通过名称或说明。在搜索字段中输入单词，然后点击 搜索 。

查看，下载和购买应用程序

Watch video: Free-of-charge testing of Expert Advisors and Indicators before purchase

Watch video: Free-of-charge testing of Expert Advisors and Indicators before purchase

Before making a purchase it's recommended to test desired robots and indicators. It's an easy and free-of-charge operation that will give you more confidence in a product. Watch the video for details.

应用程序列表中显示其成本及用户评价的评级。“免费”标签意味着应用程序在免费的基础上进行分布。

点击应用程序的标志，以浏览，下载或购买：

上部包含切换应用程序之间的数据标签的工具栏：

  • 返回 — 返回应用程序列表。
  • 应用程序 — 在这里可以查看应用程序的详细说明。
  • 截图 — 在这里可以查看应用程序截图。
  • 评论 — 在这里可以查看有关应用程序的用户评价。如果没有评论，该标签不显示。

购买

Watch video: How to purchase a robot or an indicator in Market?

Watch video: How to purchase a robot or an indicator in Market?

Any trader will find thousands of trading robots, indicators, financial magazines and books in the Market. All of that can be purchased directly in the platform and it's much easier than you think.

要购买应用程序，点击它，然后点击“买入”按钮。

要购买产品，在您的MQL5.community帐户上你必须有足够数量的积分。标志下面显示产品的成本。

点击“买入”按钮后，会出现购买确认窗口：

要确认购买，您需要同意市场服务使用规则和指定您的MQL5.community 账户密码。然后点击"OK"。

如果购买之前还没有在程序端设置中指定MQL5.community账户详情，您将需要指定它们。

  • 点击“买入”按钮后，相应的积分就会从您账户中扣除。下载到程序端的产品将启动。
  • 所有购买和下载都显示在“购买”标签。
  • 该产品被下载到 /MQL4/program_type/Market/ terminal 文件夹，其中program_type是一种应用程序类型。例如，EA交易将下载到 /MQL4/Experts/Market/。

购买/下载

Watch video: How to update, renew the rental period and reinstall products

Watch video: How to update, renew the rental period and reinstall products

All your products are tied to your mql5.com account or to your computer and available for you at any time. You will always know about updates, will be able to renew the rent or download a previously purchased product. Watch the video to find out how easy that is.

"购买"标签显示了使用当前 MQL5.community 账户下载和购买的所有产品。如果程序端设置中没有指定MQL5.community 账户数据，标签名称改为"下载"。它显示了无论哪个账户，当前客户端中的全部下载和购买。

这里会显示以下信息：

  • 名称 — 产品名称。演示版本的产品都标有 演示 标签。
  • 类别 — 产品类别，如EA，指标等。如果您点击产品类别，它会选择在 "导航" 窗口。
  • 价格，积分 — 产品成本积分。
  • 日期 — 产品下载/购买日期。


信号

开始使用 / 使用界面 / 终端 / 信号

信号

信号服务允许任意人成为供应商，出售交易信号或订阅它们，和遵循一个有经验的交易人的策略。

用户应该有一个活动的MQL5.community 帐户来使用信号服务。如果您还没有帐号，请 注册。账户应该在 程序端设置中指定。

找出更多有关如何成为信号供应商或订阅信号的信息在 信号 部分。

程序端窗口的信号标签显示可供认购的交易信号。

信号类型，由用来创建信号的账户类型决定，通过图标显示：

  • 演示信号 — 模拟账户基础上创建的信号。
  • 真实信号 — 真实帐户基础上创建的信号。

快捷菜单 允许调整信号显示的数据量：

  • 信号 — 信号的名字。当点击一个名字时，您将移动到MQL5.community上信号的描述。
  • 账户类型 — 账户类型，信号创建的基础：演示，竞争，或真实。
  • 等级 — 根据信号性能的诸多因素计算的信号等级。
  • 价格 — 每月订阅信号的成本。
  • Ping — 信号服务器和您经纪人服务器之间的以毫秒为单位的网络延迟（当使用可信执行标记时）。
  • 交易 — 总交易数量（用来固定利润或亏损的交易）。
  • 点 — 以点数监测时获得的利润/亏损。
  • 平均点 — 所有获利交易的平均利润。
  • 星期 — 从交易账户的第一笔交易操作开始过去的星期数（考虑账户的整体期间，而不仅仅是注册信号的期间）。
  • Max. DD % — 从本地最大值下降最高结余的百分比值。
  • ROI — 投资回报，与投资利润/亏损相关（初始入金和补充）。
  • 创建 — 信号服务中，信号注册的日期。
  • 最近激活 — 账户交易状态最近一次更新的日期和时间。
  • 增长, % — 以百分比计算的入金增长，只以交易操作为基础，不考虑该账户的入金和出金。
  • 结余 — 当前结余。
  • 图解 — 入金增长图解。

信号监控

双击列表中的信号，查看关于它的详细信息。

交易账户监测系统跟踪参数的详细描述可以在"账户监测" 部分找到。

该选项卡的上部包含工具栏：

  • 返回 返回 — 返回到信号列表。
  • 前一个 前一个 — 转到前一个信号。
  • 下一个 下一个 — 转到下一个信号。
  • 订阅 订阅 — 订阅当前信号。
  • 退订 退订 — 退订交易信号。
  • 续订 续订 — 延长您目前的订阅。
  • 可视化 可视化 — 此命令允许查看程序端图表上信号账户的交易历史记录。如果你点击它，信号账户上交易的全部交易品种图表将会打开。信号账户上执行的全部交易将会显示在那些图表上带有图标 买入 和 卖出 。

订阅信号

如果您满意信号（包括价格），你就可以订阅它。点击“ 订阅 订阅”在工具栏的顶部。订阅确认窗口将出现：

基本信号数据显示在这里

  • 信号 — 信号的名字。当点击一个名字，你将移动到MQL5.community上信号的描述。
  • 供应商 — 信号供应商的名字。当点击它时，您将移动到供应商的MQL5.community个人资料。
  • 交易商 — 供应商所使用的交易商服务器的名称。
  • 增长 — 信号注册那一刻起，供应商账户的入金增长。以初始值百分比指定的值。
  • 价格 — 积分计算每月的订阅价格。

通过勾选相应的选项，你也应该同意使用信号服务的条款。

没有交易将会复制到您的账户，直到您激活您交易程序端中的“启用实时信号订阅” 选项。

退订信号

找到您在信号标签上订阅的信号，通过点击“ 我的订阅 我的订阅”在快捷菜单。然后点击“ 退订 退订”在信号的工具条上。

快捷菜单

该标签的快捷方式允许执行以下命令：

  • 我的订阅 我的订阅 — 去查看您当前订阅的信号。
  • 详细信息 详细信息 — 转到信号说明。
  • 刷新 刷新 — 刷新可用信号列表。
  • 登录MQL5.community — 打开交易平台的设置 登录到 MQL5.community并获取其他服务。
  • 过滤器 — 在子菜单设置信号过滤器：
  • 真实 真实 — 显示/隐藏基于真实账户创建的信号。
  • 演示 演示 — 显示/隐藏基于模拟账户创建的信号。
  • 付费 付费 — 显示/隐藏付费基础上提供的信号。
  • 免费 免费 — 显示/隐藏免费基础上提供的信号。
  • 全部— 显示全部信号。
  • 一个月前 — 显示一个月前的信号。
  • 3个月前 — 显示3个月前的信号。
  • 6个月前 — 显示6个月前的信号。
  • 启用/禁用信号列表中的列：
  • 账户类型 — 账户类型，信号创建的基础：演示，竞争，或真实。
  • Ping — 信号服务器和您交易商服务器之间的以毫秒为单位的网络延迟。
  • 交易 — 总交易数量（用来固定利润或亏损的订单）。
  • 点 — 以点数监测时获得的利润/亏损。
  • 平均点 — 所有获利订单的平均利润。
  • 平均交易时间 — 交易持仓的平均寿命。
  • 星期 — 从交易账户的第一笔交易操作开始过去的星期数（考虑账户的整体期间，而不仅仅是注册信号的期间）。
  • Max. DD % — 从本地最大值下降最高结余的百分比值。
  • ROI — 投资回报，与投资利润/亏损相关（初始入金和补充）。
  • 创建 — 信号服务中，信号注册的日期。
  • 最近激活 — 账户交易状态最近一次更新的日期和时间。
  • 自动排列 — 如果启用此选项，列的大小将自动选择。
  • 网格 — 显示或隐藏分隔列的网格。


代码库

开始使用 / 使用界面 / 终端 / 代码库

代码库

这个标签允许访问代码库发布在MQL4.community 直接从客户端。在这个标签选择一个所需的 MQL4应用程序 ，您可以下载它并直接附加到图表中。

应用程序以包含下面信息的列表形式显示：

  • 名称 — MQL4 应用程序的名称。行前面的图标表示应用程序类型：
  • EA交易 — EA交易。
  • 指标 — 指标。
  • 脚本 — 脚本。
  • 描述 — MQL4 应用程序的描述。
  • 等级 — 其他用户评出的应用程序等级。

若要打开应用程序页面在 MQL4.community网站，需要在列表中双击。

下载应用程序

通过简单的从此标签在图表上拖动它，代码库中的任何应用程序都可以迅速启动。应用程序将被下载和保存至相应类型的文件夹中（例如，[terminal installation folder]\MQL5\Experts\），在选定图表上编译和启动。

要下载应用程序，执行" 下载 下载"命令在快捷菜单。执行命令后下载开始。

应用程序保存在应用程序类型相应的文件夹中。例如，EA交易保存在[terminal_installation_folder]/Experts/文件夹中。下载一旦结束，应用程序启动窗口即被打开：

如果您点击"OK"，应用程序将在当前图表上启动。

快捷菜单

这部分的快捷菜单包括下面命令：

  • 查看 查看 — 查看选定应用程序在MQL4.community 网站。
  • 下载 下载 — 下载 一个选定应用程序到电脑中。
  • 订购您自己的指标 订购您自己的EA交易/指标/脚本 — 转到订购开发MQL4程序在 MQL5.community的自由职业者服务"工作" 。
  • EA交易 EA交易 — 列表中启用/不启用EA交易展示。
  • 指标 指标 — 列表中启用/不启用指标展示。
  • 脚本 脚本 — 列表中启用/不启用脚本展示。
  • 自动排列 — 当启用这个选项时，如果窗口大小改变则会自动选择图表列的大小。
  • 网格 — 显示或隐藏分隔图表字段的网格。


搜索

开始使用 / 使用界面 / 终端 / 搜索

搜索

交易平台提供智能强大的系统用于搜索网站MQL4.community 和 MQL5.community — 交易人和MQL4/MQL5 开发者社区。网站提供大量有用的信息： 文档， 论坛，文章 关于编程和使用平台。社区提供了访问巨大的源代码数据库 和 应用程序商店 用于平台。您也可以 复制专业交易人的交易通过信号服务。

MQL5.community上的搜索结果显示在该选项卡。

要打开找到的元素，左击标题。使用上面板，根据市场产品，代码库，信号，MQL4.community论坛和文档，查看搜索结果。

搜索标签直到您执行搜索时才能显示出来。


?? ?????

开始使用 / 使用界面 / 终端 / 智能交易

智能交易标签

"智能交易"标签附加在交易上的所有功能信息，包括开仓/平仓， 修改定单，交易的自身信息等等。

在窗口内会显示最后交易的信息。查看最近的交易信息 ， 需要运行"打开"菜单命令，然后选择需要的文件。 交易文件被保存在/EXPERTS/LOGS 文件目录内，文件名称与记录器相符 — YYYYMMDD.LOG. 可以复制信息到写字板。


?? ???

开始使用 / 使用界面 / 终端 / 日志

日志标签

"日志"标签中包含有关交易人员所有动作的信息和客户终端。

日志中的所有固定信息包括了终端的开始、终端操作事件、所有交易操作和 智能交易系统的工作。在窗口中仅仅显示最新的信息。为了核查以前的信息，需要运行"打开"菜单命令，然后选择需要的文件。 客户端内的日志文件被储存在/LOGS 文件目录内，文件名称与日志日期相符 — YYYYMMDD.LOG. 可以复制信息到写字板。


???????

开始使用 / 使用界面 / 测试

测试窗口

"测试" 是一个多功能的窗口，允许 策略测试 和 智能交易的参数利用。当开始测试时，在交易数据被通过时，允许估算它的利润和影响。

窗口可以通过 "查看 — 策略测试" 菜单打开， 或使用快捷键Ctrl+R，或按"常规" 工具条中的 "Strategy Tester" Window 此窗口包含以下几个部分.

  • 安装 — 测试和最优化的安装。 智能交易安装，被测试时段，模型柱的方法，和其他都可以在这里安装。
  • 结果 —执行交易业务的结果，改变图表平衡。
  • 图表 —在图表中显示测试结果。
  • 报告 — 测试报告详情。 这里可以找到许多测试仪器：模型柱总量，纯赢利，赢利仓位和不赢利仓位，赢利和止损的总量等等。
  • 日志 — 所有交易内部交易信息和活动的记录。
  • 最优化结果 — 通过数据的信息，包括输入数据，利润， 借款和其他数据。
  • 最佳化图表 — 最佳化图表结果。另外，赢利和止损的总量会显示在图表内。

如果测试图表示空的，在"终端" 窗口内的一些"测试"图表会隐藏。 那么，在这种情况下只能见于"设置"和 "日志" 窗口。 "结果", "图表"和 "报告"只有在交易测试开启后才会显现。 在上述完成后"最优化结果" 和 "最佳化图表" 会显示。更多相关细节请查看 策略测试部分。


???? ? ??

开始使用 / 使用界面 / 测试 / 设置

测试设置

测试参数 和 交易参数最佳化 可以在这个标签内设置。 测试时，交易传输到模型上的数据可以查出利润和功效。 优化时，机器交易系统会取出它的最高利润值。

测试器设置可以设定:

  • 智能交易系统 — 从列表中选择需测试的智能交易系统。为了能够执行此步骤， 智能交易系统必须被编译及放置在/EXPERTS文件夹中。所有新创建的智能交易系统都被自动放置在此文件夹中；
  • 商品 — 选择一种提供的可价证券。
  • 周期 — 选择商品的时间周期。
  • 模式 — 选择棒图模型的模式：
  • 每个Tick（根据所可利用最小时期限的每一个Tick的分数维插值法）。
  • 控制点数 （根据最近最小期限内12个控制点的分数维插值法）。
  • 限于开盘价格（以最快速的方法分析完刚形成的价格）。
  • 点差 — 客户端存储的价格历史只包括卖价。默认下，要模仿买价，策略测试在测试之初使用交易品种的当前点差。然而用户可以在“点差”字段设置自定义点差用于测试。
  • 使用日期 — 在测试时使用日期和时间的区间； 换而言之，所有对于和周期的可用数据被应用。
  • 可视模式 — 启用可视模式，在图表上显示测试进程。您可以使用右侧的操控杆来调节可视化测试的速度。您也可以在“跳到”字段中指定一个日期，跳过可视化测试直接到那个日期。
  • 最佳化 — 允许开启交易最佳化模式。更多相关细节请查看 交易最佳化部分。
  • 智能交易系统属性 — 打开" 智能交易系统属性" 窗口 当测试和优化时可以管理测试参数。
  • 商品属性 — 查看商品属性。这些数据会在*.FXT 文件中给出用于模仿交易服务器。
  • 打开图表 — 为选择的商品创建新的图表窗口。 当测试时，交易使用虚拟图表。单仓位的开仓和平仓 ，对象和指标都需利用智能交易中的图表。 图表只有在测试完成后才会打开。打开一个虚拟图表，需应用 TESTER.TPL 模板。如果图表不是虚拟的，需设定默认值。
  • 修改智能交易系统 — 打开编辑器"MetaEditor"编辑选择的智能交易系统。
  • 开始 — 开始测试或优化。 测试开始后， "开始"按钮会在原为自动转化成"停止"按钮。在测试和优化过程中按停止键活动将会停止。

跟多相关交易测试细节可以在 测试部分找到。


??? ??

开始使用 / 使用界面 / 测试 / 属性

交易属性窗口

在这个窗口可以设定实质账户的参数和智能交易测试。

这些数据随后就会应用到交易参数的测试和优化中。 在这个窗口中存在三个表格：

  • 测试 —通常情况下测试和最佳化都安放在这里。会给出成交量和当前存款的相应名称。 仓位的类型在选中测试后被打开，如下： "看涨" —只打开看张仓位； "卖空" — 只打开卖空仓位； "看涨和卖空" — 全部打开。无论任何时候智能都在运行。
  • 输入数据 —所有输入数据的列表以表格的形式给出。输入数据可以直接影响交易工作，可以从客户端内直接改变。 当前在交易测试中被应用的数据会记录在"价值"标签内。 "开始"， "步骤"和 "停止"标签中的被写入数据不会影响交易测试，只是应用到它的最佳化中。变量的初始价值，改变的步骤和金融价值都会写在标签内。 在最佳化中，交易数据会连续不断地在实质价值和金融价值内通过。 在进入最佳化过程中允许检验变量。如果在通行过程中没有检验参数，将禁止参与最佳化。如果在最佳化的过程中它的价值没有改变， 写在"价值"标签的参数被应用。

    可以下载以前已经保存的输入数据设置(包括 "开始"， "步骤" 和 "停止"的价值)。 在选中保存输入数据后按 "加载"完成。 外部变量的现存设置可以按文件名称保存。

注意: 建议在最佳化过程中只包含所需变量。如果包含太多变量，总体最佳化的时间将会增加。
  • 最佳化 —允许管理最佳化的范围。以下主要参数测试范围:
  • 最小差额 — 在当前存款中的最小差额。
  • 最大赢利 — 在当前存款中的最大赢利。
  • 最小差额水平 % — 最小差额水平的百分比。
  • 最大借贷 % —最大借贷的百分比。
  • 平均连续亏损 — 交易中的最大亏损总量。连续损失交易的平均数。
  • 连续亏损交易 — 最大的连续亏损交易及其总次数。
  • 平均连续盈利 — 交易中的最大赢利总量。连续盈利交易的平均数。
  • 连续盈利交易 — 最大的连续盈利交易及其总次数。

详细信息查看"智能交易测试" 和 "最佳化"部分。


?? ? ????

开始使用 / 使用界面 / 测试 / 结果标签

结果标签

测试结果会以表格的形式呈现在标签内。

此表包括所有交易执行的信息。表格包括以下几个栏目：

  • # — 交易的数目。
  • 时间 — 履行交易的时间。
  • 类型 — 交易的类型(卖出，买入，止损， 获利了结，修改，止损平仓等待)。
  • 下单 — 下单的数量 。
  • 份额 — 交易中的总体份额。
  • 价格 — 在交易执行中保证金的价格。
  • S/L — 止损下单。没有在标签内登陆意味着未下单。
  • T/P — 获利了结下单。没有在标签内登陆意味着未下单。
  • 赢利 — 盈利/亏损仅平仓时在该栏中会显示该数值。
  • 余额 — 余额。 仅平仓时在该栏中会显示该数值。

在数组上端点击鼠标左键，可以将数组在图表内划分上升定单和下降定单。 应用"复制"键或快捷键Ctrl+C，可以复制所选数组到写字板，以便将来应用。 如果没有选择数组，全部表格被复制到写字板。复制整个表格到写字板，需要按"全部复制"操作。 相关测试报告结果可以以HTML文件形式存于硬盘内。可以使用 "保存报告"执行。 "设定日期"起始于"" 和 "设定日期"截止到""可以划分测试时间范围。 另外，被选中的业务日期会被记录在测试设置的 "应用起始日期:" 和 " 应用截至日期:"的标签内。

更多相关细节请查看 "测试"和 "最佳化"部分。


??? ??

开始使用 / 使用界面 / 测试 / 图表

图表

"图表"标签包括自动画出的帐户平衡图表。(蓝线 — "平衡"， 绿线 — "份额") 该图表显示在测试交易策略期间动态交易结果。如果在测试过程中交易手数有变化，手数图将会在此标签显现。 如果在测试中份额大小发生改变，柱状图会显示在图表下方。

在图表处双击鼠标左键转换 "结果" 标签选取相应线路。运用"复制"键或快捷键Ctrl+C,复制到写字板以便应用于其他。图表也可以作为GIF文件储存在硬盘内。 可以使用"图片保存为" 或快捷键Ctrl+S。 "设置日期"起始"" 和 "设置日期 "截止到""可以设定测试时间范围。另外，被选取的日期会写在 设置标签的 "起始应用日期:" 和 "截至应用日期:" 这样对于一定时间范围的交易测试和优化参数有益处。

详细信息查看"智能交易测试" 和 "最佳化"部分。


??? ????

开始使用 / 使用界面 / 测试 / 报告标签

报告标签

此标签中概括了测试交易结果和一些指数。

包含以下测试结果和一些主要参数：

  • 测试的棒图 — 历史的棒图的数量。
  • Tick 模型 — 在测试时，Tick模型的数量。
  • 模型的质量 — Tick模型质量的百分比值。模型是显示下一个报告的简图。有三种颜色：
  • 灰色 — 这部分的数据没有被测试。如果这些数据在测试设置部分给出，将以灰色显示。
  • 红色 — 在这个区域内短时期内没有数据模型可以执行。 另外，只有在 测试设置部分选中的数据才可以应用。
  • 绿色 — 在这个区域已经执行的模型。另外，颜色微亮些的部分，是质量模型。 例如，当在H1范围内测试时，深绿色的一组意味着数据测试的时间段为M30，亮绿色则表示时间段为M1。

注意: 如果应用最快的方法("开价") 在 测试设置部分应用模型，所有数组将会变红。另外， "n/a" — 模型还未被执行 — 会被写入 "模型的质量"标签内。
  • 初始存款 — 初始存款数量。
  • 总净利润 — 盈利减去亏损的数值。
  • 总获利 — 所有盈利交易的盈利总额。
  • 总损失 — 所有有亏损交易的亏损总额。
  • 利润因子 — 盈利减去亏损的百分比比率。意思就是说总体赢利与总体损失相同。
  • 预计盈利 — 通过数学运算来预计盈利。换而言之，是利用统计的估算方法预测交易中的赢利/损失显示平均数。 还可以通过它估算下一场交易的赢利/损失。
  • 亏损绝对值 —在余额下最大亏损值。
  • 亏损最大值 (%) — 亏损交易的最大值的百分比率。
  • 相对跌幅 — 最大亏损，最大结余值及其对应的货币值的百分比；
  • 交易总计 — 总计交易的数量。
  • 空头头寸 (盈利 %) — 建立空头头寸的数量和其中盈利的百分比。
  • 多头头寸(盈利 % ) — 建立多头头寸的数量和其中盈利的百分比。
  • 盈利交易(与总交易数量的%) — 盈利头寸的数量及其占总交易数量的百分比。
  • 损失交易(与总交易数量的%) — 亏损头寸的数量及其占总交易数量的百分比。
  • 最大的获利交易 — 最大盈利的交易。
  • 最大的亏损交易 — 最大亏损的交易。
  • 平均盈利 — 每一笔交易的平均盈利。
  • 平均亏损 — 每一笔交易的平均亏损。
  • 最大连续盈利（盈利金额) — 最大的连续盈利交易及其总和金额。
  • 最大连续损失（亏损金额) — 最大的连续亏损交易及其总和金额。
  • 最大连续盈利（盈利次数) — 最大的连续盈利交易及其总次数。
  • 最大连续损失（亏损次数) — 最大的连续亏损交易及其总次数。
  • 平均连续盈利 — 连续盈利交易的平均数。
  • 平均连续损失 — 连续损失交易的平均数。

复制报告到写字板，报告可以以HTML文件形式保存在硬盘内。 可以使用"复制" "保存报告"执行操作，或按快捷键 Ctrl+C保存，功效相同。

详细信息查看"智能交易测试" 和 "最佳化"部分。


??? ??

开始使用 / 使用界面 / 测试 / 日志

日志

所有交易业务和相关的交易测试进程都会自动公布在"日志" 标签内。

日志更倾向于 "终端 —智能交易" 窗口， 除了在智能系统测试而不是在市场真实操作期 间发布的信息以外，该日志与终端窗口的日志相同。 在测试结束之后。数据输出在单独的文件夹TESTER/LOGS。 测试日志保存在文件夹/EXPERTS/LOGS，文件名称与相应的日期记录相符— YYYYMMDD.LOG。 查看现有记录，选中文件执行"打开"操作。 可以复制当前记录到写字板。 当执行"全部删除"时，所有的记录将从目录中删除。

详细信息查看"智能交易测试" 和 "最佳化"部分。


????????

开始使用 / 使用界面 / 测试 / 最优化结果

最优化结果

最优化与测试不同，它是应用不同输入数据参数通过机械交易系统。

这个功能的执行是为了测定交易的最高赢利 。 设定最优化，需要进入"最优化"标签的 设置 按 "开始"键即可。随后，在窗口内会显现两个表格： "最优化结果"和 "最佳化图表"。

"最优化结果"表格与测试报告不同， 不公开完整的交易列表。所有数据会呈现在包含以下内容的表格里：

  • 许可证 — 许可证号码。
  • 赢利 — 纯赢利(总共赢利减去总共损失)。
  • 交易总量 — 开仓交易的总量。
  • 利润因子 — 总体赢利减去总体损失的百分比。意思就是说总体赢利与总体损失相同。
  • 预计盈利 — 通过数学运算来预计盈利。换而言之，是利用统计的估算方法预测交易中的赢利/损失显示平均数。 还可以通过它估算下一场交易的赢利/损失。
  • 借款 $ — 最大借款限额与当前的存款有直接的关系。
  • 借款 % — 最大借款限额取决于最初存款的百分比。
  • 输入数据 — 在每个许可证输入数据的价值。

用鼠标左键单击任何一个数列上端，即可将定单的减少量和增加量分类。 所选中许可证的数据将会作为交易基本数据输入( 交易属性窗口"输入数据" 表格)。 在"设定输入数据参数"执行后。另外，程序在"设置" 表格关闭后, 最优化模式也会停止。 按"开始" 键，可以测试智能交易输入数据的参数和变量。 也可以通过在最优化结果的许可表格内双击鼠标左键完成。 应用 "复制"或快捷键Ctrl+C可以复制所有数据到写字板中， 以便以后应用。如果没有选中线路全部表格将会复制到写字板中。 应用"全部复制"便于复制所有表格到写字板中。 最优化结果的报告可以以HTML格式保存到硬盘上。可以使用"保存"键执行操作。 其他一些结果显示命令允许在子菜单执行，包括以下:

  • 略过无价值结果 — 显示/隐藏损失结果。
  • 显示输入数据参数 — 显示/隐藏"输入数据"数列。
  • 自动排列 — 当改变窗口时自动调整数据的尺寸。
    也可以按A，功能相同。
  • 网格 — 显示/隐藏数列的分类网格。
    也可以按G，功能相同。

详细信息查看"智能交易测试" 和 "最佳化"部分。


?? ??????

开始使用 / 使用界面 / 测试 / 最佳化图表

最佳化图表

最佳化与测试不同，它是应用不同输入数据参数通过机械交易系统。 这个功能的执行是为了测定交易的最高赢利 。执行操作最佳化图表，可以选择在 设置标签内按"开始"键。随后，在窗口中会显现两个新标签 "最优化结果"和"最佳化图表"。

所有通过的获利图表会在 "最佳化图表"标签内自动画出。图表允许估算和显示不同数据组合所带来的利润。 赢利（绿色）和止损（红色）均可在图表中显现。

在图表处双击鼠标左键转换 "结果" 标签选取相应线路。运用"复制"键或快捷键Ctrl+C,复制到写字板以便应用于其他。图表也可以作为GIF文件储存在硬盘内。 可以使用"图片保存为" 或快捷键Ctrl+S。

详细信息查看"智能交易测试" 和 "最佳化"部分。


搜索

开始使用 / 使用界面 / 搜索

搜索

交易平台提供智能强大的系统用于搜索网站MQL4.community 和 MQL5.community — 交易人和MQL4/MQL5 开发者社区。网站提供大量有用的信息： 文档， 论坛，文章 关于编程和使用平台。社区提供了访问巨大的源代码数据库 和 应用程序商店 用于平台。您也可以 复制专业交易人的交易通过信号服务。

当您输入搜索查询时，系统会立即提供可能的选择。从列表中选择所需的短语并按下Enter钮或 [image] 键。若要搜索曾经的一个查询，将光标放在框上并点击下拉箭头来打开查询历史。

搜索结果显示在工具窗口中一个独立的 搜索 标签。系统会通过类别更方便地选择最适当的结果：

要打开找到的元素，左击标题。使用上面板，根据市场产品，代码库，信号，MQL4.community论坛和文档，查看搜索结果。


?????????

开始使用 / 使用界面 / 快速导航

快速导航

在客户终端内对于快捷键拥有多样的用法。 可以提供以下几种办法：

  • 快速导航线 — 在图表的左下角显示的线。
  • 快捷键/热键 — 快捷键对于不同程序拥有不同作用。

快速导航线

用来快速改变图表或者图表的时间周期、精确移动屏幕。快速导航线能够使用Enter键打开，从而显示在图表窗口左下方。 您也可以移动鼠标光标到图表窗口左下方， 当标记 快速导航 出现后双击鼠标左键。

快速导航线的命令格式:

格式化 | 例如
[准确的时间（小时：分钟）] | 08:30; 8:30;
[准确的日期] | 2004.10.16; 16.10.2004; 16.10.04;
[准确的时间和日期] | 2004.10.16 8:30; 16.10.2004 8:30; 16.10.04 8:30;
[金融品种的名称] | GBPUSD; EURUSD;
[图表的时间周期] | M1; M5; M15; M30; H1; H4; D1; W1; MN;
[金融品种的名称]，[图表的时间周期] | GBPUSD, M30; EURUSD, D1;

注意:仅仅上面提及的命令可以在快速导航线运行。同时运行几个命令将不会得到想要的结果。

您可以使Enter键打开快速导航线，使用Esc键关闭。 为了移动屏幕到具体的时间和日期，需要在表示日期和时间之间用一个空格来隔开。 例如，象使用命令"2004.10.16 08:30"能够移动棒图到2004年10月16日08：30。 其中日期的表示格式为年.月.日(XXXX.XX.XX) 或 日.月.年 (XX.XX.XXXX)， 您也可以表示为日.月.年 (XX.XX.XX)。 但是象年.月.日 (XX.XX.XX)这样表示日期是不允许的。在时间前面的第一个“0”可以省略。例如, 您能够简单的用"8:30" 代替 "08:30". ”。改变图表的金融品种需要输入金融品种的全名，而通常用来表示图表时间周期的字母 "М"可以省略。 命令 "GBPUSD 30" 和"GBPUSD М30" 一样，能够转换图表成英镑－美元的30分钟图。

热键

热键（快捷键）是指用不同的键或多键组合快速运行不同的程序。

  • "左箭头" — 图表向左滚动。
  • "右箭头" — 图表向右滚动。
  • "上箭头" — 图表向左快速滚动。
  • "下箭头" — 图表向右快速滚动。
  • 数字面板5 — 在它改变后自动保存图表，热键可使图表放置在可见的范围。
  • 上一页 — 图表向左快速滚动。
  • 下一页 — 图表向右快速滚动。
  • 主页 — 移动图表到开始。
  • 结束 — 移动图表到最后。
  • "-" — 缩小图表。
  • "+" — 放大图表。
  • 删除 — 删除所有对象。
  • Backspace — 删除最后进入图表窗口的对象。
  • Enter — 打开/关闭快速导航窗口。
  • Esc — 关闭对话窗口。
  • F1 — 打开"用户手册"。
  • F2 — 打开"历史数据中心" 窗口。
  • F3 — 打开"弹出报价"窗口。
  • F4 — 下载 MetaEditor。
  • F6 —显示"测试"窗口测试图表窗口的智能交易系统。
  • F7 — 改变图表窗口中智能交易系统的设置。
  • F8 — 显示图表属性窗口。
  • F9 — 显示"新定单" 窗口。
  • F10 — 开启"弹出报价" 窗口。
  • F11 — 执行/显示全屏。
  • F12 — 步进的方式向左移动图表。

  • Shift+F12 — 步进的方式向右移动图表。
  • Shift+F5 — 显示前一个数据图表。

  • Alt+1 — 显示图表为柱状图（转换图表为柱状图）。
  • Alt+2 — 显示图表为日本蜡烛图（转换图表为蜡烛图）。
  • Alt+3 — 显示图表为折线图（转换图表为折线图）。
  • Alt+A —复制全部/充分利用在写字板内的结果。
  • Alt+W — 显示图表控制窗口。
  • Alt+F4 — 关闭客户终端。
  • Alt+Backspace 或 Ctrl+Z — 取消删除对象。

  • Ctrl+A —设置所有的技术指标图表窗口为默认高度。
  • Ctrl+B — 显示"对象列表"窗口。
  • Ctrl+C or Ctrl+Insert — 复制写字板。
  • Ctrl+E — 开启/关闭智能交易系统。
  • Ctrl+F — 开启 "十字丝"。
  • Ctrl+G — 显示/隐藏网格。
  • Ctrl+H — 显示/隐藏 OHLC。
  • Ctrl+I — 显示 "指标列表" 窗口。
  • Ctrl+L — 显示/隐藏成交量。
  • Ctrl+P — 打印图表。
  • Ctrl+S — 把图表存为扩展名为: "CSV", "PRN", "HTM"。
  • Ctrl+W or Ctrl+F4 —关闭图表窗口。
  • Ctrl+Y — 显示/隐藏时段分离器。
  • Ctrl+Z or Alt+Backspace — 取消删除对象。
  • Ctrl+D — 打开/关闭"数据窗口"。
  • Ctrl+M — 打开/关闭 "市场报价" 窗口。
  • Ctrl+N — 打开/关闭 "导航" 窗口。
  • Ctrl+O — 打开 "设置"窗口。
  • Ctrl+R — 打开/关闭 "测试" 窗口。
  • Ctrl+T — 打开/关闭 "终端"窗口。
  • Ctrl+F5 — 打开下一个profile。
  • Ctrl+F6 — 激活下一个图表窗口。
  • Ctrl+F9 — 打开"终端— 交易"窗口和转换聚焦。 然后, 激活的交易可以用键盘管理。

这些特性允许在"导航"窗口内执行， 除 "账户"组外。运用组合键，需选择"定义热键"执行 相同的热键或热键组合在不同情况下有不同的作用。 例如， Ctrl+O 组合键显示终端设置窗口。如果 要求在技术指标窗口显示平衡成交量 按Ctrl+O将不会显示终端设置窗口。


工作图表

开始使用 / 工作图表

工作图表

图表及时显现了金融证券价格的动态信息。图表用于执行技术分析，EA交易工作 和由此的测试。在程序端可以同时打开多达99个图表。

客户端允许：

  • 同时打开 多达99个图表。
  • 设置 它们的表现形式和显示的信息。
  • 打印 图表。
  • 应用和删除 各种物件和指标。
  • 恢复删除的图表。
  • 使用图表模板。


???? ? ????

开始使用 / 工作图表 / 开始图表

开始图表

图表是一种工具能够显示不同证券时间内价格的变化。 图表需要在技术分析, 智能交易工作的框架内执行.多达九十九个图表能够在同一时间在同一终端内打开。

设置一个新的图表需选择"文件— 新图表" 目录执行， "窗口—新窗口"目录 执行， 或者按 新图表 "常规" 工具条，功效相同。 可用的证券列表将会按照命令执行。 新图表可以通过 "市场视察"窗口打开， 按住Ctrl 和 从终端窗口内的任何一个工作领域拖拉列表元素， 或者选择执行 "图表窗口" 完成。所有图表以默认形式打开。TPL 模板 在终端安装时被创建. 这个模板不能够删除，但可以修改。

图表所储存的历史数据将存于硬盘内。 打开图表, 数据从硬盘下载。 最近的数据将会在交易服务器上保存。 如果在硬盘上没有任何历史数据， 最近的512历史数据条将会被下载。 图表被打开后，有关当前的开价信息会收入终端内。 因此,未来价格的走势将会以真实的时间形态显示。 这些信息会储存于历史文件中，以便以后应用图表。

注意: "最大历史数据条" 和"最大图表数据条" 在 终端设置内已经被限定。 这些特性允许历史数据的显现和在硬盘上的储存。

脱机图表

客户终端允许脱机工作。这些图表在硬盘保存数据的基础上打开，以 HST 形式。 它们不会从服务器上刷新。这些图表更便于应用在非常规的证券和时期。

设置一个新的脱机图表， 需选择 "文件 — 脱机工作" 目录 来执行。 然后，在窗口中显现一个新标记, 按"打开"。 脱机模板 采用图表自动化。 这样， "(脱机)" 题词将会显现添加在图表的最上端。

在 专家测试,数据文件以FXT 形式 创建和应用。 它不同于常规图表，它能够脱机打开。


???? ? ????

开始使用 / 工作图表 / 图表属性

图表属性

图表是一种金融品种价格动态的时间模型，可以执行主菜单 "图表 — 属性..." 目录来显示图表属性窗口 ,也可以通过图表的右键菜单选择“属性”或直接按F8键来显示。 在此窗口中可以自定义图表颜色（颜色页中）：

  • 背景 —背景。
  • 前景 — 坐标轴，刻度和开高低收价格。
  • 网格 — 网格。
  • 阳柱 — 阳柱, 阳线的色度和材料。
  • 阴柱 — 阴柱, 阴线的色度和材料。
  • 阳线 — 阳线。
  • 阴线 — 阴线。
  • 折线图 —折线图和十字星。
  • 成交量 —成交量。
  • 卖出价 — 卖价。
  • 止损 —止损 (止损和获利)。

T窗口左边的图中能实时看到修改颜色的结果。除了手工选中颜色以外，在“颜色风格”的下拉列表框中还可以选择预定义的风格： "黑底黄色"，"黑底绿色"，和 "白底黑色"。选择不同的颜色风格时，对此风格的描述颜色也会改变。我们自己的颜色风格必须保存在 模板里.

此窗口能自定义常规图表属性，切换到“常规”属性页并选择所需选项：

  • 脱机图表 — 切换图表到离线模式. 选中这个选项将不能接收新的实时报价，也不能用新的价格数据画图。 取消此选项后就能接收和画出新的价格数据。 打开离线图表模式 "文件— 脱机图表" 目录 ), 此选项自动选中。
  • 前景图表 — 放置图表数据价格于 "前景". 如果这个功能开启, 所有的分析对象都放于其后. 此选项也可以通过主 "图表 — 图表前置"来实现。
  • 平移图表 — 允许/禁止从窗口的右侧移动图表.图表同样可以通过移动鼠标执行完成。
    选择 "图表切换" 功能 "图表" 工具或者选择"图表— 图表平移" 目录 功能相同。
  • 图表自动滚动 — 允许/禁止当收到新的报价时图表向左滚动. 如果选择这个选项, 图表将会显现出最近的情况。
    在图表工具条上选择 "自动滚动" 功能 "图表" 工具或者是选择 "图表 — 自动滚动" 目录 功能相同。
  • 固定比例1：1 — 固定比例 "1：1" ( A pips相当于一根图棒). 另外,选择"固定比例" 将会自动开启, 比例将会显示在窗口的右侧显示出.这是为了能够叙述准确的结构。
  • 固定比例 — 固定图表比例. 如果比例没有固定, 终端中的所有图表缺省为自动缩放比例， 选中此选项将不再自动缩放比例而是固 定比例，此时 "最大固定比例"和"最小固定比例" 被激活。
  • 柱状图 — 显示图表为柱状图表。
    在图表工具条上选择 柱状图 "图表" 工具, 或者选择 "图表— 柱状图" 目录 完成, 或者按 快捷键Alt+1功能相同。
  • 蜡烛图 — 显示图表为蜡烛状图表。
    在图表工具条上选择 蜡烛图 "图表" 工具, 或者选择"图表 — 蜡烛图" 目录 完成, 或者按 快捷键Alt+2功能相同。
  • 曲线图 — 显示图表为用收盘价连接起来的虚线。
    在图表工具条上选择 线型图 "图表" 工具, 或者选择 "图表 — 曲线图" 目录完成, 或者按 快捷键 Alt+3功能相同。
  • 显示开盘价，收盘价，最高价，最低价 — 显示/隐藏OHLC 价格线. 如果这个功能被开启,添加的数据将会在窗口的左上方显现. 价格会以下方式被记录：OPEN, HIGH, LOW and CLOSE (OHLC) —开盘价，收盘价，最高价和最低价。这样, 能够更为准确地看到最后的浮动。
  • 显示卖出价线图 — 显示/隐藏最近的卖出价线图. 在终端内柱和线仅仅能够显示出价. 无论怎样, 都需应用卖出价线图，去打开长的位置和关闭短的位置. 为了能够更为准确地检验交易活动, 选中此选项 "显示卖出价线图" 特性. 命令执行后, 添加的水平线 将会显现在图表里。
  • 显示时间区间 — 显示/隐藏时间区间. 时间和日期会精确地显示在图表内. 从1分钟到1小时图用天来区隔；4小时图用周来区隔；日线图用月来区 隔；周线图和月线图用年来区隔。同样也可以通过“程序选项”来实现相同的操作。
  • 显示网格 — 显示/隐藏图表窗口的网格。
    选择执行这个命令，可以选择选项 "图表" 目录完成, 或者按 快捷键Ctrl+G功能相同。
  • 显示成交量 — 在窗口的低端显示/隐藏成交量。
    选择执行这个命令，可以选择选项 "图表" 目录 完成, 或者按快捷键Ctrl+L功能相同。
  • 显示对象说明 — 显示/隐藏图表中的对象说明. 如果这个选项开启， 在可用到的图表上会有相应的说明, 它们将会直观的显现在图表上。


???? ? ????

开始使用 / 工作图表 / 图表控制

图表控制

图表是一种金融品种价格动态的时间模型，图表控制是：

  • 图表类型
    终端提供三种类型的金融工具图表：
  • 柱状图 — 柱状的依次排列。
    制作这种类型的图表,可以在工具条上选择 柱状图 "图表" 工具, 快捷键Alt + 1, 选择图表设置 窗口, 或者是选择 "图表 — 柱状图" 目录 执行完成。
  • 蜡烛图 — 蜡烛的依次排列。
    制作这种类型的图表,可以在工具条上选择 "Candlesticks" Chart "图表" 工具, 快捷键Alt + 2, 选择 图表设置 窗口, 或者是选择 "图表— 蜡烛图"目录 执行完成。
  • 曲线图— 用收盘价连接起来的虚线。
    制作这种类型的图表,可以在工具条上选择 线型图 button of the "图表" 工具, 快捷键Alt + 3, 选择 图表设置 窗口, 或者是选择 "图表 — 曲线图" 目录 执行完成。
  • 保存图表
    在终端内允许以文件格式"CSV", "PRN",和"HTM"保存运转图表的历史数据。
    用同样的方法去保存, 选择执行 "文件— 保存" 目录 完成 或者是按快捷键Ctrl + S.另外, 图表可以以BMP 或 GIF图片的格式保存 . 需选择选项 "文件—作为图片保存..." 目录 完成.也可以在图表窗口内直接保存，功能相同。
  • 打印图表
    打印彩色图表, 需在图表设置中选择"彩色打印" , 然后 选择执行 "文件 — 打印..." 目录 完成, 在图表窗口内直接选择打印,功能相同. 按 打印 "常规" 工具 或者快捷键Ctrl+P. 如果 "彩色打印" 已丧失, 或者是没有彩印设备, 图表将会以黑白形式打出。
  • 全屏图表
    选择执行 "查看 — 全屏" 目录 完成 或者是按 F11. 只有图表窗口, 主目录 和 图表转换条将会保留显示。
  • 附加MQL4程序
    在 MQL4 开始执行之前, 它必须要附加在图表上. 需在 "向导" 窗口内选择命令 MQL4 程序 双击鼠标或执行"附加图表" 完成. "Drag'n'Drop"技术能够充分的应用。
  • 使用指示器
    指示器是一种能够运算出定单中当前价格和成交量，从而预测未来价格走势。 以技术指标信息为基础断定以怎样的形式和什么时间开仓或平仓。指示器放入图表可以通过 "放入 — 指示器"目录 执行或控制指示器二级菜单， 选择 指标 "图表"工具条执行。"Drag'n'Drop" 技术允许指示器从 "导航" 窗口 到任一窗口。指示器的列表需在图表中查看 "数据窗口" 选择 "图表— 指示器列表"目录 执行或按快捷键Ctrl+I，功效相同。 更多细节查看技术指标 同名设置。
  • 工作对象
    在图表中利用多样化的图解对象来解析市场。做到这些需选择"插入" 目录 执行或选择"曲线研究" 工具条。 曲线研究, 图形, 信息, 和文本资料同属目录同一类。
    更多细节参考 "图解对象"部分。
  • 改变时段
    此客户终端支持九种不同的数据时段，从分钟到月.在进行技术分析指标和画线分析时，大量的图表时间周期是必要的。
    您可以在工具条上选择需要的"时段" ， 在"图表" 工具条选择 Chart Period , "图表 — 时段"目录, 或在图表窗口内执行完成。
  • 缩放图表
    图表能被缩放，这样就可以增减同时显示在屏幕上柱状图的数目。
    可以在 "图表" 工具条使用 [image] / [image] 操作, 或者使用快捷键"+"/"-", 或者在右键菜单中选择 "放大"/"缩小".
    此外, 你还可以在图表设置窗口中通过图表设置窗口 "固定比例"来设置缩放最大最小值。 The "固定比例1：1" 也可以通过同样的设置成 "1：1"。
  • 滚动，自动滚动和图表平移
    滚动就是左右移动图表中的价格数据。 此外, 图表可以应用F12滚动 (以"阶梯" 的形式 —滚动柱状向左) 或者Shift+F12 (滚动柱状向右), 或运用鼠标: 可以通过在图表中的任意一点按住鼠标左键后左右拖动鼠标或者按键盘上的左右键来滚动图表。 你可以使用快速导航线显示指明了时间和日期的图表区域。如果移动图表到没有价格数据的区域，缺少的柱状图会被自动下载。

    如果图表的等级已固定, 它能够自由的成垂直线滚动。

    “自动滚动”能一直跟踪最新柱状图。无论当前屏幕显示的是什么区域，自动滚动将会移动图表让你看到最新的柱状图。 可以在工具条上选择 Auto Scroll "图表" 工具 或者是 "图表 — 自动滚动" 目录 完成。

    "平移图表" “图表平移”功能键能从屏幕的右端移动最新的柱状图，图表平移能够用鼠标在尺寸10%到%50%的窗口内水平移动. 平移图表可以在工具条上选择 Chart Shift "图表" 工具 或者是 "图表— 平移图表"目录 完成。
  • 图表位置
    一般来讲，图表数据会显现在窗口的左边。拥有明确的时间条滚动或带有快速导航。当时间范围有变动时，它将会试图预测新的固定条来配合时间范围的变动。 最近的时间范围会显现在窗口左边。数据位置能够运用鼠标移动。它的显现只有在 "自动滚动" 失常时。这种程序应用起来更为适当，当 分析处于不同时间范围内的时段。

注意: 如果 "自动滚动" 开启，图表位置将自动关闭。
  • 使用模板
    模板记录了图表窗口的特性和利用的元素。 它保存了图表类型、时段、缩放比例信息和画线分析的设置、 技术指标和自定义技术指标信息。模板能方便的将不同的图表快速调整到同一类型。
    要调出模板控制菜单，可以选择"图表 — 模板" 目录 完成。 在图表窗口选择右键菜单“模板” "图表" 工具条. "保存模板..." 目录执行会储存一个新的模板, 即可以选择 "R取消模板"R— t删除现有的模板
    更多细节在 "模板和数据图表" 设置。
  • 使用数据图表
    数据图表呈现一种简洁的工作图表。当数据图表被储存，每个带有属性的图表将会在特定的位置找到。
    在目录中控制数据图表选择打开"文件— 数据图表" 目录 执行， 按 Profile "常规" 工具条, 或点击鼠标在显示条上执行完成。
    更多细节参考 "时段和数据图表" 部分。
  • 数据更新
    如果有任何错误 "漏洞" 出现在图表中，数据必须更新. 命令更新数据, 需选择选项 "图表 — 恢复" 目录 完成或图表窗口的相同名称. 待所有命令执行后, 遗漏的条将会自动从服务器上下载，并在图表中画出。

使用鼠标

能以如下方式通过鼠标直接控制图表:

  • 在图表中的任意点按住鼠标左键能水平拖动图表。
  • 在图表的垂直坐标刻度处按住鼠标左键并垂直拖动可以改变图表的垂直缩放比例。
  • 在图表的水平坐标刻度处( 快速导航线区) 按住鼠标左键并水平拖动可以改变图表的水平缩放比例。
  • 在图表中的任意点按鼠标右键能调出图表右键菜单。
  • 在技术分析指标上（各种线，符号，图表的柱 等等）双击左键能调出技术指标参数设置窗口。
  • 在图表中的任意点按鼠标右键能调出图表右键菜单。
  • 单击或双击, 取决于终端设置, 点击鼠标左键所选对象 (曲线研究, 正文或箭头) 将会选中对象。
  • 在所选对象上按住鼠标左键并移动，能移动所选对象。
  • 在所选的趋势线上同时按住CTRL和鼠标左键，并且移动，将会画出平行的趋势线 (创建一个通道)。
  • 在所选图表窗口内点击鼠标中间键转换光标到"十字丝"形式。
  • 在所选对象上点击鼠标右键可以调出对象设置窗口。
  • 将光标放置于平价柱上或物体元素上或者是指示器上会自动弹出提示。

菜单控制图表

一部分菜单命令能管理图表：

  • 智能交易 — 二级菜单控制智能交易. 智能交易是MQL4的一个程序。便于执行每个清单的核对，同时允许自动解析和交易激活。 应用二级菜单控制, 能够改变交易的所有权, 取消它, 或者开始 测试它。
    更多细节详见 "智能交易" 部分。
  • 删除脚本 — 删除运行脚本. 脚本是一个写在 MetaQuotes Language 4 (MQL4)内的程序， 示意执行一个单独的命令.
  • 技术指标 — 控制技术指标 附属于图表窗口。技术指标能够运算出定单中当前价格和成交量，从而预测未来价格走势。 在接收到指示器的信号后, 它会决定以怎样的方式和什么时间开仓或平仓。
  • 对象列表 — 控制 图解形式的对象. 要求以手动地形式图解终端内的对象，以达到分析的意图。
  • 周期 — 二级菜单控制图表周期。
    图表周期可以通过"图表"目录 和 工具条 执行。
  • 时段 —二级菜单控制图表的时间周期.时段是对图表窗口属性的设置，可以广泛运用到其他图表中。
    这个二级菜单控制可以通过"图表" 目录 执行，功效相同。
  • 刷新 — 刷新历史数据。这样，在所能提供的有效历史数据内，丢失的数据都将被下载。
    在"图表" 目录中执行有同样的效果。
  • 自动调整 — 设置图表为系统设定值。
    同样功能能够通过按快捷键 Ctrl+A。
  • 网格 — 显示/隐藏网格。
    同样功能能够通过 "图表" 目录执行或按快捷键Ctrl+G，功效相同。
  • 成交量 — 显示/隐藏成交量。
    同样功能能够通过"图表" 目录执行或按快捷键Ctrl+L，功效相同。
  • 放大 — 水平放大图表一倍。
    图表放大可以通过"图表" 目录 执行，按快捷键 "+" 或选择 放大 "图表"工具条，功效相同。
  • 缩小 — 缩小图表一倍。
    图表缩小可以通过 "图表" 目录执行， 按快捷键 "-"或选择 缩小 "图表" 工具条。
  • 删除指标窗口 — 从图表中删除指标窗口。一些指标被画在二级窗口内，拥有自己的级别。一般只允许删除二级窗口。
    更多使用技术指示器的细节参考通讯设置。
  • 另存为 — 保存工具的历史数据(GIF or BMP).
    同样功能能够通过"文件 — 以图片形式保存..."目录 执行完成。
  • 打印预览 — 预览即将打印的图表。
    同样功能能够通过 "文件— 打印预览"目录执行或按选择 打印预览 "常规"工具条，功效相同。
  • 打印... — 打印图表。 如果"彩色打印" 已被程序设置核实， 图表将会以彩色形式打印出。
    同样功能能够通过 "文件 — 打印..." 目录执行, 快捷键Ctrl+P, 或选择 Print Chart "常规" 工具条，功效相同。
  • 属性... — 被称作 图表窗口属性.
    同样功能能够通过按F8执行。

注意: "智能交易" 二级菜单,如果信息对象想要进入图表，只有在"删除脚本", "指示器列表", 和 "对象列表" 被激活的情况下。


应用物件列表

开始使用 / 工作图表 / 图表控制 / 应用物件列表

应用物件列表

“图表” 菜单和显示窗口的图表的快捷菜单允许访问应用图像物件，指标和EA交易的列表。因此可以修改物件属性或者从图表中删除物件。

指标列表

这个窗口可以用“ 指标列表 图表”菜单的 “指标列表”命令 或图表窗口的快捷菜单，再或者使用 "Ctrl+I" 热键来打开。T这个窗口允许管理应用到图表的指标。

这个窗口包括当前应用到图表的指标列表。指标分成两组：主图表窗口的指标和独立窗口的指标。当选定其中一个指标，“属性”和“删除”按钮被激活。“属性”按钮打开指标参量窗口。“删除”按钮从图表中删除指标。

物件列表

这个窗口可以用“ 物件列表 图表”菜单或者快捷菜单 的 “物件”子菜单中的“物件列表”命令，或者按下"Ctrl+B"热键来打开。这个窗口允许操作应用到图表上的各种图像物件。

这个窗口显示当前应用到图表上的所有物件 列表。这些物件按照以下字段显示在表格里：

  • 物件 — 物件种类。如果在“物件”勾选，那么该物件将被图表选中。
  • 名称 — 物件名。物件应用的图表周期外形成的名字，每一个物件类型及身份都是自动生成。名字可以在 物件属性中改变。
  • 描述 — 物件描述。可以在物件属性中改变。
  • 窗口 — 窗口号，物件应用的窗口。0代表图表主窗口，进一步的数字代表子窗口指标的倒序订单号。

“物件”窗口包含以下命令：

  • 显示 — 移动图表到选定物件。
  • 属性 — 编辑 选定物件的属性。
  • 删除 — 删除选定物件。
  • 列出全部 — 任何物件都可以设为隐藏（OBJPROP_HIDDEN property）从 MQL4 应用程序。这样的物件默认显示在图表上，而不显示在物件列表中。如果您点击“列出全部”按钮，隐藏的物件将显示在列表中。

使用Ctrl+A快捷键选择全部物件。


在线发布图表

开始使用 / 工作图表 / 在线发布图表

在线发布图表

客户端集成到MQL5.community以便为交易人提供获得强大而有用的服务。其中一项服务就是MQL5图表。它允许在线发布客户端的截图。只需点击几下鼠标您就可以发布一个屏幕截图，获得链接与您其他交易人分享或发送该链接到某个流行的社交网络平台 (Facebook, Twitter, VKontakte, Google+等等)。

您甚至无需拥有MQL5.community账户即可发布截图。如果您在程序端设置中没有指定您的账户，那么截图将会匿名发表而您将只得到其链接。

然而，绑定MQL5.community账户的发布会有许多明显的优势：您能创建自己的图片墙并通过您MQL5.community个人资料的“图表”标签管理它。

制作截图

要制作图表截图，请执行 另存为图片 快捷菜单中的“另存为图片”的命令。然后会出现下面的窗口。

将会提供如下选项：

  • Active workspace — 保存整个客户端窗口。
  • Active chart (as is) — 按当前大小保存当前图表。
  • Active chart — 指定保存图表的大小（像素）。
  • 在MQL5图表服务在线发布图片并获得该链接 — 如果禁用此选项，图表将会保存在用户电脑中。点击“OK”时，标准文件保存窗口将会出现。如果启用该选项，在MQL5图表服务将在线保存图表。图表评论可以添加到下面的空字段中。

在MQL5图表中在线发布图表

启用“在MQL5图表在线发布图片服务或获取链接”选项来在线发布客户端截图。文本注释可以添加到已发布的图片。单击“确定”按钮后，含有已发布图片的一个新浏览器窗口将立即被打开：

下面的数据位于图表显示窗口的顶部：

  • 自动生成的标头 - 当前图表交易品种和周期，发布日期和交易服务器名称。
  • 查看 — 截图查看数量。
  • 在社交网络发布截图的命令 — VKontakte，Facebook，Twitter，Google+，Evernote， Pinterest，LinkedIn，LiveJournal。点击其中一个即会带您转到相合适的网络资源。如果您已经授权一个社交网络，截图将会通过您的个人资料立即发布。

接下啦是截图本身。注释字段位于下面。如果发布过程中没有添加注释，那么将会显示自动生成的包含当前图表交易品种和周期的标题。

截图的各种链接显示在底部：

  • 链接到页面 — 截图查看页面的链接。
  • 图片 — 图片的直接链接。
  • HTML —在HTML页面源代码中插入链接。
  • bbCode — 支持bbCode标记语言的编辑器中插入链接（用于许多网络资源，论坛等）。

截图发布日期显示在窗口的底部。当鼠标悬停在该行之上时，会出现 删除 按钮。因此，任何已发布截图都可以删除。

MQL5.community 个人资料中的截图墙

正如上面所提到的，如果用户在程序端设置,中指定了他/她的MQL5.community账户，那么发布期间截图会绑定那个账户。 在MQL5.community个人资料，每个用户都有“图表”部分，在这里存储那个用户发布的所有图片：

点击图片缩微副本，您会转到 展示 窗口。“图表”标签允许您轻松管理您的图片墙并与其他社区成员和社交网络好友分享截图。

您甚至无需拥有MQL5.community账户即可发布截图。如果没有指定账户数据，将会匿名发布截图。


快速交易

开始使用 / 工作图表 / 快速交易

快速交易

要在图表上直接执行即时交易操作，可用一个特殊的面板。要激活它执行“ 单击交易 单击交易”命令在图表的快捷菜单中。

单击交易面板可以通过点击来显示或隐藏。 单击交易 在OHLC线的左侧。

使用此面板可以瞬间发送 指定交易量的市场买卖订单。

当在即时执行模式下进行交易时，订单中的价格可接受 偏差 根据 “偏差” 选项进行设定。


???? ? ????

开始使用 / 工作图表 / 打印图表

打印图表

在终端内存在一些打印图表的工具. 图表可以打印黑白和彩色两种形式. 打印彩色图表, 需在终端设置窗口内选择选项 "彩色打印" . 然后, 如果打印设备允许即可打印出彩色图表. 同样的, 图表将会以黑白形式打出.

有时需要安装现有的打印设备. 则需选择文件— 打印安装..." 目录 完成.

为了确保图表能够完整的打出, 可以选择选项"打印预览" 在同一目录中完成, 或选择 打印预览 "常规" 工具的按钮执行完成，功能相同.

打印图表需选择 "文件 — 打印..." 目录 执行完成, 或按 打印 "常规" 工具, 或者是快捷键ctrl+p完成.


????51; ????

开始使用 / 工作图表 / 删除图表

删除图表

在有些领域工作中图表不能很好的发挥作用, 所以我们需要删除它们. 删除需要点击 "文件 — 关闭"目录 执行或者使用 Ctrl+F4. 另外, 窗口删除的模板将会储存，如果"保存删除图表到再次打开." 这可能在 用户终端设置窗口内. 这些模式在将来会得到充分的应用. 所以, 如果图表在偶然间被删除 , 还可以将其还原. 还原图表需点击 "文件 — 打开删除" 目录执行 ，然后再列表中选取. 然后, 在删除窗口内选取恢复全部属性和完整图表.


??????? ? ????

开始使用 / 工作图表 / 模板和输入数据

模板和输入数据

模板是一组能应用到其他图表的图表窗口属性。除了金融品种和时段，所有的图表属性都能存储在模板 里。包括：

  • 图表类型和颜色。
  • 颜色示意图。
  • 图表比例。
  • 显示或隐藏开高低收线。
  • 智能交易系统及其参数。
  • 自定义指标和技术分析指标及其设置。
  • 画线分析。
  • 数据间隔。

当模板覆盖图表时，模板里的设置将会应用到图表的基本数据中（金融品种和时段）。比如，你可以创建一个包括MACD、 RSI和移动 平均线指标的模板，然后将其应用到其他图表，这样，不同的金融品种和时段的图表窗口就会有相同的外观。

这些模板以TPL的文件格式存储在模板文件夹下。模板一旦被创建，它就可以无限制的被使用多次。在安装终端软件的过程中会创 建一个常规模板DEFAULT.TPL，以后，可以在图表活动窗口的属性中改变这个模板。

为了创建一个新模板，你可以选择主菜单" 图表 — 模板— 保存模板..."，也可以图表右键菜单里选择相同的 命令或者在 "图表"工具条里选择 Templates 按钮。 这样，基于图表活动窗口里信息的一个新模板就会被创建。要改变已存的模板也可以执行 上述操作，选择一个已经存在的模板，只是要换一个新的文件名。从模板控制菜单中选择需要的模板文件可以覆盖在图表窗口。 选择主菜单"图表 —模板 —删除模板"删除选择的模板。

注意: 模板"DEFAULT.TPL"不能被删除。

Profiles

图表夹的概念提供了一个 操作多组图表的方便模式。打开图表夹时，包括所有设置的每个图表都会精确定位在这些图表夹被保存时的位置。 当前图表夹的所有图表窗口列表都在主菜单 "窗口" 下，列表中的所有图表窗口的变化都自动保存在当前图表夹中。 当前的图表夹名称显示在状态条上，并且图表夹控制菜单中的此图表夹名前面的选择框会被选中。 在终端安装的过程中将会创建缺省的图表夹。最初在图表夹中保存四个主要货币对 "EUR/USD"， "USD/CHF" "GBP/USD" 和 "USD/JPY"。 的四个图表窗口。

所有的图表夹管理命令都在主菜单中，选择主菜单"文件— 图表" 或者选择"常规"工具条 Profiles 按钮 调出此命令。为了使用新图表夹，必须要在菜单列表中选择一个需要的名称。图表夹控制菜单里的选项“保存图表夹”能保存图表窗口 的当前配置，“删除图表夹”能删除图表夹。

"下一个图表夹"和按Ctrl+F5键将搜寻下一个图表夹。

注意: 当前的图表夹和缺省的图表夹(DEFAULT)不能被删除。

在客户端内模板可以确定交易账户。模板的名称必须与交易账户数字相符。 在打开交易账户时，相应的模板将会自动打开。 如果没有前模板，当前模板将会保持原状。


???? ? ????

开始使用 / 分析

分析

技术指示物 和 曲线研究为了分析的目的建立在终端内. 这些直接显示在图表内，可以预测未来的价格变化. 另外，指示器被自动安装, 曲线研究被手动的附加上.这就是为什么当运用曲线研究工作时,需合适的画出它们. 指示器的特性能够手动地建立。技术指示器能够对于不同的记号或时期拥有不同的设置。

技术指示器和曲线研究的应用允许适当的开启和关闭.交易位置, 地点和修改 未定的定单. 再者,分析工具的运用允许执行系统化的交易活动和缩小人类情感的影响. 顺着技术指示器, 客户指示器 写入MetaQuotes Language 4 (MQL4) 对于分析的目的能够运用。没有曲线研究或相似的工具能够写入MQL4。


???????

开始使用 / 分析 / 图解对象

图解对象

应用手动在终端内图解对象用于分析。 它们包括：

  • 画线分析 — 对于价位和指标拥有多样的图解形势和曲线。 包括江恩 ，斐波纳奇 ，安德鲁分叉线，甘氏等等。 更多详细信息查看 画线分析。
  • 图形 — 使用几何体（矩形、三角形、椭圆形）在报价图表中标明不同的区域。
  • 箭头 — 使用符号（箭头、测试和停止符号）在报价图表中突出标明重要的事件。
  • 文字 — 文字用于在图表中进行注释。它会随着图表而滚动。
  • 文字标记 — 文字标记被附加在另一窗口，不存在于图表中。图表滚动时，文字标记将不会移动。

所有对象在 "插入"菜单中 可以使用"画线分析"工具操作。在列表中所选定的对象可以放入图表 (或指标窗口)。

注意:当选定一部分对象时，若没有全部执行完成，图表内将不会显示。

对象被创建后，可以移动或修改。 首先，需要选定对象。如果在终端属性内 "单击所选对象"参数。 如果没有执行，可双击鼠标左键。标记试图移动对象和改变画出的参数。 例如，改变斐波纳契扇形线位置，利用鼠标左键和移动光标掌握 它的中心市场。 最终的市场 结果将会直接改变画出对象的参数。 终端可以快速创建对象的复制版本。可以选择对象按住Ctrl键移动它到中心市场。

在图表中的所有对象或早或晚将不可用。这样，可以在执行目录中删除它。另外，后退键允许从单组内删除。所有删除的对象可以恢复。 可以在目录中选择执行 "取消删除""图表— 对象— 取消删除" 菜单或者用快捷键Ctrl+Z。

对象属性

每一对象都拥有自己的属性。对于对象属性的管理，可以选择对象和它的执行菜单 "属性"， "图表 —对象 —对象列表"菜单执行。随后，属性窗口将会自动显现。

通常对象的属性在"常规"表内，包括以下内容：

  • 名称 — 在窗口上方显现图表名称。当其他名称进入时它将被改变。 这样的命名可以清楚地划分开来。
  • 描述 — 相关对象描述/文章。 另外，这些描述可以显现在图表内若点击"显示对象描述"在 图表属性内。
  • 风格 —曲线对象的风格。可以选择曲线的颜色，形状和厚度。
  • 设对象为背景 — 在图表后，设对象为背景。开启这一选项，为对象填充外形和通道(除斐波纳契通道)。

在"参数"表内可以起到协调整理的作用。图表中的时间坐标选择进入 "时间" ，固定图表指标的垂直坐标轴，选择进入"价值"。一个对象拥有一到三个坐标。

一些对象，所添加的选项在"参数"表内：

  • 角度 —逆时针倾斜对象的角度。
  • 比例 — 对象的垂直坐标轴和水平坐标轴的比例。一般来讲，当画图表时水平轴的像点不同于垂直轴。 同样价值的情况下以1：1 显现。对于特殊的对象，可以相应调整参数。
  • 箭头 — 对象编码。
  • 射线 — 以射线形式显示对象的趋势。
  • 固定 — 固定图表角的文章标记。
  • X-距离: —窗口中固定角和文章标记的水平距离。
  • Y-距离: —窗口中固定角和文章标记的垂直距离。

在"显现"表内可以改变时间段。只有在选定时间段后对象才会显示。 当工具对于不同的时间段拥有不同设置，更为便捷。"斐波纳契水平线" 只允许应用斐波纳契工具。在这表内全部可以显现。水平线可以改变或删除( "删除"按钮)。 添加新的水平线按"添加"按钮。另外，如果"(%$)" 进入到"描述"中，价格将会伴随水平线显示在图表内。 "默认"设置原有状态。"风格"允许设置图表水平线的颜色，样子和厚度。


?????????

开始使用 / 分析 / 图解对象 / 画线分析

画线分析

画线分析是在价格和技术指标图表中画上线条和几何图形。包括支撑/阻力线、趋势线、斐波纳奇、江恩和安德鲁分叉线等等。

在软件终端，画线分析组合在"插入" 菜单 和 "画线分析"工具条 中。 应用对象需选择按工具条按钮或者菜单执行。

b | 菜单命令 | 描述
Horizontal Line | 水平线 | 水平线用来标示不同的水准。特别是用来标示支撑和阻力位。支撑位是指当价格受买方(多头)控制时，阻止其下跌的水准。阻力位则相反，当价格受卖方 (空头) 控制时，抑制其进一步上涨的水准。
Vertical Line | 垂直线 | 垂直线一般用于在时间轴上标示不同的界限，或用于技术指标信号和动态价位的比较。
Trendline | 趋势线 | 趋势线便于揭示价格趋势。为了设定趋势，您必须确定两点位置，然后接连这两个点成一条线。
Trendline by Angle | 角度趋势线 | 趋势线有助于揭示价格的发展走势。与简单的趋势线相比，运用此工具您可设置趋势线度数。
Linear Regression Channel | 线性回归通道 | 线性回归是统计学的分析工具，基于可利用数据预测今后的价值。在上涨趋势下，假设下一个棒图将高于前一个棒图。在这种逻辑假设下，线性回归方法可获得此假设的统计确定。您需要设定两个点创建这一工具。
Equidistant Channel | 等距通道 | 等距通道（平行线）指一种趋势通道。这类通道线总是平行的。为创建这种工具，您必须确定两个点
Standard Deviation Channel | 标准偏差通道 | 标准偏差通道。标准偏差是用统计的方法测量波动性。标准偏离影响此通道的宽度。您必须调整两个点来创建此工具。
Gann Line | 甘氏４５度线 | 甘氏45度线是45度角的趋势线。您必须设定两个点来创建此工具。
Gann Fan | 甘氏扇形线 | 甘氏扇形线是从一点以不同角度画出的一组趋势线， 1x1趋势线(45度)是最重要的一条线。如果价格曲线高于此线，意味着市场向好，如果低于此线，市场向淡。 1x1(45度) 甘氏扇形线被认为是在上升趋势下的一条强大的支撑线，突破此线被认为是一转向信号。您需要设定两点来创建甘氏扇形线。
Gann Grid | 甘氏网格线 | 甘氏网格线是一条45度角的网格线。您必须设定2个点来创建此工具。
Fibonacci Retracement | 斐波纳契回撤 | 斐波纳契回撤是Leonardo Fibonacci发现的数字逻辑推论，即每一个随后的数据是前两个数字的总和： 1， 1， 2， 3， 5， 8， 13， 21， 34， 55， 89， 144等等。每个数据约等于前一个的1.618倍，且每个前一数据相对于后一数据的0.618。此工具是运用决定的趋势线上两点来创建的。然后画出9条水平线， 斐波纳契水平： 0.0%， 23.6%， 38.2%， 50%， 61.8%， 100%， 161.8%， 261.8% 和 423.6%与趋势线交叉。
Fibonacci Channel | 斐波纳契通道 | 画出斐波纳契通道需用宽度隔开。 不同于斐波纳契序列，数据参数宽度为0.618 倍， 然后 1.000, 1.618, 2.618, 4.236, 依次相承。此工具是运用决定的趋势线上两点来创建的。
Fibonacci Time Zones | 斐波纳契时间周期线 | 斐波纳契时间周期线是以斐波纳契的时间间隔1， 2， 3， 5， 8， 13， 21， 34等画出的许多垂直线。假定主要的价格变化期望在这些线附近。运用确定的单位时间间隔长度的两点来创建此工具。
Fibonacci Fan | 斐波纳契扇形线 | 斐波纳契扇形线。此工具是运用确定的趋势线的两点来创建的。然后通过第二点画出一条“无形的(看不见的)”垂直线。然后，从第一个点画出第三条趋势线，并与斐波纳契水平：38.2%， 50%和61.8%的无形垂直线交叉。主要的价格变化被预期位于这些线附近。
Fibonacci Arcs | 斐波纳契弧线 | 斐波纳契弧线。此工具是运用确定的趋势线的两点来创建的。然后三条弧线均以第二个点为中心画出，并在趋势线的斐波纳契水平：38.2%， 50%和61.8%交叉。主要的价格变化被预期位于这些线附近。 。
Fibonacci Expansion | 斐波纳契扩展 | 斐波纳契扩展。运用画出两条波浪的三个点来创建此工具。 然后画出的三条线，与斐波纳契水平：61.8%，100% 和161.8%的第三条“无形”线交叉。 主要的价格变化被预期位于这些线附近。
Andrews' Pitchfork | 安德鲁分叉线 | 安德鲁分叉线。运用三个点并画出三条平行走势线用来创建此工具。 第一条趋势线从三点中最左边点(此点为重要的顶点)开始刚好画在最右边两点中间。此线相当于分叉线的手。然后， 第二条和第三条趋势线从最右端两点开始平行于第一条线画出（这是重要的最高点和最低点），这些线相当于交叉线的牙齿。 安德鲁交叉线的理论是基于支撑和阻力线的标准原理。
Cycle Lines | 周期线 | 周期线。此工具画出相等时间间隔的许多垂直线。通常地，单位时间间隔相对应一个周期。在这种情况下，通过假定的这些线描述未来的周期。运用两个点及确定单位时间间隔的长短，来创建此工具。

趋势线可以在图表内成组移动，如果它们的节点位于彼此极其接近的地方（2个像素范围内）。


?? ? ????

开始使用 / 分析 / 技术指标

技术指标

技术分析指标是将金融品种的价格和/或成交量进行数学运算去预测未来的价格变化。技术分析指标信号能帮助决定是否开仓或平仓。 通过功能属性判断，技术分析指标能分为两类： 趋势指标和震荡指标。趋势指标可以确立价格向某个方向运动以及同时或滞后出现的 价格拐点。震荡指标可以提前或同时确立价格的拐点。

技术分析指标可以通过以下方式调出：从 "导航"窗口 窗口中选中"技术指标"， 或选择主菜单"插入— 指标" 完成的或者按" 图表" 工具条中的 [image] 操作。 技术分析指标可能通过技术指标窗口的树状列表创建（如MACD）

也可能就在价格图表中创建（如Moving Average）。

在这种情况下， 创建技术分析指标不但可以基于价格数据和它们的衍生属性（中值， 类型，权重），而且还可以基于其他指标来创建。 比如，你可以基于Awesome Oscillator 来创建Moving Average indicator ，这样你就能在AO上增加一条信号线， 因此，你首先建立了AO指标，然后是MA指标。接着，你设置字段"应用"中选择"前一指标的数据"(使用前一指标的数据调用指标)。 如果你选择“第一个指标的数据”，那么MA将基于第一个指标的数据构建，那么AO指标将是没有必要的。

在设置技术分析指标时，除了可以设置分析参数以外，还可以设置线的颜色，粗细和字体的大小。往后所有的设置将都可以改变。 要实现上述功能你可以在图表的右键菜单中选择"技术指标－编辑"或者在技术指标的右键菜单中选择"指标属性。。。" （当你在需要的曲线、符号、柱状图上点击右键时就会弹出技术指标的右键菜单）。

要删除技术指标， 你可以在图表右键菜单中选择 "技术指标－删除" 或在技术指标右键菜单中选择"删除技术指标"。 技术指标右键菜单还包括“删除指标窗 口”的命令，它将删除技术指标窗口及其所有内容。

注意:如果你将鼠标光标放在技术指标线、符号或柱状图上，你可以得到技术指标的精确值。


????? ?????????

开始使用 / 分析 / 技术指标 / Accelerator/Decelerator Oscillator

加速和减速震荡指标 — AC

加速/减速技术指标反映了当前趋势的加速和减速。在任何趋势变化之前，该指标将会改变其运动方向。 趋势的变化，在价格变动之前也会改变其运动方向。如果你能意识到加速/减速指标是一种提前预警信号的话， 它就会给你带来明显的优势。

零点线基本上是趋势与加速保持平衡的那个点。如果加速/减速指标高于零点线的话，通常对于加速继续向上运动是比较容易的。 （反之，如果低于零点线的话，则继续向下的运动是比较容易的）。不象在考虑 Awesome Oscillator动能指标的情况下，越过零点线被视为是一种信号。 我们所要做的唯一的事情就是控制市场和做出决策来观察颜色的变化。为了不浪费你认真的思考，你必须记得：当前栏为红色时， 你不能借助于加速/减速指标来买进外汇；当前栏为绿色时，你也不能借助它来卖出外汇。

当你顺着趋势的方向进入市场时，（你买进外汇，指标通常高于零点线；你卖出时，指标通常低于零点线）然后你只需买进两栏绿色 （卖出两栏红色）。当趋势与所入市的方向相反时，（指数低于零点线时，买进外汇；高于零点线时，卖出外汇）这个时候， 我们需要进行确认，因此你需要另外一个额外栏。在这种情况下，指数通常表现为：在长期的位置上，三条高于零点线的红栏； 在短期的位置上，三条底于零点线的绿栏。

计算方法

AC柱型图的数值为趋势柱型图数值的5/34和五段简单移动平均值之差。

AO = SMA (子午价，5)-SMA（子午价，34） AC = AO-SMA(AO, 5)

注解:
SMA — 简单移动平均值。
AO — AO动能指数。


???? ?????

开始使用 / 分析 / 技术指标 / Accumulation/Distribution

离散指标(A/D)

离散技术指标是由价格和成交量的变化而决定的。成交量在价格的变化中充当重要的权衡系数。 系数越高（成交量），价格的变化的分布就越能被这个技术指标所体现（在当前时段内）。

实际上，这个指标是另外一个更为普遍使用的能量潮指标成交量的变体。这两个指标都用来通过衡量各自的销售成交量来确认价格的变化。

当离散指标增长时，就意味着积累（购买）了某一特定的证券，因为此时，占绝对份额的销售成交量与正在上升的价格趋势相关了。 当该指标下降时，意味着分配（卖出）某一证券，此时在价格运动下降的同时，有更多的销售正在进行。

离散指标和证券价格之间的差异表明即将到来的价格变化。原则上，在这样的差异情况下，价格的趋势会向着该指标移动的方向顺时移动。 因此，如果该指标增长时，证券的价格相应下降，我们因此可以预料到价格的回落。

计算方法

从该指标的当前的积累值中添加或扣除一定份额的日交易量。收市价越接近当天最高的价格时，被添加的份额越大。 收市价越接近当天最低的价格时，被扣除的份额越大。如果收市价正好在当天最高和最低价格之间，那么这个指标值不变。

A/D = SUM[((CLOSE — MINIMUM) — (MAXIMUM — CLOSE))*VOLUME/(MAXIMUM — MINIMUM), N]

注解:

CLOSE — 平仓价格。
LOW — 柱的最低价。
HIGH — 柱的最高价。
N — 周期的数量在运算中被运用。
SUM (..., N) — N个周期的总和。
VOLUME — 交易量。


????? ????

开始使用 / 分析 / 技术指标 / Alligator

颚鱼指标

"大部分之时间里，市场是保持静止的状态的，只有在15-30%的时间间段内，市场才会产生趋势 。那些不把自己的精力只定位在外汇交易本身的交易员主要是从这种趋势当中获得利益。我的祖父以前总是反复强调说： "即便是一只失明的小鸡也会找到它所要的玉米，如果人们总是在同一时间喂养它的话。"我们况且称这样的趋势贸易 "失明小鸡市场"。 或许我们要数年的时间来等待到这样一个市场，但是毕竟我们已经获得了这样一个指标，可以使得我们摩拳擦掌，直到等到它。"

Bill Williams

原则上来说 鳄鱼技术指标是使用了分形几何学和非线性动能学的平衡曲线 (移动平均线) 的组合。

  • 蓝线(鳄鱼的下巴) 是用以绘制图表时间框架的平衡曲线。 （十三段 顺畅移动平均线，以8栏的速度向未来方向延伸）。
  • 红线 (鳄鱼的牙齿) 是较低一级的价值时间框架的平衡曲线。 （八段顺畅移动平均线 ，以5栏的速度向未来方向延伸）。
  • 绿线（鳄鱼的嘴唇） 是更低一级的价值时间框架的平衡曲线。（五段 顺畅移动平均线， 以3栏的速度向未来方向延伸）。

鳄鱼的嘴唇，牙齿和下巴显示出不同时间段的相互作用。因为我们只有在每个时间段的15-30%的 部分里看到比较清晰的趋势，所以，遵循这些时间段是非常必要的， 我们也需要避免研究那些只有在某个时间段内波动的市场。

当下巴，牙齿和嘴唇都闭合或者是相互纠缠时，就表明鳄鱼要睡觉了或者已经睡着了。当它睡觉时， 会变的越来越饥饿，鳄鱼睡的时间越长时，它就会越饿，越早醒来。当它醒来后所做的第一件事情就是张开它的大嘴巴， 打个哈切。然后食物的味道会进入它的鼻子里：一头公牛的肉或者是一只熊的肉。随后鳄鱼就开始捕猎它们。 当鳄鱼进食完毕，感到足够的饱了，它就开始对食物（价格）失去了兴趣（平衡曲线重合在一起）此时就是收获利益的时候了。

计算方法

MEDIAN PRICE = (HIGH + LOW) / 2

鳄鱼的下巴 = SMMA (MEDEAN PRICE, 13, 8)

鳄鱼的牙齿 = SMMA (MEDEAN PRICE, 8, 5)

鳄鱼的嘴唇 = SMMA (MEDEAN PRICE, 5, 3)

注解:
MEDIAN PRICE — 中间价。
HIGH —最高价格柱。
LOW — 最低价格柱。
SMMA (A, B, C) — 顺畅移动平均线。
ALLIGATORS JAW — 鳄鱼的下巴（蓝线）。
ALLIGATORS TEETH — 鳄鱼的牙齿（红线）。
ALLIGATORS LIPS — 鳄鱼的嘴唇（绿线）。


???? ? ?????????

开始使用 / 分析 / 技术指标 / Average Directional Movement Index

平均方向性运动指标

平均方向移动指数技术指标帮助我们确定是否存在一个价格趋势。这一指数是由Welles Wilder开发出来的， 并且在他的《新概念贸易体系》一书中详细描述的。

基于这个指标体系最为简单的贸易方法就是对两个方向指标进行比较：14段 +DI 指标和 14段 ?CDI 指标。 为了进行比较，我们要么把一个指标图表叠加到另外一个指标图表上， 要么，我们从-DI指标里扣除+DI指标。 W. Wilder 建议在+DI指标高于-DI指标时进行买入， 在+DI指标下沉到低于-DI指标时进行卖出。

T对于这些简单的商业法则来说，他附加了一条"极点法则"，这一法则被用来消除错误的信号并且降低交易的数量。 根据"极点法则"的原则，"极点"是+ID指标和-ID指标相互交合的那一点。 当+ID指标上升的比-ID指标高的时候，它们两者相交时， 这一点就会成为当天的最高价格。如果+ID指标低于-ID指标的时候，两者再次相交时候，这一点就会成为当天的最低价格了。

到了那个时候，极点就被用来作为市场准入的水平。因此，当购买信号发出后（+ID指标高于-ID指标时）， 我们必须等到价格超过“极点”的那个时候在来进行购买。当然，如果价格未能超过"极点"水平的话， 我们应该保持原来的短线位置。

计算方法

ADX = SUM[(+DI-(-DI))/(+DI+(-DI)), N]/N

注解:
N — 是在计算中所使用的时间段的数值 。


???? ?????????

开始使用 / 分析 / 技术指标 / Average True Range

平均波幅通道指标

平均波幅通道技术指标(ATR)是显示市场变化率的指标。这一指标是由WILDER开发的， 并且在他的"新概念技术贸易体系"一书中详细的进行了论述。这一指标是无数其他指标以及之后其它贸易体系的组成部分。

由于惊恐购买所驱使的价格的剧烈下跌，这一指标在市场底部通常可以达到一个较高的价值。 这一指标对于长期持续边幅移动的时段是非常典型的，这一情况通常发生在市场的顶部，或者是在价格巩固期间。 平均波幅通道技术指标依据同样的原则，可以被解释成为其他一些易变指数。 根据这个指标来进行预测的原则可以表达为：该指标价值越高，趋势改变的可能性就越高；该指标的价值越低，趋势的移动性就越弱。

计算方法

下面罗列的三种波幅通道数值最大:

  • 当前最大和最小值之差（最高和最低值）。
  • 上一收市价和当前最大值之差。
  • 上一收市价和当前最小值之差。

平均波幅通道指标是该波幅通道的移动平均线的数值 。


????? ????

开始使用 / 分析 / 技术指标 / Awesome Oscillator

震荡指标

AO动能技术指标是（AO）34段简单移动平均线，其轨迹通过柱形中间点（H-L）/2，这一点是从五段简单移动平均线中扣除的， 它建立在横跨（H-L）/2柱形中间的那点上，并且向我们清楚的显示了当前市场趋势的一个状况。

购买的信号

茶托

只有当柱形图高于零点线时，唯一的购买信号才会到来。我们必须牢记:

  • 当柱形图由下降的趋势变化为上升时，才产生“茶托”购买信号。第二栏比第一栏低，并且第二栏是红色。
  • 第三栏比第二栏高，而且第三栏是绿色的。

请记住：为了能使用“茶托”信号，所有的AO动能指标都应超过零点线。

零点线相交

当柱形图由负值的区域向正值的区域过度时，会产生购买的信号。 当柱形图通过零点线以后，购买信号也随之而来。关于这个信号:

  • 为了使信号产生，我们只需要两栏。
  • 第一栏应该低于零点线，第二栏应该穿过它。（从负值转化为正值）。
  • 购买信号和卖出信号同时产生是不可能的。

两个箭头

当柱形图的价值低于零点线，唯一的购买信号才会产生。关于这个信号，我们请牢记：

  • 当你有一个向下的箭头（最小值），并且这一点低于零点线，还有一个方向同时往下的尖头紧随其后， 它的位置比上一个箭头稍高一点。其绝对值比较小（因此离开零点更近一些），在这种情况下，购买信号才会产生。
  • 柱形图低于两个箭头之间的零点线。如果柱形图穿过两个箭头之间的部分 ，购买的信号不会起作用。当然，与零点线相交时，购买信号会产生。
  • 柱形图的每一个新的箭头（一个接近零点线并且绝对值比较小的那个负数）其数值高于前一个箭头。
  • 如果形成了另外一个数值较高的箭头（接近零点线），并且柱形图没有穿过零点，那么会产生一个额外的购买信号。

卖出信号

AO动量指标的卖出信号和购买信号相同。“茶拖”信号则相反，而且其低于零点线， 穿过零点线的机会会减小——第一栏高于零点线，第二栏低于零点线。两个箭头的信号高于零点线也可低于零点线。

计算方法

AO34段简单移动平均线，其轨迹通过柱形中间点（H-L）/2，这一点是从五段简单移动平均线中扣除的， 它建立在横跨(H+L)/2柱形中间的那点上。

MEDIAN PRICE = (HIGH+LOW)/2

AO = SMA(MEDIAN PRICE, 5)-SMA(MEDIAN PRICE, 34)

注解:
SMA — 简单移动平均值。


技术指标 — 熊市指标

开始使用 / 分析 / 技术指标 / 熊市指标

熊市指标

每天的交易都表示为将价格推高的购买者("牛市") 和将价格拉低的出售者("熊市") 的战争。根据谁打败谁，每天都会以或高或低于前一天的价格收盘。中间结果，首先，全部最高和最低价，允许判定每天的战争如何发展。

能够评估最初可能发生逆转的熊市平衡很重要。该任务使用Alexander Elder 开发的熊市振荡器指标来解决并在名为为生活而交易的书中描述。Elder根据以下前提得出该振荡器：

  • 移动平均线是某一特定周期出售者和购买者之间的价格协议。
  • 价格最低时就表示一天中出售者最多。

这些前提下，Elder开发熊市表示为最低价和13-周期指数移动平均线之间的不同（LOW-EWA）。

应用

该指标与趋势指标搭配使用更好（大部分时间是移动平均线指标）：

  • 如果趋势指标向上而熊市指数指标低于零，但却处于发展状态，这就是买入信号；
  • 这种情况下，需要基础分歧在指标图表中形成。

计算

该指标计算第一阶段是计算指数移动平均线（通常情况，建议使用13-周期 EMA）。

BEARS = LOW - EMA

这里：
BEARS — 熊市。
LOW — 当前柱的最低值。
EMA — 指数移动平均线.

下降趋势中，LOW低于EMA，所以熊市低于零而柱状图位于零线以下。如果价格上升时LOW超过EMA，熊市高于零并且其柱状图高于零线。


???? ????????

开始使用 / 分析 / 技术指标 / Bollinger Bands

保力加通道指标

保力加通道技术指标（BB）与包络线技术指标相似。 唯一的差别在于包络线技术指标是以固定的距离（%） 偏离移动平均线而进行轨迹移动的，而保力加通道技术指标是以一 定数量的标准偏差值偏离移动平均线而进行轨迹移动的。 标准偏差值是测量易变性的一个标准。 因此保力加通道技术指标应市场条件而变化。当市场变化较快时，通道宽度会增加，易变时间段较小时，通道宽度会缩小。

保力加通道技术指标通常按照价格图表轨迹移动，但有时它也可被添加到指标图表里（习惯图表）。 就象有包络线指标的情况一样，保力加通道指标的解释是根据价格往往保持在通道的顶线和通道的底线之间这样一个事实。 保力加通道指标的一个明显的特征就是其可变的通道宽度取决于价格的易变性。在价格变化相当厉害的一个时间段里 （比如，高变化率）通道宽度会留出大量的空间来让价格进入，] 在停滞阶段，或是在变化率较低的时间段里，通道宽度的缩小会使得价格保持在其限额之内。

保力加通道指标的一些独特的特点:

  1. 因为变化率的下降，价格的突然变动往往会在通道宽度缩小后发生。
  2. 当价格突破通道上部时，我们一般会预计到一个持续性的实事趋势。
  3. 当通道外的箭头和空洞带动通道内的箭头和空洞，我们可以预计到一个相反的趋势。
  4. 某个通道线路上开始的价格的移动通常会到达另外一个通道的线路上，最后的观察对于价格的预测可以说是非常的有用的。

计算方法

保力加通道指标由三根线组成，中线（ML）通常是移动平均线。

ML = SUM [CLOSE, N]/N

通道顶线（ML）和通道中线相同，离开通道中线有一定距离的标准偏差值（D）

TL = ML + (D*StdDev)

通道底线，和通道中线相同，向下离开通道中线一定距离的标准偏差值

BL = ML — (D*StdDev)

注解：
N — N —计算中所使用的时间段的数值;
SMA — 简单移动平均线。
StdDev — 标准偏差值。
StdDev = SQRT(SUM[(CLOSE — SMA(CLOSE, N))^2, N]/N)

建议20段 简单移动平均线作为通道中线，离开该段上下通道曲线两个标准偏差值的距离进行轨迹移动， 此外，小于十段的移动平均线没有影响。


技术指标 — 牛市指标

开始使用 / 分析 / 技术指标 / 牛市指标

牛市指标

每天的交易都表示为将价格推高的购买者("牛市") 和将价格拉低的出售者("熊市") 的战争。根据谁打败谁，每天都会以或高或低于前一天的价格收盘。中间结果，首先，全部最高和最低价，允许判定每天的战争如何发展。

能够评估最初可能发生逆转的牛市平衡很重要。该任务使用Alexander Elder 开发的牛市振荡器指标来解决并在名为为生活而交易的书中描述。Elder根据以下前提得出该振荡器：

  • 移动平均线是某一特定周期出售者和购买者之间的价格协议。
  • 价格最高时就表示一天中购买者最多。

这些前提下，Elder开发牛市表示为最高价和13-周期指数移动平均线之间的不同 (HIGH - EMA)。

应用

该指标与趋势指标搭配使用更好（大部分时间是移动平均线指标）：

  • 如果趋势指标下降且牛市指标指数在零以上，但却处于下行，则是卖出信号。
  • 这种情况下，需要峰值分歧在指标图表中形成。

计算

该指标计算第一阶段是计算指数移动平均线（通常情况，建议使用13-周期 EMA）。

BULLS = HIGH - EMA

这里：
BULLS — 牛市。
HIGH — 当前柱的最高价格。
EMA — 指数移动平均线。

上升趋势中，HIGH高于EMA，所以牛市高于零且柱状图位于零线以上。如果价格下跌HIGH降到EMA以下，牛市就在零以下且柱状图跌到零线以下。


????? ????????

开始使用 / 分析 / 技术指标 / Commodity Channel Index

商品通道指数指标

商品通道指数技术指标（CCI）测量商品价格与其平均统计价格的偏差值。 该指数的高值表明，与平均价格相比，价格通常是高的。 低值说明价格过于的低了。商品通道指数可以充当除了器皿以外的任何金融测算工具，就好像起它的名字一样。

有两种基本的使用该指标的技巧:

  1. 找出偏差
    当价格达到一个新的最大值时，偏差出现了，商品通道指数不会超过前一个最大值。 这种典型的偏差通常伴随着价格的修正而发生。
  2. 作为一个过度买进和卖出的指标
    商品通道指数通常在+ -100的范围内变化。超过+100的数值表明过度买入了 （可能出现修正减小的可能性）小于-100的数值表示过度卖出了（可能出现修正增加的可能性）

计算方法

  1. 为了发现一个典型的价格，你必须在每个柱上添加高，低和闭合的价格然后把结果除以三

TP = (HIGH + LOW +CLOSE)/3

  1. 计算典型价格在N段的 简单移动平均线。

SMA(TP, N) = SUM[TP, N]/N

  1. 从典型的价格里扣除已经得到的简单移动平均线。

D = TP — SMA(TP, N)

  1. 计算绝对值D在N段的简单移动平均线 。

SMA(D, N) = SUM[D, N]/N

  1. 0.015乘以得到的简单移动平均线（D，N）

M = SMA(D, N) * 0,015

  1. 用M除以D

CCI = M/D

注解:
SMA — 简单移动平均线。
N —用于计算的时间段的数值。


????? DeM??

开始使用 / 分析 / 技术指标 / DeMarker

DeM指标

DeM指标（DEM） DEM技术指标是把当前时段最大值和上一时段的最大值进行比较的的一个指标。如果当前时段数值高于上一时段的数值时， 就登记两个时段的差额。如果当前时段低于或等于上一时的数值时，就登记零值。汇总所得到的N个时段的差额， 所获得的数值作为去DEM技术指标的计数器数值，然后将这个数值除以相同的数值加上前一时段最小值和当前最小值差额的总值（柱）。 如果当前价格最小值大于上一时段的最小值（柱），就登记零值。

当该指标数值低于30时，我们可以预计一个牛市价格的反转。当该指数值高于70时，将可能会出现熊市价格的反转。

当你使用持续时间较长的时段，计算指标数值时，你就能够抓住一个长期的市场走势。根据持续时间比较短的时段的指标 可以让你在一个风险较小的时间进入市场，并且可以让你计算交易时间，以便那个时间恰巧与市场主要趋势时间同步。

计算方法

以I为间隔的DEM指标的数值的计算方法如下:

  • The DeMax(i)的计算:
    如果 high(i) > 数值大于HIGH（I-1）那DEMAX等于HIGH（I）-HIGH（I-1）不然就登记零值
  • The DeMin(i) 数值的计算
    如果low(i) <小于LOW（I-1）那DEMIN等于LOW（I-1）-LOW（I）不然就登记零值
  • DEM指标数值的计算:
    DMark(i) = SMA(DeMax, N)/(SMA(DeMax, N)+SMA(DeMin, N))

Where:
SMA — 简单移动平均线。
N — 计算中所使用的时段的数值


???? ? ?????

开始使用 / 分析 / 技术指标 / Envelopes

包络线指标

包络线技术指标是由两条移动平均线组成， 一个向上运动， 另外一个向下运动。选择哪个相关联数量的通道边幅的移动是由市场的变化率决定的：市场变化率越高，通道边幅的变化就越强烈。

包络线指数定义价格范围的上下边幅。当价格到达通道上端的边幅时，卖出信号就出现了；当价格达到通道下端的边幅时，则购买信号出现了。

包络线指标背后的逻辑就是过于热情的买家和卖家推动价格达到极端（上端通道或者是下端通道）在这几点上， 价格通过移动到一个相对现实的水平上而通常变得比较稳定。这就和保力加通道指标的解释颇为相似。

计算方法

上端通道 = SMA(CLOSE, N)*[1+K/1000]

下端通道 = SMA(CLOSE, N)*[1-K/1000]

注解:
SMA — 简单移动平均线。
N — 平均时段的数值。
K/1000 — 从平均值中变化的数值（以基本点来进行测算）。


???????????

开始使用 / 分析 / 技术指标 / Force Index

强力指数指标

强力指数技术指标由ALEXANDER ELDER开发，这个指标测算每一次增加的牛力震荡指标和每一 次减少的牛力震荡指标。它与最基本的市场信息要素相关联：价格趋势，价格趋势的下跌，以及外汇交易量。 这个指标可以就其作用来进行使用，但是最好和平均指标配合使用，与长期平均指标一起使用， 有助于发现入市和退市的最好时机。与短期平均指彪一起使用，（时段13）该指标会显示市场趋势和其变动情况。

  • 当强力指标在指标增加趋势的时段内是负值时（小于零），是买入外汇比较好的时候。
  • 当强力指标标志着增加的趋势会持续时，它会上升到一个新的高峰。
  • 当强力指标在下降趋势的时段内变为正值时，卖出的信号就到来了。
  • 当强力指标下降到一个新的低谷时，它就标志着熊力的到来和不断减少的趋势的持续。
  • 如果价格的变化不与相应的成交量的变化相关联的话，强力指标仍旧保持在一个水平上，这就意味着告诉你趋势很快就会变化。

计算方法

方向，成交量和规模是每个市场移动力量的主要特征。如果当前柱的收市价格高于上一个柱的价格，强力指数是正值，假如当前柱的收 市价格低于上一个柱的价格，那么强力指数是负值。两个数值的差额越大，则强力指标就越大；交易量越大，强力指标就越大。

FORCE INDEX (i) = VOLUME (i) * ((MA (ApPRICE, N, i) - MA (ApPRICE, N, i-1))

注解:
FORCE INDEX (i) — 当前柱的力量指数。
VOLUME (i) — 当前柱的交易量。
MA (ApPRICE, N, i) —在任何N时段内当前柱的任何 移动平均线 of the current bar for N period:
简单， 指数， 权数 或 通畅。
ApPRICE — 应用的价格。
N — 顺畅的时段。
MA (ApPRICE, N, i-1) —前一柱的任何 移动平均线 。


????? ????

开始使用 / 分析 / 技术指标 / Fractals

分形指标

在所有的市场上，价格一般都不会怎么变化的， 趋势的改变也只占据时间段里的15-30%。大多数获利的情况也只是处于某一趋势下，市场价格的变化。

分形指标是BILL WILLIAMS五大贸易体系指标之一，它用于测算底线和上线。

分形技术指标是由至少五个连续的柱图组成；中间柱图为最高，两边其次。 相反，在另外一面，也有至少五个连续的柱图组成，中间柱图为最低，两边其次。分形指标有高低值并配有上下的箭头。

我们需要使用鳄鱼技术指标来对分形指标进行透析。换言之， 如果分形指标低于鳄鱼的牙齿的话，你就不应该结束购买交易；当分形指标高于鳄鱼的牙齿时，你也不应该结束卖出交易 。分形指标的信号发出并作用的时候 （通常是由鳄鱼嘴巴上部的分形指标的位置所决定的）。除非它受到攻击或者产生新的信号，原来的信号还是有效的。


???? ? ??????

开始使用 / 分析 / 技术指标 / Gator Oscillator

加多摆动指标

加多摆动指标是基于鳄鱼指标之上的， 它表明了平衡曲线的离散程度（顺畅移动平均线）顶上的柱形图是蓝色曲线和红色曲线价值的绝对差 。底层的柱形图是红色曲线和和绿色曲线价值的绝对差。但是这个数值是个负数，因为柱形图被往下拉了。

计算

MEDIAN PRICE = (HIGH + LOW) / 2

ALLIGATORS JAW = SMMA (MEDIAN PRICE, 13, 8)

ALLIGATORS TEETH = SMMA (MEDIAN PRICE, 8, 5)

ALLIGATORS LIPS = SMMA (MEDIAN PRICE, 5, 3)

这里：

MEDIAN PRICE — 中间价。
HIGH — 柱的最高价格。
LOW — 柱的最低价格。
SMMA (A, B, C) — 平滑移动平均线。参量 À — 平滑数据，Â — 平滑周期， Ñ — 转到未来。例如， SMMA (MEDIAN PRICE, 5, 3) 表示平滑移动平均线来自中间价，而平滑周期等于5柱，而移动等于3柱。
ALLIGATORS JAW — 蓝线。
ALLIGATORS TEETH — 绿线。
ALLIGATORS LIPS — 红线。


????????????

开始使用 / 分析 / 技术指标 / Ichimoku Kinko Hyo

一目平衡表指标

一目平衡表技术指标的定义以市场趋势，支持体系，和抗级为特征。 该指标通常发出购买和卖出信号。这个指标在日图表和周图表中的作用最为明显。

当定义参数空间时，我们使用四个不同长度的时间段，组成这这个指标的每个单一曲线的数值都是以这些时间段为基础的:

  • TENKAN线表示了在第一时段里的平均价格水平，取这个时间段最大和最小值，然后除以二。
  • KIJUN线是第二个时间段里的平均价格水平。
  • SENKOU 通道A由第二时间段所推动向前运动的前两条曲线之间的距离。
  • SENKOU 通道B由第二时间段所推动向前运动的第三时间段里的平均价格水平。

CHIKOU 通道表示了由第二时间段所推动向后运动的当前柱的收市价格。 SHENKOU 曲线之间的距离被赋予了红色，也被称作"云"。 如果价格在这些曲线之间，那么这个市场会被认为是"非趋势性"的。随后，"云"的边缘形成了支持体系和抗级。

  • 如果价格高于"云"，那么它的上线形成第一支持体系，它的第二条曲线形成第二条支持体系。
  • 如果价格低于"云"，则它的下线形成第一抗级，它的上线形成第二抗级。
  • 假如CHIKOU 通道曲线以自下而上的方式在图表内运动，我们说购买的信号到来了；如果它以自上而下的方式运动，那么卖出的信号又产生了。

KIJUN线被作为市场运动的指标。如果价格高于这个指标的话，那么它将继续增加。倘若价格沿着这条曲线运动的话， 那么进一步的趋势变化是非常有可能的.KIJUN线路的另外一个作用就是发出各种信号。当KIJUN线路作自下而上的运动时， 就产生了购买的信号，反之，则产生卖出的信号。TENKAN线被作为市场趋势的一个指标。如果这条曲线增长或降低， 那么我们说市场趋势就是存在的。当它在水平方向运动时，就表明市场已经进入了某一个通道。


????? ????????

开始使用 / 分析 / 技术指标 / Market Facilitation Index

市场促进指数指标

市场促进指数技术指标（BW MFI）是显示某个时点价格的变化。该指标的绝对值并没有什么意义， 有意义的只是该指标的变化。BILL WILLIAM强调的是该指标和交易量的相互变化:

  • 市场促进指数增加，交易量增加。这一点表明: a)进入市场的交易人员的数量增加。（交易量增加） b) 新的交易人员会随着柱图的发展趋势入市。（例如，移动的开始和速度的加快）。
  • 市场促进指数的回落和交易量的下降，表明市场的交易人对该市场不在感到有任何的兴趣。
  • 市场促进指数的增加，但交易量下降。最有可能的就是，市场并不受到来自客户交易量的支持， 价格随着"底楼"交易人员的游资而变化（经济人和交易人）。
  • 市场促进指数的下跌，但是交易量的增加。存在牛力和熊力之间的斗争。主要特征为大量的买进和大量的卖出。 但是价格没有重大的变化，因为两股势力比较相当。竞争的其中一方（买家或卖家）将会最终赢得这次斗争的胜利。通常， 柱形的停滞让你知道是否这个柱形决定了市场趋势的连续性，或这个柱形终止了市场趋势。 BILL WILLIAMS称之为"行屈膝礼"。

计算方法

计算市场促进指数，你必须从最高柱形的价格中扣除最低柱形的价格，得出的结果除以成交量。

BW MFI = RANGE*(HIGH-LOW)/VOLUME

注解:
RANGE — 乘积系数，会带来整个数组的落点差。


?????????

开始使用 / 分析 / 技术指标 / Momentum

动量指标

动量技术指标是测算在一定时间段里证券价格的变化量。

有两种使用证券价格的基本方法 :

  • 你可以使用动量指标作为类似于振荡指标的移动平均汇总/分离指标 (MACD)来追随市场趋势。当动量指标探底并反弹时， 进行买入；该指标上升并下挫时，进行卖出。你必须要追寻一个短期的指标的移动平均线来决定其是否探底或是上扬。 如果动量指数到达一个极端高或者极低的数值（相对于历史数据而言），你必须推测当前的市场有一个长时间的趋势。 例如，当动量指数达到一个极端高的数值，然后下挫，你应该认为价格仍然会持续走高。在任何一种情况下， 只有价格在确认了由指标所产生的信号后，才能进行交易。（例如，如果价格上升或者回落，你在卖出之前，必须等待价格的回落）。
  • 动量指标也可作为你的一个主要指标。这种方法认为，市场的整体上升主要的特征是快速的价格增长。 （当每个人预计到价格会走高时），事情经常是这样的，但是，它也是一个比较宽泛的概括。

当市场的整体上升时，动量指标会急剧的攀爬然后回落，从持续上升或两边运动的价格移动中分离出来；类似的情况， 当市场探底时，动量指标会急剧的下降，然后爬升到其他价格之上。这两种情况都会导致指标和价格的分离。

计算方法

动量数值就是当天价格同前几个时段的价格的比率

MOMENTUM = CLOSE(i)/CLOSE(i-N)*100

注解:
CLOSE(i) — 当前柱形的收市价格。
CLOSE(i-N) — 前几个时段柱形的收市价格。


????? ????????

开始使用 / 分析 / 技术指标 / Money Flow Index

资金流量指数指标

资金流量指标（MFI）是测算资金投入证券并从证券市场中收回时的。速率的技术指标。 对于该指标的构筑和解释与相对强弱指标相似，区别只是在于：成交量对于资金流量指数是重要的

当我们分析资金流量指数时，必须考虑下列几点 :

  • 指标和价格移动的偏离，如果价格上升而指标下降的话（或者相反），则价格存在一个极有可能的变化。
  • 资金流量指数值，如果超过80或者是低于20的话，则分别可以表明市场潜在的上升或探底趋势。

计算方法

资金流量指标的计算方法包括几个步骤。 首先我们要定义一个需要研究时段的典型价。

TP = (HIGH + LOW + CLOSE)/3

然后我们计算资金流量的数额:

MF = TP * VOLUME

如果当天的典型价格高于昨天的典型价格，那么资金流量指数应该是个正数。 如果今天的典型价格低于昨天的典型价格，那么资金流量的指数应该是个负数。

正资金流量是在一定时段里，正资金流量的一个总和。负资金流量是一定时段里，负资金流量的一个总和。

然后我们计算资金比率（MR），把正资金流量以负资金流量:

MR = Positive Money Flow (PMF)/Negative Money Flow (NMF)

最后我们用资金比率来计算资金流量指数：

MFI = 100 - (100 / (1 + MR))


????? ?????

开始使用 / 分析 / 技术指标 / Moving Average

移动平均线

移动平均线指标显示某一个时间段平均工具性价格的数值。当我们计算移动平均线的时候， 其实我们是在平均这段时间内工具性价格的数值。由于价格的变化，移动平均线指标要么增加要么减少。

有四种不同类型的移动平均线: 简单（也被成为算术）移动平均线， 指数移动平均线， 通畅移动平均线和 线形权数移动平均线。 。我们可以为任何一套顺序排列的数据来进行移动平均线的计算，包括开市和闭市价格，最高和最低价格， 交易量和任何其他的指标。同时有两条移动平均线被使用的情况比较普遍。

只有在一种情况下，不同种类的移动平均线会产生相当大的分离 ，就是当权数系数不同的情况下（该系数是被安排到最近的一个数据里的），我们在讨论简单移动平均线的时候， 我们研究的时间段的所有价格都在数值上相等。指数和线形权数移动平均线的数值更趋向于最近的价格

解释价格平均移动最普遍的方法是就是将其动量与价格运动相比较。当工具性价格上升到其移动平均线之上时， 购买信号出现了；当价格下落到移动平均线下面时，我们所得到的是一个卖出信号。

这种基于移动平均线的贸易体系，并不是设计用来提供给我们一个通道的：市场处于低潮期的时候让我们进入， 在进入高峰期的时候让我们出来。根据下列市场趋势的变化， 它可以使得我们作出相应的行动:一旦价格探底，我们就开始买进；一旦价格攀升，我们就开始卖出。

移动平均线也可被运用于各种指标。那就是移动平均指标的解释和价格移动平均线解释相似的地方 。如果指标上升到移动平均线上面的时候， 那就意味着上升的指标运动还将继续。指标若是低于移动平均线，那就表明指标有可能继续下滑。

这是图表上移动平均线:

  • 简单移动平均线(SMA)
  • 指数移动平均线 (EMA)
  • 通畅移动平均线 (SMMA)
  • 线性权数移动平均线 (LWMA)

计算方法

简单移动平均线(SMA)

简单，或者说是算术移动平均线的计算：汇总某几个单一时间段内闭合的工具性价格（比如，12个小时） 然后这个汇总的数值在除以时段数

SMA = SUM(CLOSE, N) / N

注解:
N — 计算用的时段数目。

指数移动平均线(EMA)

指数通畅移动平均线的计算：把某一份额的当前收市价格的移动平均线与上一个这样的数值相 加有指数通畅移动平均线的当前价格的数值最大，P百分率的指数移动平均数率表示为 :

EMA = (CLOSE(i) * P) + (EMA(i - 1) * (100 - P))

注解:
CLOSE(i) — 当前时段收市价格。
EMA(i-1) — 上一收市时段移动平均线。
P — 使用价格数值的百分比。

通畅移动平均线 (SMMA)

该通畅移动平均线的第一个数值的计算和简单移动平均线一样(SMA):

SUM1 = SUM(CLOSE, N)

SMMA1 = SUM1/N

第二个和接下来的数值的计算，可参照下列公式:

PREVSUM = SMMA(i - 1) * N

SMMA(i) = (PREVSUM - SMMA(i - 1) + CLOSE(i)) / N

Where:
SUM1 —N个时间段收市价格的总值。
SMMA1 — 第一个柱形的通畅移动平均线。
SMMA(i) — 当前柱形的通畅移动平均线（除了第一个以外）。
CLOSE(i) — 当前收市价格。
N — 通畅时段。

线性权数移动平均线(LWMA)

就线性权术移动平均线而言，其最新的数据值大于它早期的数值。权数移动平均线的计算：在所考虑的一系列数据里， 两两相乘每一个收市价格，然后在比上某一个特定的权数系数。

LWMA = SUM(Close(i)*i, N) / SUM(i, N)

在这里：
SUM(i, N) — 权数系数的总合。


????????????/????

开始使用 / 分析 / 技术指标 / Moving Average Convergence/Divergence

移动平均数汇总/分离指标

移动平均汇总/分离指标是跟随动态指标的第二个市场趋势。它表示了两个价格 移动平均线的相互关联。

移动平均汇总/分离技术指标是26段和12段 指数移动平均线 (EMA)的差额（EMA）。为了清楚的表明买卖的机会， 所谓的信号曲线（9段指标移动平均线）会在移动平均汇总/分离技术指标图上做轨迹运动。

在摇摆较大的市场，该指数图表被证明是非常有效果的。有三种使用该指标的普遍方法：相交，过度买入和过度卖出条件和分离。

相交

最基本的MACD贸易规则就是当该指数低于信号曲线时，进行卖出，类似，当该指数高于信号曲线时， 买入信号产生。当MACD指数在零点上下游离时，建议买入或卖出。

过度买入和卖出条件

MACD图表作为过度买入和过度卖出指标是非常有用的。当短期移动平均线急剧偏离长期移动平均线时（MACD指标上升）， 证券价格有可能过度的扩张，并且可能很快的会回到一个更为实际的水平线上。

分离

当MACD指数从证券分离时，就意味着当前趋势趋向于结束的时刻即将来到。当移动平均汇总/分离指标创出新高的时候， 牛力的分离将会发生，此时，价格并未能达到它的新高。当移动平均汇总/分离指标创出新低的时候，熊力的分离发生， 此时价格也并未能达到它的新低。当这两种分离发生在过度买入和卖出的情况下时，他们的意义是非常重大的。

计算方法

MACD的数值是12段指数移动平均线与26段指数移动平均线的差额。MACD的9段点状移动平均线（信号曲线）， 在MACD的图表上作轨迹运动。

MACD = EMA(CLOSE, 12)-EMA(CLOSE, 26)

SIGNAL = SMA(MACD, 9)

注解:
EMA — 指数移动平均线。
SMA — 简单移动平均线。
SIGNAL — 指标的信号曲线。


????????????????

开始使用 / 分析 / 技术指标 / Moving Average of Oscillator

移动振动平均震荡器指标

震荡移动平均指数的数值是振荡指数和震荡通畅指数的差额。在这种情况下，MACD的基本曲线被作为振荡指标。信号曲线被作为通畅指标。

计算方法

OSMA = MACD-SIGNAL


????? ?????

开始使用 / 分析 / 技术指标 / On Balance Volume

能量潮指标

能量潮技术指标是关联成交量和价格变化的一个冲量指标。JOSEPH GRANVELLE提出的这个指标相当简单 。当证券收市价格高于前一收市价格， 当天所有的交易都被称为上能量潮；当证券收市价格低于前一收市价格时，当天所有交易都被称为下能量潮。

有关能量潮交易的一个最基本的假设是：该指标的变化先于价格的变化。该理论意思就是说，通过上升的能量潮交易量指标， 我们可以看到游动资金流入证券市场。当大众都纷纷进入证券市场的时候，证券和能量潮交易量指标都会上升。

如果证券的价格移动先于能量潮交易量的移动，“非确认“将会产生。这种情况会出现在牛力占据市场主导地位的时候 （那时证券价格单独上涨或者是先于能量潮指数上升）；同样， 这种情况也会出现在熊力占市场主导地位的时候（那时证券价格单独下降，或先于能量潮指数下降）。

当能量潮技术指标每一个高峰高于上一个的时候，或者它的每一个低谷都高于上一个的时候 ，那么我们就说能量潮处于一个上升趋势。同样，与上面情况相反的话，那么我们就说能量潮技术指标处于一个下降的趋势。 当指数进行边际移动或者没有进行上下的波动时，那能量潮技术指标就处于一个怀疑趋势。

一旦这个趋势建立以后，只有当它被打破时，该趋势的作用才会消失。我们有两种打破能量潮指标趋势的方法。 第一种就是趋势从高到低的运动，或者从低到高的运动。

第二种就是如果当指标进入怀疑趋势或者在处于怀疑趋势三天以上的，我们也可以打破这个指标趋势 。如果证券价格的变化遵循从上升趋势进入怀疑趋势， 并只要能在回复到上升趋势之前在怀疑趋势中保持两天的话，那我么就认定这个能量潮指数可以一直处于上升阶段。

当移动平衡指数变化到上升或是下降趋势的时候，"爆发"就发生了。由于该指标的"爆发"先于价格的“爆发”， 投资者应该在指标向下"爆发"时买进长线；同样， 投资者在该指标向上"爆发"的时候，卖出长线。应该等到趋势变化的时候在收线。

计算方法

如果当天的收盘价高于昨天的话，那么: OBV(i) = OBV(i-1)+VOLUME(i)

如果当天的收盘价低于昨天的话，那么: OBV(i) = OBV(i-1)-VOLUME(i)

如果当前的收盘价等于昨天的话，那么: OBV(i) = OBV(i-1)

注解:
OBV(i) —当前时段指标值。
OBV(i-1) —上一时段的指标值 。
VOLUME(i) —当前柱形的成交量。


???? ????????????

开始使用 / 分析 / 技术指标 / Parabolic SAR

抛物线状止损和反转指标

抛物线状止损和反转技术指标是用来分析市场的趋势变化的。这个指标是构件于价格图表之上的。 抛物线状止损和反转技术指标与移动平均线技术指标相似，唯一的差别就是： 抛物线技术指标是以越来越快的速度加速移动的， 并且就价格而改变自己的位置的。该指标在牛力时（上升趋势） 低于价格水平，在熊力时（下降趋势）高于价格水平。

如果价格穿过抛物线指数时，那么该指标开始反转，它的进一步的价值会落在价格水平的另外一面。 当该指标的反转确实发生时，上一个时间段的最高和最低值将作为一个开始点。当该指标反转， 它就会给出一个市场趋势结束或者是开始的信号（修正阶段或无波动阶段）如果价格穿过抛物线指数时， 那么该指标开始反转，它的进一步的价值会落在价格水平的另外一面。当该指标的反转确实发生时， 上一个时间段的最高和最低值将作为一个开始点。 当该指标反转，它就会给出一个市场趋势结束或者是开始的信号（修正阶段或无波动阶段）

抛物线指标在出市点方面的表现十分出色。当价格下沉到低于抛物线指标时，我们应该关闭长线的交易； 当价格上升到超过该指标时，我们则应该关闭短线交易。通常情况下，该指标作为轨迹终止曲线。

如果长线位置开放的时候（价格高于抛物线指标），不管价格采取如何方向的走势，指标总是向上运动的。 指标曲线移动的长度取决于价格移动的规模。

计算方法

SAR(i) = SAR(i-1)+ACCELERATION*(EPRICE(i-1)-SAR(i-1))

注解:
SAR(i-1) — 上一柱形的指标数值。
ACCELERATION —加速的因素 。
EPRICE(i-1) —上一时间段的最高（最低）价格，EPRICE=HIGH是长线的价格（EPRICE=LOW是短线的价格）。

如果当前柱形的价格高于上一个牛力的价格，那么抛物线指标数值增加；反之，则指标值下降。与此同时， 加速因素（ACELERATION）会以成一倍的方式增加，这时，抛物线指标和价格趋于同一。换句话说，就是价格上升或下降的越快， 指标就会更快的趋向于价格水平。


???? ? ????????

开始使用 / 分析 / 技术指标 / Relative Strength Index

相对强弱指数指标

相对强弱指数技术指标（RSI）是追寻震荡指标的价格，该震荡指标的取值范围在0-100之间。 当WILDER在引进这个指数时， 他建议使用一个14天的RSI指标。自他提出这个建议以后，人们使用9天和25天的RSI指标也非常的普遍了。

分析RSI指标最为普遍的方法是：我们要寻找这样一个分离的情况，在那点上，证券的价格是创新高的 ，但RSI指标并未能超过它以前的那个高度。这样的分离暗示着一个迫近的相反趋势。当RSI指标那时开始反转， 并且下降到它最近的那个低谷，人们称之为"失败摇摆"，"失败摇摆"被看作为是即将到来的一个相反趋势的确认。

使用RSI指标来做图表分析的方法:

  • 顶部和底部
    RSI指标通常上升到70以上或者是下降到30以下。在构成价格图表之前，该指标一般形成这样的顶部和底部趋势。
  • 图表的形成
    RSI指标一般会形成象头，肩膀和三角形这样的图表图案，这些图形可能在价格图表上是看不到了。
  • 失败摇摆 (支持或抗拒；渗透或爆发)
    在这个时候，RSI指标一般会超过上一个高点（波峰）或下降到下一个低点（低谷）。
  • 支持或抗拒水平
    RSI指标在表现支持或抗拒水平的时候比价格本身更为的清楚。
  • 分离
    就上述讨论的一样，当价格水平创出新高（低），但这种新高（低）的趋势并没有被RSI指标所确认的时候， 分离的情况就发生了。价格通常会修正并且沿着RSI指标的方向进行移动。

计算方法

RSI = 100-(100/(1+U/D))

注解:
U —价格变化正值的平均数。
D — 价格变化负值的平均数。


?????????????

开始使用 / 分析 / 技术指标 / Relative Vigor Index

相对活力指数指标

相对活力指数技术指标（RVI）的技术特点就是，原则上，在牛力上，收盘价格高于开盘价格；在熊力的时候， 情况则相反。所以蕴涵在该RVI之后的原理就是：指数移动的活力或能量是由价格在收市时的那个数值所确立的。 为了使得该指标正常于当日的交易范围，我们根据当日价格范围的最大值来划分价格的变动情况。 为了进行更为便利的运算，我们应该使用简单移动平均线指标。10是最好的时间段。为了避免可能的混淆， 我们必须构建一个信号曲线， 这一曲线是RVI指标数值的4段对称加权平均线。曲线之间的汇合被认为是购买或者是卖出的信号。.

计算方法

RVI = (CLOSE-OPEN)/(HIGH-LOW)

注解:
OPEN — OPEN —开盘价格。
HIGH — 最大价格。
LOW — 最低价格 。
CLOSE —收盘价格。


????? ????

开始使用 / 分析 / 技术指标 / Standard Deviation

标准离差

标准离差 —是市场上的一种易变得价值尺寸。 标准离差指标是对简单移动平均线价格涨落变化的描述。 所以，如果指标的价值为高，说明市场是易变的，价格柱将会随着简单移动平均线而涨落。如果指标的价值为低，市场的浮动则会降低， 价格柱也会随着简单移动平均线涨落。

正常情况下，标准离差指标作为其他指标的组成部分应用。由于， 当计算 保力加通道指标时， 需要添加标准离差指标到它的 移动平均线。

计算方法

StdDev = SQRT (SUM (CLOSE - SMA (CLOSE, N), N)^2)/N

注解:
SQRT — 正方体根。
SUM (..., N) — N个周期内的总和。
SMA (..., N) — 简单移动平均线 存在N个周期。
N —计算周期。


???? ???????

开始使用 / 分析 / 技术指标 / Stochastic Oscillator

随机震荡指标

随机震荡技术指标比较一定时段里，价格的范围同证券价格收市值的相关情况 。该振荡指标以双线来显示。主线被称为%K线，第二根线被称为%D线， 它的数值是主线%K的移动平均线。%K通常显示为一个固定的曲线，而%D线则显示为点状曲线。

我们有很多方法来解释这个震荡指标，其中有三种方法比较普遍:

  • 当震荡指标（%K或是%D）下降到低于某一个具体水平的时候（比如20），然后又上升到高于那个水平的时候， 我们可以进行买入。当指标上升到高于某一个具体水平时（比如80），然后又回落到低于那个水平时，我们就可以卖出了。
  • 我们可以在%K曲线高于%D曲线的情况下进行买入，或者在%K曲线低于%D曲线的情况下卖出。
  • 寻找分离点。比如：当价格不断的创出新高，随机震荡指数未能突破它之前的新高的时候。

计算方法

随机震荡指标有四种变形:

  • %K 时段：这是在计算震荡指标过程中所用到的时间段的数值。
  • %K减速时段：这个数值控制着%K的内部通畅度。数值一被看作是快速随机震荡指标，而数值三则被视为慢速随机指标。
  • %D时段：在计算%K移动平均线时，所用到的时间段的数值。
  • %D方法：在计算%D时所使用的方法（包括简单，指数，通畅和加权）。

%K的方程式: %K = (CLOSE-LOW(%K))/(HIGH(%K)-LOW(%K))*100

注解:
CLOSE —当天的收盘价格。
LOW(%K) —%K的最低最低值。
HIGH(%K) — %K的最高最高值。

根据公式，我们可以计算出%D的移动平均线: %D = SMA(%K, N)

注解:
N — 通畅时间段。
SMA — 简单移动平均线。


????? ????

开始使用 / 分析 / 技术指标 / Williams' Percent Range

威廉指标

威廉指标是一个动态技术指标， 由它来决定市场是否过度买入或买进。威廉的%R曲线和与随机震荡指标非常类似。 唯一的区别在与%R曲线有上下运动的标尺，而随机震荡指标有振动指数有内部的舒张。

为了表明威廉指标的上下运动方式，我们应该在其指数前添加负号，（例如-30）不过在进行指标分析的时候， 我们应忽略那个负号的存在。

在80到100%范围内变化的指标数值表明市场处于一种过度卖出状态。 在0到20%范围内变化的指标数值则表示市场处于过度买入状态。

就所有过度买入或过度卖出的指标，你最好在下单之前，等待证券价格改变它的走向。 如果在过度买入或是过度卖出的指标显示出过度买入的条件，那你在卖出某个证券之前等待价格的回落是非常明智的。

威廉技术指标有趣的一个现象就是它能大胆的预测基本证券价格相反趋势的能力。指标总是在证券在进行上下运动 之前的几天里形成自己的波动。同样，威廉指标通常会形成一个低谷，并且在证券价格出现之前保持几天的时间。

计算方法

TBELOW是计算%R指标的方程式，这个公式和 随机震荡指标的计算方法相似:

%R = (HIGH(i-n)-CLOSE)/(HIGH(i-n)-LOW(i-n))*100

注解:
CLOSE —当日收盘价。
HIGH(i-n) —过去时段的最高值。
LOW(i-n) —过去时段的最底值。


??

开始使用 / 交易

交易

在交易市场获得利润的基本原理即低买高卖。金融市场中完整的交易活动是通过成功的买卖业务完成的。 这样需打开，修改和关闭交易仓。交易仓是一种市场义务(定单),对于没有反诉的一宗交易会执行买卖交易合同的数量。 在终端内完整的交易要通过交易仓执行。

开仓，执行交易。平仓，执行相反业务。开仓是经纪商根据市价单或根据挂单指令所作出的。 如果附在仓位上的止损和赢利价值改变则需修改。交易者可以请求关闭仓位。 另外，带有智能交易仓位的打开，修改和关闭—详细描述查看 智能交易部分。


?? ?????

开始使用 / 交易 / 定单类型

定单类型

客户终端为执行交易可以准备和发出交易指令，并且可以监控和管理开仓头寸。 为了这些目的，可以使用几种下单类型。定单是经纪公司执行交易的一种指令。 客户终端包括以下几种类型的定单：市价单, 挂单交易， 止损和 赢利。

  • 市价单
    市价单是经纪公司以现价买入或卖出金融品种的定单。经纪公司执行此定单建立交易头寸，买入是以卖方叫价（卖出价）成交的， 卖出是以买方出价（买入价）成交的。市价单中含有止损和获利定单。 实施类型 取决于交易工具。
  • 挂单交易
    挂单交易是经纪公司未来以固定价格买入或卖出金融品种的一种定单。在未来的价格等于设定的价格水平时， 此定单类型用于建立交易头寸。挂单交易包括四种类型：
  • 限价买单 —在未来的卖方"叫价"（卖出价）等于指定水平时买入。而且当前市场价格水平高于挂单交易设定的 价格。
  • 止损买单 — 在未来的卖方"叫价"（卖出价）等于指定水平时买入。而且当前市场价格水平低于挂单交易设定的价格。
  • 限价卖单 — 在未来的买方"出价"（买入价）等于指定水平时卖出。而且当前市场价格水平低于挂单交易设定 的价格。
  • 止损卖单 — 在未来的买方"出价"（买入价）等于指定水平时卖出。而且当前市场价格水平高于挂单交易设定的价格。

挂单交易中含有止损和获利定单。在挂单交易启动后，它的止损和赢利将会自动附加上。

  • 止损
    止损定单用于在金融品种价格开始向无盈利方向运行时使亏损最小化。如果价位达到设定的价位线，将会自动关闭。 该定单常常与开仓就是与挂单交易结合。 在设定止损定单之后，经纪公司进行定单执行。而且，在图表窗口会显示定单价格水平的标记；在设定止损定单之后，经纪公司进行定单执行。而且，在图表窗口会显示定单价格水平的标记。
    自动止损需查看交易停止。
  • 赢利
    获利定单是为了在金融品种价格达到预期水平之后进行获利了结。定单可以与市价单和挂单一起交予经纪公司执行。 同样这类定单也可以进行修改或删除。既然这样，您除了要填写获利栏目以外，其他的操作和止损定单一样。

注意:

  • 需用指定的交易人执行交易业务。
  • 止损和赢利只能在开仓的情况下执行，而不是挂单交易。
  • 终端内的历史图表为买入价图表。 显示最后的叫价图，需在终端内选择"显示叫价"。


?? ?????

开始使用 / 交易 / 移动止损

移动止损

止损是指在价位向下滑动时，当滑落到止损水平位的时候，停止交易。 如果仓位开始赢利 止损可以手动维持在持平位上。 若想自动执行这个程序，需要创建移动止损。这个工具可以在价格大幅度变动时或连续市场报价时，起到一定的作用。

移动止损与止损服务器不同，它需要附加在打开的仓位和客户端上。 设置移动止损，需要在 "终端"窗口开仓的菜单中进行操作。 然后 ，在打开的列表中选择需要的止损水平位与当前价位的差额。 每个仓位仅可以设定一个移动止损。

所有活动完成后，报价会进入，终端会检测仓位赢利。 渐渐地赢利点数会等于或高于所指定的水平位，这样放置 止损定单的命令将会自动给出。 定单所设定的水平位必须不同于当前价位。 将来，如果在赢利方向内价格发生改变，移动止损会按照定单所设定的价位自动止损，但如果仓位赢利下滑， 定单不能修改。因为交易仓的赢利是被自动规定的。 在每一个止损定单修改后，记录将会写在 终端日志内。

在管理菜单禁止移动止损可以设定为"没有" 。如果执行"删除全部"，所有开仓交易和挂单交易的移动止损被禁止。

注意: 移动止损是在客户端内运行，不是在服务器上(像止损或赢利)。 这就是在终端关闭后移动止损不运行的原因。 这种情况下，只有止损水平位会启动。


??? ????

开始使用 / 交易 / 实施类型

实施类型

在客户终端内存在三种实施类型:

  • 立即实施
    在这种类型中, 订单执行价格由交易商提供。 在定单实施发送时，终端会在定单上设置当前价格。 如果交易商接受价格, 定单会被执行 如果不, 会要求"重新报价" 将会出现：交易商会返回到定单执行的价位。
  • 请求实施
    在这种类型中, 市场定单会在未得到交易商的价位前执行。在定单被发送前，会请求交易商。 价格收益后,定单执行给出的价位会完成或拒绝。
  • 市场实施
    在这种实施类型中，交易商会使定单执行价位与交易者交易时不允许添加任何附加条件。 定单的发送要同意价位。

注意: 对于每个证券实施形式必须用固定的经纪公司。


?? ? ???

开始使用 / 交易 / 交易仓

交易仓

金融市场最基本和最简单的获利是低买高卖。金融市场中完整的交易活动是通过成功的买卖业务完成的。 这样需打开，修改和关闭交易仓。交易仓是一种市场义务(定单),对于没有反诉的一宗交易会执行买卖交易合同的数量。 在终端内完整的交易要通过交易仓执行。 客户端给与机会去检验和管理交易仓。交易发出的指令(定单)，和经济公司开仓或平仓。 交易仓管理由以下部分组成：

  • 开仓 — 在市场或挂单交易中执行买卖。
  • 仓位修改 — 改变附在仓位上的 止损和 赢利 水平。
  • 挂单交易安装 — 像Buy Limit, Buy Stop, Sell Limit, 或 Sell Stop挂单交易的安装。
  • 挂单交易修改或删除 — 修改或删除未开启的挂单交易。
  • 平仓 — 关闭存在交易的仓位。


????????

开始使用 / 交易 / 交易仓 / 开仓

开仓

开仓或进入金融市场是执行买卖交易。 可以使用 市场定单操作或挂单交易自动开启。

市场定单

应用市场定单开仓，可以使用 "工具 —菜单 执行， 按 新订单 按钮 "常规" 工具条操作，按 F9， 或在 "市场报价"窗口双击标志。 也可以使用"市场报价"和 "终端 — 交易"中"新定单"操作。 对于交易仓所管理的 "定单"窗口打开。

开仓必须填写以下内容：

  • 标志 — 对于已开启的仓位设定标志。
  • 成交量 — 指定交易成交量(份额)。
  • 止损 — 设定止损水平(可选择)。
  • 赢利 — 设定赢利水平 (可选择)。

注意: 止损/赢利t成交量为零时，意味着定单未被安装。
  • 注解 — 写下注解(可选择).注解的大小不可超过25个字符。经济公司添加的注解不可超过6个字符。 开仓后，注解不会改变。
  • 开启从开价最大离差 — 开启/关闭离差。如果交易商重新开价，新定单之间的离差将会重新估价。 如果离差低于或等于指定离差，定单将会按照新价位执行操作 交易商会返回新价位执行。
  • 最大离差: —最大离差的成交量。

注意:提供定单时价格偏差只有在快速执行形式下应用。

在所有数据指定后，可以按"买" 或者 "卖"按钮。 另外，卖空的或看涨的仓位定单会发送给经济人。

注意:如果对品种的定单 实施请求，可以按"请求"按钮。 提供的开价将会继续运行几秒。如果在这几秒钟没有执行指令， "卖" 和 "买"的按钮将会被锁定。

如果止损 和 赢利的水平 在当前开仓处于关闭状态，" S/L 和T/P无效"信息将会显示。这样则需重新请求。 在经济公司设定止损和赢利后交易仓将会打开。另外，开仓的状态栏将会显示在 "终端 —交易" 表内， 开价， 止损和赢利水平也会显示在图表内 (如果 "显示交易水平"选项 开启)。

挂单交易

利用挂单交易开仓，首先须安装。相关信息查看 "挂单交易安装"部分。如果当前价位支持， 挂单交易将会自动执行，新交易仓位将会打开。另外，挂单交易的状态栏会从 "终端 — 交易" 表内删除， 新仓位的状态栏会显示。如果 止损和赢利附在挂单交易上，它们自动附在新仓位上。


????? ?????

开始使用 / 交易 / 交易仓 / 仓位修改

仓位修改

当前仓位的修改是附在 止损 和 赢利 的基础上的。修改仓位，可以使用 "修改或删除定单" 或者在 "终端" 窗口 开仓的"止损" 和 "赢利"双击鼠标左键 在设定新的止损和赢利的价值后按"修改"。

改变止损和赢利的价值，需进入相应的区域。 进入当前价位的定单，在"水平"中设定要求的价值按"复制"。 如果这个区域的价值为零，最小离差将由经济人设定。

如果止损和赢利对于当前价位处于关闭状态， "修改"键是被锁定的。这种情况下需重新请求修改仓位。 在经济公司对止损和赢利设定新价值后，交易仓将会修改。 这样在"终端 — 交易" 表内"止损" 和 "赢利" 价值将会改变 而且，修改后的水平会在"显示交易水平" 选项中开启。

注意: 在 "止损"和 "赢利"区域的价值为零意味着这些定单未被安装。


????????

开始使用 / 交易 / 交易仓 / 平仓

平仓

证券的买卖在交易仓内执行。当开价和叫价有差距时，定单赢利，此时需要平仓。 稍候交易业务会倒退。例如，如果先前的业务购买一份GOLD，在平仓时必须出卖。 在客户端内平仓方式不同: 单仓位平仓，反方位平仓和多仓位平仓。

单仓位平仓

如果价格等于 止损 或 赢利价值，此仓位将会自动平仓。

注意: 当一个看涨的仓位平仓时， 叫价必须等于止损或赢利的价值，要价必须卖空仓位。

手动平仓，可以在"终端 —交易"窗口操作，在这个仓位处双击鼠标左键。

也可以要求请求实施平仓，可以使用按"请求"键。

注意:

  • 在"请求实施" 类型中，提供的开价将会继续运行几秒。如果在这几秒钟没有执行指令，"关闭 "键会被锁定 。
  • 客户终端允许部分平仓。需在按 "关闭"之前，在"成交量"指定最少份额总量。
  • 经济人可以平仓。例如，当价位达到"Stop Out"水平时，经济人可以平仓。
  • 终端内只保存开价历史图表。 想要查看最后要价需要在终端设置内选择"显示要价"。

反方位平仓

反方位平仓是指运用当前金融工具反方向平仓。 若当前仓位中存在一个或多个反方位仓，选中其中一个即可关闭所有。首先需要打开"定单"窗口。

然后在"类型"中选择"反方位平仓"。随后，列表将会在窗口中显示。选中列表中需关闭的仓位 按"平仓 "按钮即可。可以同时关闭两个仓位。 如果两个仓位的交易份额不同，其中一个将会残留下来。这时这个仓位的成交量（份额）等于已平仓两个仓位的顺差。

多方位平仓

多方位平仓可以关闭两个以上的仓位。 需要打开"定单" 窗口。 然后在"类型"中选择"多方位平仓" 。随后，列表将会在窗口中显示。选中列表中需关闭的仓位 按"多方位平仓 "按钮即可。仓位将会按照开启的时间平仓。 如果仓位之间存在金额差，新仓位将会作为业务结果打开，成交量等于金额差。 新开启的仓位会带有多舱位平仓的功能。

注意: 在反方位平仓后，相应的信息会显示在 "终端 —历史账户" 窗口。可以在 "注解"区域查看相关信息。


????? ???????

开始使用 / 交易 / 交易仓 / 挂单交易安装

挂单交易安装

安装挂单交易，需打开"定单"窗口。可以使用 "工具 — 新定单"菜单 操作， 新订单 "常规" 工具操作，按快捷键F9， 使用"市场报价"中"新定单"执行和 "终端 —交易" 窗口双击在 "市场报价" 窗口中的 "挂单交易" 选中"类型" 执行。

接下来，需选择标志， 指定定单止损 和 赢利 价值。若有需要，注明文件名称。 在"挂单交易"区域需要如下：

  • 类型 —设定挂单交易类型: Buy Limit, Buy Stop, Sell Limit,或 Sell Stop。
  • 价位 —设定价位水平在定单中开启。
  • 期限 — 设定定单的期限。如果在时间内没有设定，它将会被自动删除。

注意:定单期限不能少于10分钟！

"安装"按钮将发送的定单分两个阶段执行。首先，经济公司在定单发送后安装。 随后， 包含数字和挂单交易的状态将会在"终端 — 交易" 表内显示。 如果"显示交易水平"选项开启，挂单交易水平(包含止损和赢利) 会在图表中显示。下一步，如果价位与定单提供的相协调，它将被删除被打开的交易仓代替。 这些变动将会在 "终端 —交易"窗口显现。

注意: 只有在开仓的情况下止损和赢利才会启动，并不是挂单交易。


????????????

开始使用 / 交易 / 交易仓 / 挂单交易修改

挂单交易修改

在工作过程中，经常需要修改或删除 挂单交易的位置。可以选择菜单中的"修改或删除定单"操作 或在"终端 —交易"窗口中挂单交易状态栏双击鼠标左键。 窗口所管理的定单被打开。 挂单交易的新价位开启， new levels of 止损和赢利 的水平会被设定在窗口内， 在定单被修改后按 "修改" 按钮执行。

注意: 若设定止损和赢利的价值为零，即等于关闭它们。

如果挂单交易被成功修改后， 在 "终端—交易" 窗口相应区域的价值将会改变。 如果 "显示交易水平"选项在终端属性 开启， 在图表中会显示挂单交易的水平，止损和赢利的价值。


?????? ????

开始使用 / 交易 / 交易仓 / 删除挂单

删除挂单

如果市场形势有所变化，有时需删除挂单交易。 可以使用在菜单中 "修改或删除定单"或者在挂单交易的状态栏双击鼠标左键 "终端 —交易" 窗口。 将会打开管理的定单。删除它点击删除即可。挂单交易在"期满"会被自动删除。 当挂单交易已删除，相应的记录会在"终端 —账户历史" 窗口显示。


图表交易

开始使用 / 交易 / 图表交易

图表交易

客户端允许交易人在交易品种的 图表上直接执行交易操作。结合 单击交易功能，这能够使用户快速地打开，更改和关闭仓位，以及管理挂单。

如果程序端设置中的单击交易选项 被启用，这部分描述的交易命令无需额外确认即被执行（交易对话框不显示）。

单击交易面板

已经实施一个特别面板，以允许在图表上直接执行交易操作。要激活它，执行“ 单击交易 单击交易”在图表快捷菜单。

您可以显示/隐藏面板通过点击 单击交易 图标到OHLC左侧。

使用此面板您可以立时发送买入或卖出指定交易量的市价单 。

  • 当在即时执行模式下进行交易时，订单中的价格可接受 偏差 根据 “偏差” 选项进行设定。
  • 当获得重新报价时，相应的信息会写入 程序端日志 并且会播放重新报价的声音 。

下挂单

可以使用图表快捷菜单的交易子菜单，从图表下挂单：

将鼠标光标放在图表上必要的价格水平上，并在快捷菜单中，执行相应的命令来安装挂单。

根据光标的位置，可用 订单类型 将显示在菜单中。If t如果菜单以高于当前价格被激活，用户可以下单限价卖单和买入止损订单。如果菜单以低于当前价格被激活，则将会下单限价买单和卖出止损订单。

交易品种选择价和当前价间的有效距离被额外检查 ("止损水平")。

订单交易量通过图表上的快速交易面板来选择。

执行命令以后，订单窗口 将会出现，允许用户更准确地调整其参数。如果程序端设置中的 “单击交易” 选项被启用，就会在指定价格马上下订单，而不显示交易对话框。

管理图表上的止损水平

启用程序端设置 中的“显示交易水平”选项，能够改变图表上的止损和获利水平。

要设置止损水平，用鼠标左键点击持仓水平并向上拖拽（买入持仓的获利或卖出持仓的止损）或向下拖拽（买入持仓的止损或卖出持仓的获利）。光标到达所需的价格即松开鼠标键。

要修改图表上的水平，左击图表，按住鼠标按钮，上下拖拽水平到所需的值(Drag'n'Drop)：

移动水平时，入金货币和如果触动该水平可能获得的点中会有一个显示潜在利润（亏损）的工具提示。

设置水平后，修改持仓 窗口将会出现，允许用户 更准确地调整水平。如果程序端设置中的 “单击交易” 选项被启用，就会马上执行修改，而不显示交易对话框。

管理图表上的挂单

启用程序端设置中的“显示交易水平”选项，能够改变图表上的挂单。

对于挂单，可以分别更改 止损 和 获利水平，也可以更改订单价格和止损水平：

  • 要修改图表上的止损水平，左击所需的水平，并按住鼠标按钮，上下拖拽水平到所需的值(Drag'n'Drop)。
  • 拖动价格线来修改整个订单。在这种情况下，价格和止损水平都将被重新定位。

移动订单时，入金货币和点中会有一个显示与当前价格差距的工具提示。

设置水平后，订单修改 窗口将会出现，允许用户 更准确地调整水平。如果程序端设置中的 “单击交易” 选项被启用，就会马上执行修改，而不显示交易对话框。

图表上持仓的快捷菜单

您可以修改和平掉您的持仓，以及使用图表上的持仓快捷菜单设置追踪止损：

  • 修改或删除 修改 — 打开 持仓修改 窗口。
  • 平仓 关闭 — 打开平仓窗口。如果程序端设置中的“单击交易”选项被启用，则会马上平仓，而不显示交易对话框。
  • 追踪止损 — 打开持仓的追踪止损 水平选择菜单。

图表上订单的快捷菜单

您可以更改或删除您的挂单，以及使用图表上的挂单快捷菜单设置追踪止损：

  • 修改或删除 修改 — 打开选定的订单修改窗口。
  • 删除订单 删除 — 打开删除选定订单的窗口。如果程序端设置中的“单击交易” 选项被启用，则立即执行删除，而不显示交易对话框。
  • 追踪止损 — 打开订单的追踪止损 水平选择菜单。


????, ?????, ?? ? ????

开始使用 / 自动交易

自动交易

为了能够在金融市场更多有成效的工作，需要建立完善的交易系统.由于人类带有情感，所以以手动的方式控制交易系统非常困难. 机械交易系统弥补了这点不足.

客户终端给予足够的空间建立和应用机械交易系统(MTS,专家, 顾问). 环境的发展允许去创造，调试. 专家不仅仅建议交易信息, 还要从事在联机交易过程中完全指挥交易的活动.

MetaQuotes Language 4, MetaEditor 和 范畴测试工具 建立在终端内. 运用以下这些方法可以创建:

  • 专家顾问 — 机械交易系统允许分析和交易活动完全自动化。
  • 客户指示器 — 独立描绘 技术指示器 是对价格变更分析的预知。
  • 脚本 — 在请求时程序只运行一次。


Where to Get Trading Robots and Indicators

开始使用 / 自动交易 / Where to Get Trade Robots and Indicators

Where to Get Trading Robots and Indicators

The trading platform features a great amount of popular technical indicators. However, you are not limited to the provided set of tools. There are a lot of custom indicators you can obtain directly via the trading platform.

  • Market — a store of applications for the trading platform
  • Code Base — a free source code library of Expert Advisors and indicators
  • Freelance — a service where you can order trading applications
  • MQL4 — a programming language for developing Expert Advisors and indicators

Market — a Store of Applications for the Trading Platform

Market is a secure service for buying trading robots, indicators, scripts and other trading programs. The service offers ready-made applications for working on financial markets and is available to all trading platform users. They can open Market, buy or rent a program and launch it right via their platforms at any time.

Apart from automated trading applications, the Market also offers Magazines and Books.

To purchase a Market product, go to its page and click Buy. After the operation is confirmed, the application is activated and downloaded to an appropriate folder — Expert Advisors, Indicators or Scripts. The application appears in the Navigator window and is ready to be launched on a chart.

Code Base — a Free Source Code Library of Expert Advisors and Indicators

You have access to a huge library of free automated trading programs directly from your trading platform. Despite the fact that they are presented as source codes, you do not need to have programming skills to launch them.

The code is compiled automatically during the download and a ready-to-run application is placed to an appropriate folder — Expert Advisors, Indicators or Scripts. The application appears in the Navigator window and is ready to be launched on a chart.

Freelance — a Service Where You Can Order Trading Applications

In case you have not found the application you need in Code Base or Market sections, make an appropriate order to professional developers in Freelance section on MQL5.community website.

The process is completely secure, since a payment remains frozen and is transferred to a developer only when a customer accepts the work. In case of a dispute, you can resort to arbitration.

MQL4 — a Programming Language for Developing Expert Advisors and Indicators

You can develop trading robots and indicators using MQL4 programming language based on the concepts of well known and popular С++ language. MQL4 is also a high-level object-oriented programming language. However, due to its narrow specialization, MQL4 thrives in financial markets challenges.

Programs are developed using specialized MetaEditor tool which recognizes different language structures, suggests tips on how to use functions and highlights various elements of the program source code. Thus, the editor enhances navigation in the source code of trading programs and speeds up the development process.


???? ? MQL4

开始使用 / 自动交易 / MQL4

MetaQuotes Language 4

MetaQuotes Language 4 (MQL4) 是一种客户终端内的程序语言。 可以自动分析和操作交易。智能交易系统可以以自动的模式进行市场技术性分析。除此之外，智能交易系统还可通过接收到的信号下单执行交易， 并且监控开仓头寸。所有关于进行技术分析和交易的常规操作都可以交给智能交易系统执行。

MQL4的句法与 C 语言及其相似。如功能分析报价，管理寸头，显示技术指示器和其他都包含在MQL4中。 MetaEditor是内置的编辑器， 用于程序源代码的写入。 MetaQuotes Language 包含所有语言构造的描写和功能。

MQL4程序拥有不同的任务和属性：

  • 智能交易 是一种机械交易系统(MTS) 。 它能够在开启警报模式下，独立执行交易。终端可以历史数据定单中测试交易战略 ，也可以在不同的市场状态发觉交易特性。
  • 客户指示器r是一种特殊的技术指示器。它用于分析价格的变化。
  • 脚本 为执行单一功能而设计。不像智能交易系统， 脚本仅按需求执行一次，而不是按每笔报价执行。


???? ? MetaEditor

开始使用 / 自动交易 / MetaEditor

MetaEditor

MetaEditor是客户终端的一个组成部分。它能够创建，编辑，完成写入 MetaQuotes Language 4 (MQL4)程序的源代码。 应用到连接交易， 客户指示器， 脚本 和 DLL's。

Expert Advisors Wizard 建立在编辑器上帮助快速创建新MQL4程序。新文件将会自动保存在客户端的信息文件夹内。 模板用于MQL4 程序的创建。随后，开始编写程序文字。补充信息可以在 MQL4里找到完整的语言描述并附有范例。完成写入后，需要在MetaEditor里编译。若成功编译，被创建的程序代码开启 ，开始检测终端 。

关于MetaEditor的详细信息查看它的帮助文件。


????? ????

开始使用 / 自动交易 / 智能交易

智能交易

客户终端的智能交易系统调用使用 MetaQuotes Language 4 (MQL4) 语言开发的程序，可以自动分析和操作交易。 智能交易系统可以以自动的模式进行市场技术性分析。除此之外，智能交易系统还可通过接收到的信号下单执行交易，并且监控开仓头寸。 所有关于进行技术分析和交易的常规操作都可以交给智能交易系统执行。

运用智能意味着:

  • 交易的创建
    创建智能交易，与"MetaEditor"是密不可分的。
  • 交易安装
    在应用前必须安装。全部的交易特性在客户终端属性. 另外，每个交易拥有本身的属性。
  • 交易的开启
    开启智能交易，需使它进入图表。智能交易将会开始执行。
  • 关闭交易
    在交易从图表中删除后，关闭交易。


???? ? ??

开始使用 / 自动交易 / 智能交易 / 创建

交易的创建

创建智能，需应用 MetaQuotes Language 4 (MQL4) 和 MetaEditor.开启编译程序，需选择执行"创建"在 "导航— 智能交易窗口" 窗口 或者选择 "工具— MetaQuotes Language Editor" 目录 执行， 或按F4或选择 MetaEditor "常规" 工具条.

随后，EA创建向导将会自动开启 允许立即在新MQL4程序运用。 创建"智能交易" 必须完整填写以下:

  • 名称 — 自定义交易的名称。
  • 作者 — 作者的名称。
  • 连接 — 连接作者的网址。
  • 参数 — 参数列表。添加新的参数,需按 "添加" 或者选择 "删除"删除参数。

数据输入特定新的交易窗口后. 交易的资源文件(*.MQ4)将会自动在客户终端的/EXPERTS文件夹内保存。 这时可以填写代码。

在交易执行完成后，必须实施编辑。 这样做需选择选项"文件— 编辑" 完成 ，或按F5或者选择 编译 工具。 若成功编辑完成结果*.EX4将会自动保存于 /EXPERTS文件夹内。 这个编辑完成的列表能够在客户终端内的"导航— 智能交易" 窗口 查看。 如果没有编译成功，图表将会显示为灰白色。这意味着交易不可用。

交易的编译

从终端内编译存在的交易，需选择执行 "修改" 在"导航—智能交易"窗口 。 另外，在设置交易的源代码处交易将会打开。在交易源代码被修改后， 需选择 重新编辑它 得到新执行文件EX4 。 否则,终端将会运用未修改的交易版本。

注意: 如果交易没有成功完成,图标将会变白。这就意味着交易不可用。


????? ????

开始使用 / 自动交易 / 智能交易 / 智能交易

交易设置

在使用交易以前，必须实行安装。所有交易的工作属性常规在客户终端属性窗口. 开启这个窗口需选择 "工具—选项"目录 完成或按 快捷键 Ctrl+O。

设置交易特性，需选择设置 "智能交易" 所有属性将会显现如下:

  • 允许自动交易 — 该选项允许启用或禁用通过EA交易 和 脚本执行交易操作。如果被禁用，脚本和EA交易可以工作，但它们不能进行交易。该限制对于在实时模式下测试EA的分析能力可以非常有用（不要混淆历史数据上EA的测试）。自动交易也能被允许或禁止使用 自动交易 按钮在工具栏上。
  • 账户更改时禁用自动交易 — 该选项代表了保护机制，当账户更改时不启用EA和脚本交易。它很有用，例如，当把模拟账户变成真实账户的时候。
  • 当个人资料已经更改时不启用自动交易 — 有关工作区所有图表当前设置的大量信息存储在个人资料里。特别是，个人资料包含了附加的EA信息。个人资料包含的EA交易当新订单号进来时将会开始工作。 启用这个选项后，当个人资料更改时，您可以通过EA启动阻碍交易。
  • 当图表交易品种或周期更改时禁用自动交易 --- 如果启用了这个选项，那么当一个图表的周期或交易品种改变时附加的EA交易，将自动禁止执行交易操作。
  • 允许导入动态连接库
    为了增加运作功能，可以运用DLLs (动态链接库). 如果此选项开启，交易时将不受任何限制。如果禁止此选项进入，没有交易可以运用外部DLLs。 当运行不清楚的智能交易系统时，建议禁止此功能。
  • 允许WebRequest用于所列URL
    MQL4的WebRequest() 函数用于使用GET和POST请求接收和发送信息到网站。要允许MQL4应用程序发送这种请求，启用该选项并手动明确指定URL的可信网站。出于安全考虑，该选项默认禁用。


???? ???

开始使用 / 自动交易 / 智能交易 / 开启

智能交易的开启

在基本参数设定后，交易可以开启。 需要将交易添加到图表内。"添加到图表t"命令，需要在 "导航 —智能交易"窗口菜单中在选中的图表上双击鼠标左键。

"Drag'n'Drop"技术可以添加交易到任意的图表。另外，交易窗口的特有属性会显现。

在它的 "共享"标签内会显示以下内容：

  • 位置 — 选择打开位置的方向。
  • 多头&空头 — 方向。
  • 看涨 — 只买。
  • 卖空 —只卖。
  • 允许警报 — 允许/禁止交易警报。
  • 一次性警报 — 在第一次警报后禁止警报。
  • 允许现场交易 — 允许/禁止现场交易。
  • 允许DLL导入 — 允许/禁止从DLL 文件导入功能。
  • 允许外部交易导入 — 允许/禁止从外部交易导入功能。
  • 允许更改信号设置- 该选项允许/禁止MQL4应用程序订阅和取消订阅信号以及改变信号复制设置。MQL4应用程序以信号为基础的使用功能允许执行您自己的分析信号质量，动态管理订阅和调整风险。有关管理信号功能的更详尽信息提供在MQL4参考中。

在"输入数据"标签中外部可用交易可以改变。 保存输入数据，需要在它的价值处双击鼠标左键。另外，可以改变每个可用的价值或下载已保存的输入数据 ("加载"按钮)。

"重新设置"按钮使所有设置还原默认值。 在终端设置 窗口的 "共享"标签中会给出限定的参数。在程序源代码中限定参数被设为输入数据。 确认按 "确定"键即可，取消按键也可执行。

注意: 只有添加的交易可以自行设置。尽管，当前执行交易属性窗口没有打开。 另外，直到交易属性窗口关闭，交易不会开启。 如果交易的输入数据发生改变，交易将会应用新的输入数据重新初始化。需要按 "确定"按钮。

在交易设定后，它将会初始化 。随后添加到图表中。如果在 交易设置内禁止现场交易， L 显示表示运行成功， (û)表示被禁止。

注意:每个图表只可以附一个交易。如果其他交易进入，原有的交易会被替代。


????? ??

开始使用 / 自动交易 / 智能交易 / 完成

完成交易

完成交易，必须从图表中将其删除。 从图表中将其移除, 需选择执行 图表目录 "智能交易— 删除" 完成或附加其他交易到图表中。另外，交易能够从 数据图表或模板移除.

注意:

  • 客户终端完成，所有的交易也完成。
  • 当图表关闭时，附加到图表上的交易将完成。
  • 在前一个交易确认删除后，允许添加其他。
  • 从 "导航"窗口 中删除交易，而在同名图表中未完成。
  • 在客户终端属性开启交易并不等于完全开启交易。 选项start()会终止每个交易的功能，但init() 将会继续执行。


?????????

开始使用 / 自动交易 / 策略测试

策略测试

终端内部不仅仅可以写入智能交易，但在应用之前需要 测试。这一功能可以检测交易系统中的历史数据功率。. 该有用的功能测试允许在不同的市场条件下开始自动交易。 专业的 "测试" 建立在终端内。应用需要进入 交易优化窗口。


???????

开始使用 / 自动交易 / 策略测试 / 设置

测试参数设置

在开始策略测试之前，需要设置参数。需要完成以下内容：

  • 选中交易并设定输入数据
  • 选择商品和它的周期
  • 选择修改方式
  • 设定测试时间范围

测试和优化交易，在终端内可以应用特有"测试"窗口。 所有参数可以在 "设置" 窗口设置。

智能交易和它的参数

在 "测试 —智能交易" 选择测试的交易。在这里可以选择任何交易文件。 选择交易完成后，必须指定在/EXPERTS 文件夹内。

选择交易后，可以添加测试参数和输入数据。按"交易属性"按钮即可完成。

随后，新窗口内会显示以下三个标签：

  • 测试 — 通常情况下测试参数会在这里设定。在相应的部分会给出最初存款量和保证金。 在测试过程中存款会在交易中运行操作。 对于不同仓位类型有相应的测试，如下: 多头 —只打开看涨仓位；空头—只打开卖空仓位； 多头和空头— 打开看涨和卖空仓位。交易的运算是在开仓的指定管理下进行的。包括初始运算最佳化和选择被优化的参数。
  • 输入数据 — 所有输入数据列表会显现。可变的输入数据会直接影响客户端内的交易行为。 在定单中没有必要改变交易代码来改变交易参数。 输入数据的总体变量取决于交易。在测试时，交易的输入数据会在 "流量"中限定。 "开始"， "步骤"和"停止" 的动作不会影响交易测试和 它的参数最优化。 详细的使用参数查看"最佳化设定"部分。
  • 最佳化 — 在这个标签内的参数的改变将不会影响单独交易的测试。

商品和它的周期

交易测试不仅仅需要选择交易并设定。还需要选择商品和测试周期（时间范围）。 这些数据会应用到测试中。测试时，在终端可以选择任意商品或应用外部数据文件。 以*.FXT 格式储存于/TESTER文件中的历史数据会应用到测试中。如果在终端内选定商品，这些文件会在测试时自动创建。 如果应用外部数据，需要手动保存相应信息到/TESTER文件，并且禁止"重新估算"输入新数据覆盖。

商品测试的时间范围会在 "周期"显示。 如果商品没有数据文件，周期和模型方法也不会存在，它将会自动创建。若需要的文件已经创建完毕， "重新估算" 选项将会开启。如果对于商品和周期没有历史数据，测试将会自动下载最近512历史条。

注意: 如果商品所需的数据在最近512条之外，历史数据将会自动下载最后可用的数据。

模型方法

历史数据在终端内仅以条的形式储存， 会以TOHLCV (HST格式)呈现。 这些数据会应用到价格改变的模型中。一些情况下，一些信息不能满足测试。例如，对于每日的时间范围等等。

终端可以使用历史数据模型的多种方法测试交易。从较小的周期使用历史数据，可能看到价位的波动等等， 例如，当被测试的交易是一个小时的数据，那价位的变动是一分钟的数据。由于， 模型的历史数据接近真实的价位波动，使得交易测试更为真实。

以下的三种模型方法的任意一个可以关闭测试：

  • 只开价(最快的方法去分析完整条)
    一些机械交易系统不取决于模型条的属性，它们需要在完整条上交易。如果下一个条显现说明这个条是完整的。
    在这种模式下，模型条会第一个打开 (开仓 = 最高值 = 最低值= 平仓， 成交量=1)交易能够准确地识别在前面位置的 完整条。刚开始的条会应用到交易的开始测试中。下一步， 当前完整条将会给出，但测试不会执行！
  • 检测点 (应用最近的时间范围和不规则图形碎片插入)
    检测点模型是利用对于交易利润的粗糙估算和内部条进行的。对于这种方法可用的最近的历史数据时间范围会显示。 多数情况下，最近的时间范围可用数据不能完整覆盖测试的时间范围。如果最近时间范围的数据丢失，接下来的工作条在平仓后 形成先前的12工作条。那就意味着内部条的改变将会与最后的12个周期相同。这就是不规则图形碎片插入。
    最近时间范围显现后，对于新数据不规则图形碎片插入将被显示。但不是应用先前的12个条，而是6个。 意味着真正存在的开仓，最高值，最低值和平仓将会重新产生。 两个形成价格的价值和位置取决于先前的6个工作条。
  • 全部信用(在带有全部信用的不规则图形碎片可用的时间范围基础上)
    这是一个极其精确的内部工作条。 与"检测点"不同，它不仅最近的时间范围数据，而是利用最近时间范围的可用数据。 另外，如果在相同时间内对于相同时间段数据多于一个周期，最近的时间范围数据将会被应用到模型中。 与检测点相似的是同样利用不规则图形碎片插入。有可能出现一些相近的信用效仿其他。这种情况下，双倍的开价会被滤除。
    值得考虑的是大量应用数据。它会影响到交易系统的消耗和测试速度。

注意:

  • 如果最近时间范围没有可用数据覆盖测试，换而言之，结果不够精确，建议不要在全部信用上开启测试；
  • 在检测点上的模型是在交易最佳化的基础上，全部信用模型是为了关闭测试。

模型的质量可以在 "报告"窗口检查。 对了检测"模型质量"，颜色条可以呈现。模型质量有以下三种颜色：

  1. 灰色 — 这个部分的可用数据不会参与到测试中。如果测试的日期范围被指定灰色会显示；
  2. 红色 —在这个空间内模型没有执行，由于最近时间范围内的数据丢失。 另外， 只有在最近时间范围内选中的才会应用；
  3. 绿色 — 在这个空间内模型已经被执行。颜色的明暗度也有差别，颜色越亮说明模型质量越佳。

在模型参数和日期范围改变后，数据文件必须重新创建。 可以使用"重新估算"。如果设置没有发生改变，将无需重新估算。这种情况下，建议禁止定单减少测试时间。

时间范围

时间范围可以允许不测试交易全部可用数据，但需要内部中心时间。 如果需要测试历史数据的中心部分，它会充分发挥它的益处。时间范围不仅仅可以应用到交易测试中，也可以使用在模型条的测试中。 它无需模拟全部历史的数据，可以广泛的应用全部信用的数据。这就是数据范围可以在最初测试模型 设置的原因。数据会连续从指标估算的定单中进入，并记录为历史。必须记录下最先的100条将不被模拟。 这个界限不取决于日期限定。

允许日期范围限定，可以使用"应用日期"来指定所需要的时间"起始于" 和"截止到"。所有设置完成后，按 "开始"按钮即可开始测试。 在测试开始后，在窗口的下端可以查看接近完成的时间。

测试直观化

如果"直观化"被允许，在点击"开始"按钮后，图表将会自动打开，图表上的模型将会运行。 重放速度可以控制。重放也可以按"||" 按钮推迟。重新点击此键将会继续运行 按快捷键F12可以立即显示下一个信用。直观化能够跳过中心日期。在需要的日期设定后点击"跳到" 就会显现所需要的页面。

注意： 如果"最佳化"允许， 交易参数就会被优化， 而不是测试，按 "开始"按钮即可。


???????

开始使用 / 自动交易 / 策略测试 / 结果

测试结果

在测试完成后，能够在"结果"， "图表"， "报告"和 "日志"标签中查看结果。

结果

所有交易业务执行的信息会以以下类表呈现：

  • # — 交易业务的次序数字。
  • 时间 —交易业务执行的时间。
  • 类型 — 交易类型(卖，买，止损，赢利，修改，平仓等等。)。
  • 定单 — 交易仓或挂单交易的数票 。
  • 份额 —交易份额的总数。
  • 价格 — 交易中的商品价格。
  • S/L — 止损定单。在这个标签内没有意味着没有止损定单。
  • T/P —赢利定单。在这个标签内没有意味着没有赢利定单。
  • 获利 — 盈利/亏损。在平仓后盈利/亏损会显现。
  • 差额 —价值差额。只有在平仓后价值差额才会显现。

可以把鼠标放在数组上方点击鼠标左键，就可以减少或增加定单。 应用 "复制"按钮或快捷键Ctrl+C，可以复制所选结果到写字板。以便将来应用。 如果没有选择需要数组，整个文件会被复制到写字板内，按 "全部复制"操作即可。结果报告可以以HTML 文件保存到硬盘内。 可以使用"保存报告为"操作。 "设置日期 "起始于""和 "设置日期 "截止到""允许设定时间间隔。另外，所选择的时间会写入到 "应用起始日期:"和 "应用截至日期:" 在测试设置 窗口。

图表

通常开仓账户的状态(绿色线为 "份额")会自动画在"图表"标签内。 如果只有平衡线显示在图表内，意味着在测试周期内"差额" 和 "份额"处于平衡状态。 图表可以使交易测试直观化。如果在测试过程中份额大小有所改变，改变的份额大小会在图表底部显示。

在图表处双击鼠标左键转换 "结果" 标签选取相应线路。运用"复制"键或快捷键Ctrl+C,复制到写字板以便应用于其他。图表也可以作为GIF文件储存在硬盘内。 可以使用"图片保存为" 或快捷键Ctrl+S。 "设置日期 "起始于""和 "设置日期 "截止到""允许设定时间间隔。另外，所选择的时间会写入到 "应用起始日期:"和 "应用截至日期:" 在测试设置 窗口。

报告

交易测试形成的结果和一些键会在 "报告"标签内呈现。 包含以下测试结果和一些主要参数：

  • 测试的棒图 — 历史的棒图的数量。
  • Tick 模型 — 在测试时，Tick模型的数量。
  • 模型的质量 — Tick模型质量的百分比值。模型是显示下一个报告的简图。有三种颜色：
  • 灰色 — 这部分的数据没有被测试。如果这些数据在测试设置部分给出，将以灰色显示。
  • 红色 — 在这个区域内短时期内没有数据模型可以执行。 另外，只有在 测试设置部分选中的数据才可以应用。
  • 绿色 — 在这个区域已经执行的模型。另外，颜色微亮些的部分，是质量模型。 例如，当在H1范围内测试时，深绿色的一组意味着数据测试的时间段为M30，亮绿色则表示时间段为M1。

注意: 如果应用最快的方法("开价") 在 测试设置部分应用模型，所有数组将会变红。另外， "n/a" — 模型还未被执行 — 会被写入 "模型的质量"标签内。
  • 初始存款 — 初始存款数量。
  • 总净利润 — 盈利减去亏损的数值。
  • 总获利 — 所有盈利交易的盈利总额。
  • 总损失 — 所有有亏损交易的亏损总额。
  • 利润因子 — 盈利减去亏损的百分比比率。意思就是说总体赢利与总体损失相同。
  • 预计盈利 — 通过数学运算来预计盈利。换而言之，是利用统计的估算方法预测交易中的赢利/损失显示平均数。 还可以通过它估算下一场交易的赢利/损失。
  • 亏损绝对值 — 在余额下最大亏损值。
  • 亏损最大值 (%) — 亏损交易的最大值的百分比率。
  • 交易总计 — 总计交易的数量。
  • 空头头寸 (盈利 %) — 建立空头头寸的数量和其中盈利的百分比。
  • 多头头寸(盈利 % ) — 建立多头头寸的数量和其中盈利的百分比。
  • 盈利交易(与总交易数量的%) — 盈利头寸的数量及其占总交易数量的百分比。
  • 损失交易(与总交易数量的%) — 亏损头寸的数量及其占总交易数量的百分比。
  • 最大的获利交易 — 最大盈利的交易。
  • 最大的亏损交易 —最大亏损的交易。
  • 平均盈利 — 每一笔交易的平均盈利。
  • 平均亏损 — 每一笔交易的平均亏损。
  • 最大连续盈利（盈利金额） — 最大的连续盈利交易及其总和金额。
  • 最大连续损失（亏损金额） — 最大的连续亏损交易及其总和金额。
  • 最大连续盈利（盈利次数） — 最大的连续盈利交易及其总次数。
  • 最大连续损失（亏损次数） — 最大的连续亏损交易及其总次数。
  • 平均连续盈利 — 连续盈利交易的平均数。
  • 平均连续损失 — 连续损失交易的平均数。

复制报告到写字板，报告可以以HTML文件形式保存在硬盘内。 可以使用"复制" "保存报告"执行操作，或按快捷键 Ctrl+C保存，功效相同。

"日志"标签

所有交易业务和相关的交易测试进程都会自动公布在"日志" 标签内。 日志更倾向于 "终端 —智能交易" 窗口， 除了在智能系统测试而不是在市场真实操作期 间发布的信息以外，该日志与终端窗口的日志相同。 在测试结束之后。数据输出在单独的文件夹TESTER/LOGS。 测试日志保存在文件夹/EXPERTS/LOGS，文件名称与相应的日期记录相符— YYYYMMDD.LOG。 查看现有记录，选中文件执行"打开"操作。 可以复制当前记录到写字板。 当执行"全部删除"时，所有的记录将从目录中删除。


????? FXT ???????

开始使用 / 自动交易 / 策略测试 / FXT 格式的历史文件

FXT 格式的历史文件

测试者应用*.FXT 文件形成柱状图。每一个形成柱状的连线记录会在状态栏上呈现。 当运用模型柱时,如果它刚开始形成,测试者从这个文件中选择新的模型柱并更新前边的模型柱或另外增添。

测试/优化时可以拒绝标准柱的模式化并使用自己的数据文件。 为此必须禁止 "重新估算" 并把所必需的FXT文件放入/TESTER/HISTORY文件夹.文件名必须以 "[商品名称][周期时段]_[模型类型 (0 — 按照每个 tick, 1 —按照检测点, 2 — 按照开价)].FXT" (不带空格)格式显示. 例如，它可以是 "EURUSD1440_1.FXT" 在"EURUSD" 是商品保证金的位置 "1440" D1 (1440 分钟, 24 小时)的时段, 并且 "1"意思是检测点标准化。

下面给出一个简短的格式描述。它是带有主题开始的：

//+------------------------------------------------------------------+
//| |
//+------------------------------------------------------------------+
struct TestHistoryHeader
{
int version; // 405
char copyright[64]; // 版权
char symbol[12];
int period;
int model; //生成订单号序列的模式类型
int bars; // 历史中的柱数
time_t fromdate; // 从该日期生成订单号
time_t todate; // 订单号生成截止于此日期
double modelquality; // 模式质量
//---- 普通参数
char currency[12]; // 货币基础
int 点差；
int 数字；
double 点；
int lot_min; // 最小手数大小
int lot_max; // 最大手数大小
int lot_step;
int stops_level; // 止损水平值
int gtc_pendings; // 在一天结束的时候关闭挂单的指示
//---- 利润计算参数
double contract_size; // 合约大小
double tick_value; // 一个订单号值
double tick_size; // 一个订单号大小
int profit_mode; // 利润计算模式 { PROFIT_CALC_FOREX, PROFIT_CALC_CFD, PROFIT_CALC_FUTURES }
//---- 库存费计算
int swap_enable; // 启用库存费
int swap_type; // 库存费类型 { SWAP_BY_POINTS, SWAP_BY_DOLLARS, SWAP_BY_INTEREST }
double swap_long;
double swap_short; // 整夜库存费的值
int swap_rollover3days; // 库存费延期交割三日
//---- 预付款计算
int leverage; // 杠杆
int free_margin_mode; // 可用预付款计算模式 { MARGIN_DONT_USE, MARGIN_USE_ALL, MARGIN_USE_PROFIT, MARGIN_USE_LOSS }
int margin_mode; // 预付款计算模式 { MARGIN_CALC_FOREX,MARGIN_CALC_CFD,MARGIN_CALC_FUTURES,MARGIN_CALC_CFDINDEX };
int margin_stopout; // 预付款止损离场水平
int margin_stopout_mode;// 止损离场检查模式 { MARGIN_TYPE_PERCENT, MARGIN_TYPE_CURRENCY }
double margin_initial; // 预付款请求
double margin_maintenance; // 预付款维持请求
double margin_hedged; // 预付款对冲请求
double margin_divider; // 预付款分割
char margin_currency[12];// 预付款货币
//---- 手续费计算
double comm_base; // 基本手续费
int comm_type; // 基本手续费类型 { COMM_TYPE_MONEY, COMM_TYPE_PIPS, COMM_TYPE_PERCENT }
int comm_lots; // 每手或每笔交易的手续费 { COMMISSION_PER_LOT, COMMISSION_PER_DEAL }
//---- 内部使用
int from_bar; // 起始日期柱数
int to_bar; // 截止日期柱数
int start_period[6]; // 最小周期模式开始的柱数
int set_from; // 测试设置的开始日期
int set_to; // 测试设置的结束日期
//----
int freeze_level; // 以点数计算的订单冻结水平
int generating_errors;
//----
int reserved[60];;
};

然后，模型柱的安排如下：

#pragma pack(push,1)
struct TestHistory
{
time_t otm; // bar time
double open; // OHLCV 值
double low;
double high;
double close;
double volume;
time_t ctm; // 柱内的当前时间
int flag; // 标记启动EA （0 - 柱将被更改，但是EA将不会启动）
};
#pragma pack(pop)


?????????

开始使用 / 自动交易 / 交易优化

交易优化

通过输入不同的数据进行对智能交易的优化。另外，一些参数会从交易功效中清除。终端可以允许自动运行这个程序。 优化交易，可以在 "测试" 窗口中 按"开始" 按钮。


??????? ???

开始使用 / 自动交易 / 交易优化 / 设定

最佳化设定

最佳化呈现的交易顺序与同样输入数据的顺序不同。另外，一些数据能够给交易带来最大利润。 终端允许这个步骤地自动运行。在优化交易参数之前，需要设定以下：

  • 选择交易和它的输入数据
  • 选择商品和它的时间范围
  • 选择一个模型方法
  • 设定最佳化的间距

在终端内存在交易测试和最佳化的窗口"测试"。 所有安装列表可以在"安装"标签内看到。

智能交易和它的参数

需要在"测试 —交易"窗口选择需要优化的交易参数。 优化交易必须编辑并放置到/EXPERTS 文件夹内。

选定EA后，就必须做额外的设置并设置输入。这可以通过按下“EA属性”按钮来完成。

然后，含有以下三个标签的新窗口将会出现：

测试

在这个标签设置普通优化参数。它们包括在相关字段指定的初始入金交易量和货币。这是优化期间由EA操作的入金。

在本标签选定持仓类型，以及：只买入，只卖出，或买入和卖出。无论EA使用什么算法，都将只在这里定义的方向持仓。

在这里可以打开优化的遗传算法。关于它的详细信息提供在"遗传算法：数学"文章。

优化参数是一个特定因素，它的值定义了测试参数系列的质量。优化标准的值越高，给定参数系列的测试值越好。以下参数用于优化：

  • 结余 — 结余的最高值。
  • 利润因子 — 利润因子的最高值。
  • 期望收益 — 期望收益的最高值。
  • 最大跌幅 — 最大跌幅的最低值。
  • 跌幅百分比 — 相对跌幅的最低值（百分比计算） 。
  • 自定义 — 这里优化标准就是EA交易中的OnTester()函数的值。该参数允许使用任何自定义的值用来优化EA交易。

输入

这里所有输入都列在一个表上。输入是影响EA 操作的变量，可以直接从客户端更改。由于这些操作要被更改，所以也无需改变EA代码。输入量的变化取决于EA。

优化时，EA输入在“开始”，“步长”，和“停止”字段中设置。初始值，更改间隔，和外部变量的终值都将在这些字段分别设置。变量名称左侧有许多勾选框，包括优化进程的参数。如果在这个勾选框没有勾选该变量，那么它就不会参与优化。优化过程中不能改变它的值，并且在这里写下“值”字段给出的参数。EA通过的数量直接取决于这些参数。“值”字段写下的数据不会影响EA优化而只是用于测试需要。

之前已经保存的输入组（包括“开始”，“步长”，和“停止”字段中给定的组）可以被下载。这可以通过点击“载入”按钮和选择预保存的参数组来完成。当前的外部变量组可以通过按下相应的按钮来保存。

优化

优化 — 该标签允许管理优化时的局限性。如果单次通过时遇到任何情况，那么该次EA通过就将会受到干扰。优化会在下次通过时继续。

要启用条件限制，就需要在其左侧的勾选框做出标记。在“值”字段双击鼠标左键可以用来改变现有参数。极限参数：

  • 最低结余 — 存款货币的最小结余值。
  • 最高利润 — 存款货币的最高利润。
  • 最低预付款水平% — 最低预付款水平百分比。
  • 最大跌幅% — 最大跌幅百分比。
  • 连续亏损 — 最大系列的亏损。亏损系列是许多连续亏损的交易。。
  • 连续亏损交易 — 一个系列内最大亏损交易额。
  • 连胜 —个系列内最大的总利润。盈利系列就是许多连续获利的交易。
  • 连胜交易 — 一个系列内最大的盈利交易额。。

商品和它的周期

交易测试不仅仅需要选择交易并设定。还需要选择商品和优化周期（时间范围）。 这些数据会应用到优化中。优化时，在终端可以选择任意商品或应用外部数据文件。 以*.FXT 格式储存于/TESTER文件中的历史数据会应用到测试中。如果在终端内选定商品，这些文件会在测试时自动创建。 如果应用外部数据，需要手动保存相应信息到/TESTER文件，并且禁止"重新估算"输入新数据覆盖。

商品测试的时间范围会在 "周期"显示。 如果商品没有数据文件，周期和模型方法也不会存在，它将会自动创建。若需要的文件已经创建完毕， "重新估算" 选项将会开启。如果对于商品和周期没有历史数据，测试将会自动下载最近512历史条。

注意: 如果商品所需的数据在最近512条之外，历史数据将会自动下载最后可用的数据。

模型方法

历史数据在终端内仅以条的形式储存， 会以TOHLCV (HST格式)呈现。 这些数据会应用到价格改变的模型中。一些情况下，一些信息不能满足测试。例如，对于每日的时间范围等等。

终端可以使用历史数据模型的多种方法测试交易。从较小的周期使用历史数据，可能看到价位的波动等等， 例如，当被测试的交易是一个小时的数据，那价位的变动是一分钟的数据。由于， 模型的历史数据接近真实的价位波动，使得交易测试更为真实。

以下的三种模型方法的任意一个可以关闭测试：

  • 只开价(最快的方法去分析完整条)
    一些机械交易系统不取决于模型条的属性，它们需要在完整条上交易。如果下一个条显现说明这个条是完整的。
    在这种模式下，模型条会第一个打开 (开仓 = 最高值 = 最低值= 平仓， 成交量=1)交易能够准确地识别在前面位置的 完整条。刚开始的条会应用到交易的开始测试中。下一步， 当前完整条将会给出，但测试不会执行!
  • 检测点 (应用最近的时间范围和不规则图形碎片插入)
    检测点模型是利用对于交易利润的粗糙估算和内部条进行的。对于这种方法可用的最近的历史数据时间范围会显示。 多数情况下，最近的时间范围可用数据不能完整覆盖测试的时间范围。如果最近时间范围的数据丢失，接下来的工作条在平仓后 形成先前的12工作条。那就意味着内部条的改变将会与最后的12个周期相同。这就是不规则图形碎片插入。
    最近时间范围显现后，对于新数据不规则图形碎片插入将被显示。但不是应用先前的12个条，而是6个。 意味着真正存在的开仓，最高值，最低值和平仓将会重新产生。 两个形成价格的价值和位置取决于先前的6个工作条。
  • 全部信用(在带有全部信用的不规则图形碎片可用的时间范围基础上)
    这是一个极其精确的内部工作条。 与"检测点"不同，它不仅最近的时间范围数据，而是利用最近时间范围的可用数据。 另外，如果在相同时间内对于相同时间段数据多于一个周期，最近的时间范围数据将会被应用到模型中。 与检测点相似的是同样利用不规则图形碎片插入。有可能出现一些相近的信用效仿其他。这种情况下，双倍的开价会被滤除。
    值得考虑的是大量应用数据。它会影响到交易系统的消耗和测试速度。

注意:

  • 如果最近时间范围没有可用数据覆盖测试，换而言之，结果不够精确，建议不要在全部信用上开启测试；
  • 在检测点上的模型是在交易最佳化的基础上，全部信用模型是为了关闭测试。

在模型参数和日期范围改变后，数据文件必须重新创建。 可以使用"重新估算"。如果设置没有发生改变，将无需重新估算。这种情况下，建议禁止定单减少测试时间。

时间范围

时间范围可以允许不测试交易全部可用数据，但需要内部中心时间。 如果需要测试历史数据的中心部分，它会充分发挥它的益处。时间范围不仅仅可以应用到交易测试中，也可以使用在模型条的测试中。 它无需模拟全部历史的数据，可以广泛的应用全部信用的数据。这就是数据范围可以在最初测试模型 设置的原因。数据会连续从指标估算的定单中进入，并记录为历史。必须记录下最先的100条将不被模拟。 这个界限不取决于日期限定。

允许日期范围限定，可以使用"应用日期"来指定所需要的时间"起始于" 和"截止到"。所有设置完成后，按 "开始"按钮即可开始测试。 在测试开始后，在窗口的下端可以查看接近完成的时间。

注意:

  • 如果"最佳化"允许， 交易参数就会被优化， 而不是测试，按 "开始"按钮即可。
  • 最佳化过程中与测试不同，需要应用自己的历史文件。


??????????

开始使用 / 自动交易 / 交易优化 / 结果

最佳化结果

在优化被完成后，优化的结果可以在"最优化结果"和 "最优化图表"窗口查看。

最优化结果

与测试不同，最优化是利用通过机械交易系统(MTS)输入不同数据。 最佳化结果是预算出交易最高获利值。 最佳化交易需要在 测试设置窗口 "最佳化"按"开始"。随后，会在窗口中显现 "最佳化结果" 和"最佳化图表"。

最优化结果"表格与测试报告不同， 不公开完整的交易列表。所有数据会呈现在包含以下内容的表格里：

  • 许可证 — 许可证号码。
  • 赢利 — 纯赢利(总共赢利减去总共损失)。
  • 交易总量 — 开仓交易的总量。
  • 利润因子 — 总体赢利减去总体损失的百分比。意思就是说总体赢利与总体损失相同。
  • 预计盈利 — 通过数学运算来预计盈利。换而言之，是利用统计的估算方法预测交易中的赢利/损失显示平均数。 还可以通过它估算下一场交易的赢利/损失。
  • 借款 $ — 最大借款限额与当前的存款有直接的关系。
  • 借款 % — 最大借款限额取决于最初存款的百分比。
  • 输入数据 — 在每个许可证输入数据的价值。

用鼠标左键单击任何一个数列上端，即可将定单的减少量和增加量分类。 所选中许可证的数据将会作为交易基本数据输入( 交易属性窗口"输入数据" 表格)。 在"设定输入数据参数"执行后。另外，程序在"设置" 表格关闭后, 最优化模式也会停止。 按"开始" 键，可以测试智能交易输入数据的参数和变量。 也可以通过在最优化结果的许可表格内双击鼠标左键完成。 应用 "复制"或快捷键Ctrl+C可以复制所有数据到写字板中， 以便以后应用。如果没有选中线路全部表格将会复制到写字板中。 应用"全部复制"便于复制所有表格到写字板中。 最优化结果的报告可以以HTML格式保存到硬盘上。可以使用"保存"键执行操作。 其他一些结果显示命令允许在子菜单执行，包括以下:

  • 略过无价值结果 — 显示/隐藏损失结果。
  • 显示输入数据参数 — 显示/隐藏"输入数据"数列。
  • 自动排列 — 当改变窗口时自动调整数据的尺寸。
    也可以按A，功能相同。
  • 网格 — 显示/隐藏数列的分类网格。
    也可以按G，功能相同。

最佳化图表

所有获利的执行都会直观的画在"最佳化图表"标签内。 所有通过的获利图表会在 "最佳化图表"标签内自动画出。图表允许估算和显示不同数据组合所带来的利润。 赢利（绿色）和止损（红色）均可在图表中显现。

在图表处双击鼠标左键转换 "结果" 标签选取相应线路。运用"复制"键或快捷键Ctrl+C,复制到写字板以便应用于其他。图表也可以作为GIF文件储存在硬盘内。 可以使用"图片保存为" 或快捷键Ctrl+S。


???? ? ?????

开始使用 / 自动交易 / 客户指示器

客户指示器

客户指示器是一种独立的程序在 MetaQuotes Language 4中 存在技术指示器的作用. 技术指示器是一种精确的价格换算和预测未来价格走势的工具. 运用指示器可以提出货币趋势存留和转账的相关问题 . 指示器能够使繁琐的交易过程变得简单易懂. 指示器也能在运算的基础上发展交易战略和专家顾问。

注意:客户指示器仅仅是分析价格走势的工具, 自身并不能够完成交易业务。

使用客户指示器工具:

  • 创建指示器
    创建编译客户指示器, 需运用固有装置 "MetaEditor". 它是客户终端组成的一部分, 同时呈现一个研究MQL4程序的舒适环境。
  • 属性指示器
    在运用客户指示器之前, 首先需要安装. 全部指示器的工作范围在 用户终端设置窗口. 另外, 每一个指示器拥有自身的属性。
  • 放置指示器
    放入图表后,指示器自身能够预测特性。
  • 删除指示器
    如果指示器不再需要, 可以从图表中删除。


????? ? ??

开始使用 / 自动交易 / 客户指示器 / 创建

客户指示器的创建

创建客户指示器，需运用MetaQuotes Language 4 (MQL4) 和 MetaEditor程序。 选择选项 "导航— 客户指示器" 窗口 "创建"执行完成或者选择 "工具— MetaQuotes Language Editor" 目录 完成，再者按F4或者选择 MetaEditor "常规" 工具条. MQL4 程序的创建，Experts Wizard允许新创建的MQL4程序自动开启。 "客户指示器" 必须是针对一个对象设置，

需完整填写以下内容:

  • 名称 — 指示器名称。
  • 作者 — 作者的名称。
  • 连接 — 作者的网址。
  • 参数 — 指示器参数的列表。 添加新的参数， 需按 "添加" ， 删除则需选择 "删除"执行完成。

然后，需要确定新指示器将会创建一个分开的二级窗口和它的范围。 另外,需要确定总量和指示器数组的特性。 这样，它们的价格元素将会在图表中画出。 换句话讲，当指示器的数据被确定，曲线也被确定。随后，带有新指示器的窗口将会打开。带有代码(*.MQ4)的指示器将会自动放置到客户终端文件夹内。

创建后，必须编译。 编译指示器需选择 "文件 — 编译" 执行， 按F9 或选择 编译 工具条完成。 成功编译指示器后，带有 *.EX4扩充部分已经编译完成的程序文件将会自动放置于/EXPERTS/INDICATORS文件夹内. 客户指示器的列表可以在客户终端内 "导航 — 客户指示器s" 窗口 查看。

客户指示器的修改

从终端内修改现有的指示器，需选择 "导航—客户指示器""修改" 执行完成。 另外， MetaEditor将会在设置指示器的位置打开下载代码。 代码改变后，将需要 重新编译一个新的 EX4执行文件. 在其他情况下，没有修改的指示器版本会在终端内继续应用。

注意: 如果指示器的编译出现差错，错误会附加到图表上。


????? ? ??

开始使用 / 自动交易 / 客户指示器 / 安装

客户指示器安装

指示器在使用前必须安装。 全部客户指示器安装在 客户终端设置内。通讯窗口打开可以通过 "工具— 选取" 目录 执行或按快捷键Ctrl+O。 指示器的安装，需选择"专家顾问"。

客户指示器只有两个功能:

  • 允许DLL进入
    客户指示器应用DLLs增大他们的机能。如果这项功能开启，打开图书收藏将不受任何限。
  • 允许WebRequest用于所列URL
    MQL4的WebRequest() 函数用于使用GET和POST请求接收和发送信息到网站。要允许MQL4应用程序发送这种请求，启用该选项并手动明确指定URL的可信网站。出于安全考虑，该选项默认禁用。


????? ? ????

开始使用 / 自动交易 / 客户指示器 / 附加图表

怎样在客户指示器上附加图表

在 基本安装 完成后， 需要在客户指示器上附加图表。客户指示器可以利用在运行的图表上双击鼠标左键 进入 "导航 — 客户指示器" 窗口或者选择执行 "附加图表". "Drag'n'Drop"允许利用技术工具进入任何图表。 另外， 设置窗口将会自动显现以下图表:

  • 常规图表
    从DLLs和MQL4进入管理 "常规"图表。另外,如果指示器画在二级窗口内,从这里放置到它的领域。
  • 允许DLL导入 — 允许/禁止从DLL 文件导入功能。
  • 允许外部交易导入 — 允许/禁止从外部交易导入功能。
  • 允许更改信号设置 — 该选项允许/禁止MQL4应用程序订阅和取消订阅信号 以及改变信号复制设置。MQL4应用程序以信号为基础的使用功能允许执行您自己的分析信号质量，动态管理订阅和调整风险。有关管理信号功能的更详尽信息提供在 MQL4 参考中。
  • 输入数据
    外部的定量直接被终端内的 "输入数据"图表所控制。 修改变量, 需在图表中它的价格上双击和写下新的数据。
  • 彩色图表
    "彩色"图表被指示器元素所控制显现在屏幕上。除颜色外, 同样可以修改它的宽度和曲线风格。
  • 水平图表
    水平线能够在任何一个"水平" 图表指示器窗口设置. 创建新的水平图表，需点击"添加" ,若要删除它, 则点击"删除" 图表的颜色，宽度，风格也可以改变。

注意: 这种图表对于直接画出价格图表不可用。
  • 直观图表
    在"直观"图表中能够表现时间段内的指示器。如果相同的指示器对于不同的时间段拥有不同的设置，直观图表表现它的优势。 比如说，进入不同设置的相同指示器的图表内：前者将会运行详细的时间段，而后一个指示器将会运行大的时间段。 "在数据图表中显示" 可以选择显示/隐藏指示器在 数据窗口给出的数据。

在这之后指示器将立即重新开始估算并画在图表上。 客户指示器是一种技术机械，它能在二级窗口内创建自己的等级 (例如, MACD) 或者直接进入价格图表(例如, Moving Average)。


????????

开始使用 / 自动交易 / 客户指示器 / 删除

从图表中删除客户指示器

关闭指示器，从图表中删除。另外，图表的画线和它的价格重新计算将会停止。 从图表中删除指示器，需选择执行 "删除指示器" 或"删除指示器窗口"， 或者 选择执行 "指示器列表— 删除"。

注意: 从 "导航"窗口删除客户指示器将不需关闭指示器。


???????

开始使用 / 自动交易 / 脚本

脚本

脚本是一种由MetaQuotes Language 4 (MQL4) 语言编写的程序， 为执行单一功能而设计。不像智能交易系统，脚本仅按需求执行一次，而不是按每笔报价执行。

脚本包括以下内容:

  • 脚本的创建
    应用"MetaEditor"创建并编辑脚本。它是由客户终端和MQL4程序组成。
  • 脚本的安装
    在应用前须安装脚本。在 客户终端安装窗口安装。 每个脚本都拥有自己的属性。
  • 脚本的开启
    开启脚本，需要附加在图表上。附加之后脚本会立即开始运算。
  • 脚本的删除
    脚本运算完成后可以从图表中删除。


?????

开始使用 / 自动交易 / 脚本 / 创建

创建

脚本的创建需要应用MetaQuotes Language 4 (MQL4) 和MetaEditor.开启交易编辑程序，可以在 "导航 — 脚本" 窗口点击"创建"操作，或者使用 "工具 — MetaQuotes Language" 菜单 执行，或按F4或在 "常规" 工具中按 MetaEditor 。MQL4 程序创建时，EA创建向导将会自动打开，允许立即创建新的MQL4程序。创建对象时必须在其中选择“脚本”，

并且所有必要的字段都要填写：

  • 名称 — 脚本名称。
  • 作者 — 作者的名称。
  • 连接 — 作者的网址。

随后，新脚本会在编辑器中打开。含源代码(*.MQ4)的脚本文件将会自动安放在 客户端的 /EXPERTS/SCRIPTS文件夹内。然后，可以编写程序源代码。

创建脚本后，必须进行编译。可以使用"文件 — 编辑" ，按F5或者按 编译 按钮。脚本被成功编译后，带有*.EX4执行文件将会自动安放于/EXPERTS/SCRIPTS 文件夹内。 所有脚本的列表可以在客户端的 "导航—脚本"窗口 查看。

脚本的编辑

从终端内编辑现存的脚本，可以使用 "导航—脚本" 窗口 按"修改"执行。 另外，已下载的脚本源代码会打开。源代码被修改后，需要重新编译得到新执行文件EX4。 若没有修改终端会继续运行老版本。


?? ???

开始使用 / 自动交易 / 脚本 / 安装

安装

在应用脚本之前，需要安装。在终端属性窗口随时可以查看所有脚本运行情况。 可以应用 "工具 — 选项"菜单打开操作或按快捷键 Ctrl+O。 设定脚本参数，需要打开"智能交易"表。

只有五项影响着脚本业务:

  • 允许自动交易 — 该选项允许启用或禁用通过EA交易 和 脚本执行交易操作。如果被禁用，脚本和EA交易可以工作，但它们不能进行交易。该限制对于在实时模式下测试EA的分析能力可以非常有用（不要混淆历史数据上EA的测试）。自动交易也能被允许或禁止使用 自动交易 按钮在工具栏上。
  • 允许 DLL输入
    应用DLLs，脚本能够增加功能。 如果选项开启，资料库将不受任何限制。 如果选项关闭，任何脚本都不能应用。
  • 允许WebRequest用于所列URL
    MQL4的WebRequest() 函数用于使用GET和POST请求接收和发送信息到网站。要允许MQL4应用程序发送这种请求，启用该选项并手动明确指定URL的可信网站。出于安全考虑，该选项默认禁用。


?????

开始使用 / 自动交易 / 脚本 / 开启

开启

在 全部参数 安装后，这时脚本能够开启。需要将它附加在图表上。 另外，在程序源代码中存在"#property show_inputs" 命令，这样脚本设置窗口将会自动显示。

在 "共享"窗口图表中显现如下:

  • 仓位 — 选择管理开仓:
  • Long&Short — 双重执行。
  • Only Long — 只买。
  • Only Short — 只卖。
  • 开启警报 — 开启/关闭脚本警报。
  • 一次性警报 — 警报一次后关闭。
  • 允许现场交易 — 开启/关闭现场交易。
  • 允许DLL输入 — 开启/关闭从DLL文件的输入功能。
  • 允许外部交易的输入 — 从外部交易开启/关闭功能。
  • 允许更改信号设置- 该选项允许/禁止MQL4应用程序订阅和取消订阅信号以及改变信号复制设置。MQL4应用程序以信号为基础的使用功能允许执行您自己的分析信号质量，动态管理订阅和调整风险。有关管理信号功能的更详尽信息提供在MQL4参考中。

在"输入"表中脚本外部的变量可以改变。 改变参数，可以双击鼠标左键在价值上填写新参数。另外， 在每个变量的价值改变或输入信息下载之前已经被保存( "加载" )。 利用这个键同样可以保存输入设置。

使用"复位" 键恢复默认设置。在 终端属性内限定参数， 在"共享" 表内设定。脚本参数的限定可以按"确定"和取消相同。

注意: 脚本与交易 和客户指示器不同只有在开启后才会显示属性。

脚本会立即开启。 双击鼠标左键在"导航 — 脚本"窗口选中脚本或者 在 "图表执行"操作，将会附加图表到已激活的图表中。 "Drag'n'Drop" 技术可以使脚本附加到任意图表。如果"删除脚本" 在图表窗口显现，说明脚本已经运行。 命令被激活后MQL4程序同时运行。

注意: 每个图表只可以附加一个脚本。


??? ??

开始使用 / 自动交易 / 脚本 / 关闭

关闭

一般来讲，脚本本身可以关闭。但它也可以手动删除。另外，它必须从储存卡中移除。 从图表中删除脚本，可以使用图表控制菜单 "删除脚本" 操作或者在这图表上附加其他脚本。另外，脚本被删除后，品种和时间段将发生改变。

注意:

  • 终端在关闭后，所有脚本会被删除。
  • 从 "导航"窗口删除脚本，MQL4程序中的脚本会继续运行。


工具

开始使用 / 工具

工具

该部分描述了客户端的各种服务功能：

  • 配置开启
  • 历史数据中心
  • 行情输出
  • 总体变量
  • 协议一览表
  • 语言帮助


?? ?????

开始使用 / 工具 / 配置开启

配置开启

客户端可以应用预先设定开启。 For this purpose,这样配置文件的名称会作为参数通过客户端。

例如:

terminal.exe config\start.ini
terminal.exe test1.txt
terminal.exe "C:\Program Files\MetaTrader 4\config\settings25.ini"

如果没有给出完整路径(Drive:\SubDirectory\FileName) 在客户端目录里搜索文件。配置文件包括以下内容：

[参数] = [成交量]

注解以分号开始(;)。

配置文件分以下几组: 通用设置，代理服务器设置(终端设置 "服务器" )， FTP 设置 (服务器设置 "公开页" ) EA 设置 (服务器设置"智能交易" )， 交易或脚本的单独设置，策略测试设置的开启。

通用设置

  • Profile — 在数据图表目录中的子菜单名称。客户端内的图表会按照所给出的数据图表打开。 如果参数没有被指定，当前数据图表会被打开。
  • MarketWatch — 在包含商品列表的文件名称内( 目录\symbolsets ) 会显示在市场报价窗口。 文件可以在执行命令的"市场报价 - 设置 - 保存为..."窗口得到。
  • Login — 建立连接账户数字。如果参数未被设定，应用当前登陆。
  • Password — 允许进入系统的密码。 如果客户端在盘上存贮个人数据，参数会被忽略。
  • Server — 交易服务器的连接。服务器的名称会作为相应信息的名称。服务器文件是存贮在配置菜单里的。 如果账户信息存贮在盘上参数会被忽略。
  • AutoConfiguration — "true" 或"false"取决于自动配置是否允许。如果参数未被指定，则会应用当前服务器设置的成交量。
  • DataServer — 数据中心地址。如果允许服务器自动配置，记录可以忽略。 如果参数未被指定，则会应用当前服务器设置的成交量。
  • EnableDDE — "true" 或"false" 取决于DDE是否允许。 如果参数未被指定，则会应用当前服务器设置的成交量。
  • EnableNews — "true" 或 "false" 取决于新闻是否开启。如果参数未被指定，则会应用当前服务器设置的成交量。

范例:

; common settings
Profile=test 3
MarketWatch=set2.set
Login=12345
Password=xxxxxx
Server=MetaQuotes-demo
AutoConfiguration=false
DataServer=192.168.0.1:443
EnableDDE=true
EnableNews=false

代理服务器设置

  • ProxyEnable — "true" 或 "false" 取决于必须应用代理服务器连接交易服务器。
  • ProxyServer — 代理服务器地址。
  • ProxyType — 代理服务器类型。可以是"HTTP"， "SOCKS4"后 "SOCKS5"。
  • ProxyLogin — 验明登陆。
  • ProxyPassword — 代理服务器的访问密码。

如果上述参数未被指定，应用客户端的当前设置 (在客户端设置 "服务器"代理服务器)。

范例:

; proxy settings
ProxyEnable=true
ProxyServer=proxy.company.com:3128
ProxyType=HTTP
ProxyLogin=user45
ProxyPassword=xxx

FTP设置

  • FTPEnable — 允许/禁止公开。 可接受价值为"true" 或"false"。
  • FTPPassiveMode — 允许/禁止以被动模式传输数据。 可接受价值为"true" 或"false"。
  • FTPAccount — 发送账户数字的状态到FTP。
  • FTPServer — FTP服务器地址。
  • FTPLogin — 验明 FTP 服务器登陆。
  • FTPPassword — FTP服务器访问密码。
  • FTPPath — 在FTP服务器上的目录名称安放报告位置。
  • FTPPeriod — FTP服务器发送周期。

如果上述参数未被指定，应用客户端的当前设置 (在服务器设置"公开页")。

范例:

; ftp settings
FTPEnable=true
FTPPassiveMode=false
FTPAccount=12345
FTPServer=ftp.company.com
FTPLogin=admin
FTPPassword=pAssWOrd123
FTPPath=/inetpub
FTPPeriod=10

EA 设置

  • ExpertsEnable — 允许/禁止交易。
  • ExpertsDllImport — 允许/禁止DLL导入。
  • ExpertsExpImport — 允许/禁止从外部交易或 MQL4资料库导入。
  • ExpertsTrades — 允许/禁止执行交易。

注意: 所有交易的参数组只有以 "true" 或 "false"为接受价值。

如果上述参数未被指定，应用客户端的当前设置 (在服务器设置 "智能交易" )。

范例:

; experts settings
ExpertsEnable=true
ExpertsDllImport=true
ExpertsExpImport=true
ExpertsTrades=true

交易或脚本的单独设置

  • Symbol — 终端启动后报价图表中的商品会立即开始运作。客户端关闭时，附加到图表的信息不会保存。 在没有配置文件的情况下终端重起时，图表不会打开。如果参数未被指定，没有附加图表可以打开。
  • Period — 图表时间范围 (M1, M5, M15, M30, H1, H4, D1, W1, MN). 如果没有指定参数，时间为一小时。
  • Template — 模板文件名称(目录 \templates )会使用在图表中。
  • Expert — 客户端开始后交易名称开启。交易会在图表中开启，开启的图表会按照指定的数据显现。 如果商品参数没有被设定，则没有附加图表打开，交易会在当前数据图表的第一个图表开启。 如果在当前数据图表没有图表，说明交易没有开启。如果参数没有指定，交易也不会开启。
  • ExpertParameters — 包含交易参数的文件名称(目录\MQL5\Presets)。可以在 交易属性窗口按"输入 - 保存" 键创建。 如果参数未被设定，将会应用默认值。
  • Script — 脚本名称。在客户端启动后脚本随即会开启。 脚本会按照交易的规则开启
  • ScriptParameters — 包含脚本参数的文件名称(目录\MQL5\Presets). 此文件与交易文件相似。

范例:

; open chart and run expert and/or script
Symbol=EURUSD
Period=H4
Template=popular.tpl
Expert=MACD Sample
ExpertParameters=macd.set
Script=period_converter
ScriptParameters==per_conv.set

策略测试设置的开启

  • TestExpert — 需要测试的交易名称。 如果参数未被设定，测试不会开启。
  • TestExpertParameters — 包含参数的文件名称(目录\tester ). 这个文件可以创建在测试参数设定窗口 按"输入 - 保存"键。 其他测试交易参数在 "测试" 表 最后的测试会自动填充在保存在 \tester\[the expert name].ini文件内
  • TestSymbol — 需要测试的商品名称。 如果参数没有设定，最后的价值会应用到测试中。
  • TestPeriod — 图表时段(M1, M5, M15, M30, H1, H4, D1, W1, MN)。 如果参数未被设定，一小时为默认值。
  • TestModel — 0, 1, 或 2, 取决于测试模板(每个标记，控制点， Open prices only)。 如果参数未被设定， 默认值为0。
  • TestRecalculate — 允许/禁止 "重新估算"。 可接受价值为"true" 或"false"。 If this parameter had not been specified, the "false" value is used。
  • TestOptimization — 允许/禁止利用。 可接受价值为"true" 或"false"。 如果参数未被设定，应用"false" 价值。
  • TestDateEnable — 允许/禁止"应用日期" 可接受价值为"true" 或"false"。 如果参数未被设定，应用"false" 价值。
  • TestFromDate — 以YYYY.MM.DD.形式显现开始测试日期。如果参数未被设定，则从1970.01.01开始。
  • TestToDate — 以YYYY.MM.DD.形式显现截至测试日期。 如果参数未被设定，则到1970.01.01截至。
  • TestReport — 测试报告文件名称。文件可以在客户端目录内创建。 回给出指定路径，例如： "tester\MovingAverageReport"。 如果扩充部分在文件名内没有指定，".htm" 会自动设置。 如果参数没有被设定，测试报告不会运作。
  • TestReplaceReport — 允许/禁止重复报告记录。可接受价值为"true" 或"false"。 如果"false"价值被指定，报告文件的名称同样存在。 例如， "MovingAverageReport[1].htm"。如果参数未被设定，应用"false" 价值。
  • TestShutdownTerminal — 允许/禁止测试结束后关闭终端。 可接受价值为"true" 或"false"。 如果参数未被设定，应用"false" 价值。如果用户按 "停止"键， 所有参数会存储在 "false" 中。

范例:

; start strategy tester
TestExpert=Moving Average
TestExpertParameters=ma0.set
TestSymbol=EURUSD
TestPeriod=H1
TestModel=2
TestSpread=0
TestOptimization=false
TestDateEnable=true
TestFromDate=1970.01.01
TestToDate=2006.06.06
TestReport=MovingAverageReport
TestReplaceReport=false
TestShutdownTerminal=true


?????????

开始使用 / 工具 / 历史数据中心

历史数据中心

技术分析-研究市场变化和预测未来价格走势。 通常研究市场通过图表完成。 因此可见不同时期历史价格数据的重要性。历史数据会以连续不断的形式储存到服务器上。 当建立连接，终端会下载一切所需的数据。随后, 运用这些数据画出图表 测试和图表利用。 这是存在于终端内的特殊窗口"历史数据中心" 来管理历史数据。 打开这个窗口需执行 "工具 — 历史中心"目录完成或按 F2。

在终端关闭后，所有历史数据会保存于"历史数据中心", 历史文件的大小不能超过 设定量。如果历史数据账户储存超过 设置 " 历史最大限量: "原有的信息组将会被新的数据替代。历史数据文件按照SSSSSSPP.hst (其中SSSSSS是品种的名字, and PP是时间周期）文件名格式保存在 /HISTORY文件。 这些文件在时能够有特殊的用途。 测试交易策略时能够有特殊的用途。

在"历史数据中心"窗口可以变动任何可用的数据。 这样做需选择窗口左部的品种和时段。信息数据将会被下载以图表形式呈现。 添加档案，需按同名文件，在新窗口内填写完整所需的信息，按"OK"。 随后，新的将会以历史的基础显现。 按 "编辑" 选项，能够修改所设定的信息数据。从历史中删除，需选中它按删除即可。

载入历史数据

可以从历史数据服务器载入1999年至今的基础货币组的报价。要做到这个，必须选择所需的交易品种并点击“下载”。

注意：加载的数据不同于交易商交易服务器上存储的历史数据。

按下按钮时，M1时间表的数据将会加载。其他时间表将从M1自动重新计算。并且，下载数据的时间将根据激活账户的时区自动重新计算。

当下载历史数据时，建议控制 历史和图表的柱数。

注意：历史使用层次越深，PC资源需要的就越多。

历史数据服务器上报价每周更新。另外，重启时，只有更新的报价才会下载。

历史数据输出/输入

历史数据可以以CSV, PRN, HTM 文件格式输出。这样做，需在"历史数据中心"窗口左部选中品种对象， 按"输出"按钮 。然后，选择任意一种可用形式发送储存到硬盘上。历史数据同样可以从终端内输入。同样以CSV, PRN, HTM,和HST格式输入。

文件中的历史数据按如下表示（任何其他的分隔符都可以用来代替空格）：

  • YYYY.MM.DD HH:MM O H L C V
  • YYYY-MM-DD HH:MM O H L C V
  • YYYY/MM/DD HH:MM O H L C V
  • DD.MM.YYYY HH:MM O H L C V
  • DD-MM-YYYY HH:MM O H L C V
  • DD/MM/YYYY HH:MM O H L C V

在"历史数据中心"窗口左部选中品种和时间段。 然后，按"输入"按钮，需设置输入参数:

  • 分离器 — 分离当前的输入文件。可以应用逗号，分号，空白和列表进行分离。
  • 忽略数列 — 当输入时忽略一个中心总量数列。如果输入数据拥有多种形式，忽略数列会友极大的益处。
  • 忽略横栏 — 当输入时忽略一个中心总量横栏(行)。
  • 移动小时 — 及时移动当前小时。
  • 只应用所选 — 只输入所选数据。所选数据行，按"Ctrl" 和"Shift" 键。
  • 输入量 — 开启/关闭输入量。

历史数据完整输入后，它们将会以图表形式画出 测试交易.


?? ?????

开始使用 / 工具 / 行情输出

行情输出

服务数据资源是终端用户分析的基础，是证券价位变化的工具。这些信息由中介公司供应。价格数据允许运用不同的交易战略和交易决策画出图表以便研究经济市场。 报价会以 "SYMBOL, BID, ASK, DATE"文件形式呈现 (开价 , 出价, 要价, 日期和时间)在连接建立后，收益会自动运行。

终端允许输出报价经"DDE"或其他程序即使处理 (Dynamic Data Exchange)数据交换传送规程。MS Windows 数据交换传送规程业务系统常常应用在数据转换。 通过DDE输出报价只有在ADVISE形式收益。请求REQUEST会显示N/A, 在新价位收益后，报价会显示。

通过DDE从终端内激活报价输出, 需选择选项 "执行DDE服务器"在 终端设置内执行。

注意: 历史数据不能通过DDE 数据交换传送规程。通用报价输出只有在在线的时候执行。

DDE请求形式和它的显示结果，范例 "DDE-sample.xls"文件:

BID 请求： = MT4|BID!USDCHF 结果： 1.5773
ASK 请求： = MT4|ASK!USDCHF 结果： 1.5778
HIGH 请求： = MT4|HIGH!USDCHF 结果： 1.5801
LOW 请求： = MT4|LOW!USDCHF 结果： 1.5741
TIME 请求： = MT4|TIME!USDCHF 结果： 21.05.02 9:52
QUOTE 请求： = MT4|QUOTE!USDCHF 结果： 21.05.02 9:52 1.5773 1.5778 1.5776

注意: MS Excel会显示数据, 需选择选项"工具— 选项... — 通道— 常规登陆" MS Excel的目录选项。


???????

开始使用 / 工具 / 总体变量

总体变量

一些交易在客户终端内启动时，同时启动。 有时，需要相互交换信息。在它们之间存在少量的信息交流，在终端交易过程中这些交易不发生任何冲突，这些就是终端内的总体变量。总体变量的存在不取决于交易。 在终端开启时总体变量被保存, 与一些其他变量不同(它们设置在保存在 交易启动 和消失在 交易完成后)。 总体变量能够在交易中放置四个星期，手动修改。

对于总体变量拥有特殊的管理窗口。打开它需选择 "工具— 总体变量"目录 完成或按F3. 全部的总体变量，它们的成交量和最后在列表中交易的时间会在窗口中显示。 在窗口右部运用开关，可以添加新的总体变量或删除现存的。 改变总体变量的名称和成交量，需双击鼠标左键将会显示。 最近显示时间会自动更改。


?? ??????

开始使用 / 工具 / 协议一览表

协议一览表

这个信息窗口可以查看协议说明。主要参数分为以下内容：

  • 展开 — 在Bid 和 Ask之间的不同价位点。
  • 数字 — 在呈现价位中十进位数的总量。
  • 停止水平 — 与当前价位的最小差距，被安放在 止损定单和赢利定单 中。
  • 脱离定单（GTC） — 强行打开平仓的挂单交易。"Yes" 表示挂单交易不会强行平仓。
  • 协议大小 — 在当前存款中的一价位份额。
  • Tick 价格 — 当前开价中的价格最小变化。
  • Tick 大小 — 用点改变最小商品价格。
  • 估算盈利模式 — 接受盈利估算技术(Forex, CFD, Futures)。
  • 交换类型 — 延续估算类型(点，当前存款或百分比)。
  • 多寸头交换 — 多寸头交换延期。
  • 空寸头交换 — 空寸头交换延期。
  • 估算差额模式 — 接受估算差额技术 (Forex, CFD, Futures)。
  • 回避差额 — 回避仓位的差额大小。

商品说明窗口可以在 市场报价窗口"属性" 或 "测试 — 设置" 窗口中"商品属性"查看。


???????

开始使用 / 工具 / 语言帮助

语言帮助

客户终端界面是使用多种语言的。 能够呈现多种语言。 这个特性使得操作繁琐，但同时也降低了交易中发生错误的总量。 查找可以应用的语言列表可以选择 "查看— 语言" 目录. 选择列表中的任意语言开启终端。 当终端重新开启后语言会发生改变。


文章

开始使用 / 文章

文章

在本节中，您可以找到有关客户端工作的链接和简短的描述文章。

  • 常规
  • 测试器


文章 —通用

开始使用 / 文章 / 常规

常规

外汇交易ABC

外汇交易ABC

金融市场工作代表，首先，就是交易操作。我们所有人，从孩童时代开始，就有一种直观的想法，就是购买和卖出什么。但是外汇交易仍然是某种特殊的东西。本文处理了必要的想法来解释一些术语。我们将也会考虑到与那些术语相一致的MQL4的功能。

MetaTrader 4 客户端的秘密

MetaTrader 4 客户端的秘密

21种缓解生命周期的方式：MetaTrader 4客户端的潜在特性。全屏；热键；快速导航条；窗口最小化；收藏夹；流量减少；新闻禁用；交易品种设置；市场报价；测试模板和独立图表；个人资料；十字光标；电子尺；横向图表分页；图表中的账户历史记录；挂单类型；修改止损和获利；撤销删除；图表打印。

MetaTrader 4 客户端的秘密：警告系统

MetaTrader 4 客户端的秘密：警告系统

如何在没有保持关注显示器时意识到程序端和账户中发生了什么事。系统事件；自定义事件；波动和可执行文件；电子信息；设置SMTP服务器访问；发布；设置FTP服务器访问。

MetaTrader 4 客户端的秘密：指标

MetaTrader 4 客户端的秘密：指标

您要编写您自己的指标吗？也许在客户端已嵌有的指标中您能找到您所需的那一个。所以为什么要白费力气做重复工作呢？综合指标特点的汇总表；特殊特性和指标附加到图表的方法；建立水平；展示不同时间表的指标。

MetaTrader 4 客户端的秘密：MetaEditor的文件库

MetaTrader 4 客户端的秘密：MetaEditor的文件库

当创建自定义程序时，代码编辑是最重要的。越多功能提供在editor，程序创建的越快越方便。许多程序是基于现有的代码创建。您在使用不完全适合您初衷的指标或脚本吗？从我们网站下载该程序代码并亲自进行定制。


文章 — 测试器

开始使用 / 文章 / 测试器

测试器

策略测试器：测试期间的建模方式

策略测试器：测试期间的建模方式

许多技术分析的程序都允许在历史数据上测试交易策略。在大部分情况下，测试在现已完成的数据上实施，而不会试图在价格柱内模拟趋势。它很快，但不精确。

MetaTrader 4的测试特定和限制

MetaTrader 4的测试特定和限制

该文章允许找到MetaTrader 4策略测试器的更多特点和限制。

EA测试报告中的数字意味着什么

EA测试报告中的数字意味着什么

文章解释了如何阅读测试报告和恰当地解释所得的结果。

MetaTrader 4客户端的EA测试：外部一瞥

MetaTrader 4客户端的EA测试：外部一瞥

您点击“开始”按钮后会怎样？该文章回答了这个以及许多其他问题。

程序端MetaTrader 4中的测试器：应该知晓

程序端MetaTrader 4中的测试器：应该知晓

精心设计的MetaTrader 4程序端界面是前脸，但除此之外该程序端还包括 策划巧妙的策略测试器。而MetaTrader 4作为交易程序端的价值显而易见，测试器的策略测试质量只能在实践中评估。 该文章显示了MetaTrader 4测试的优势和便利性。


信号

开始使用 / 信号

信号

信号服务允许任意人成为供应商，出售交易信号或订阅它们，和遵循一个有经验的交易人的策略。

用户应该有一个活动的MQL5.community 帐户来使用信号服务。如果您还没有帐号，请 注册。账户应该在 程序端设置中指定。

Discover in 15 Minutes: Video on Trading Signals

Watch the below tutorial videos to learn about trading signals. Click on the video image to watch it.

Watch video: Trading signals showcase Watch video: Detailed statistics of a trading signal Watch video: Trade statistics, growth, equity & balance graphs Watch video: Risks, distribution, news and reviews of trading signals

Watch video: Visualize a signal on a chart Watch video: Subscribe to a trading signal Watch video: The report on the copied trades

信号供应商

如果您是一个成功的交易人，并愿意利用您的经验和技能赚钱，您可以作为信号服务的供应商，通过MQL5.community网站注册。

完成简单的注册流程后，您将会可以连接您的交易账户和监控系统，在这里会显示账户的全部基本参数。

您的账户将会被纳入到MQL5.community和直接在交易程序端的有效交易信号列表中。交易人将能够轻松认购您的交易信号。

如果您提供的交易信号是收费的，来自交易人的付款将会转到您MQL5.community内部支付账户。

了解如何成为一个信号供应商。

信号订阅人

成为订阅人的整个流程非常简单。在MQL5.community网站或客户端选择您感兴趣的信号。您仅需做出几次点击，来订阅他或她的信号。

信号订阅后，您的交易账户将与供应商的账户同步。之后，您账户上的全部交易操作都将会自动执行。

信号服务的工作具有巨大的优势：

  • 供应商和投资人之间无需拟定协议。
  • 交易操作的复制完全自动完成。不需要您的干预。
  • 信号供应商和订阅人可在不同的经纪公司拥有账户。
  • 超快的数据交换协议大大缩短了在订阅人账户上执行订单的延迟。
  • 数据传输是绝对安全的。
  • 固定认购价格，没有额外的认购手续费。

了解如何订阅信号。


信号供应商

开始使用 / 信号 / 信号供应商

信号供应商

信号供应商就是在他或她的交易操作上授予数据 访问权限的交易人，允许其他交易人在其自己的交易账户上复制这些操作。信号既可以免费提供，也可以基于商业基础的提供。

若要成为信号供应商，用户应该拥有一个活动的MQL5.community账户。如果您还没有帐号，请 注册。

请务必阅读 规则，在使用信号服务之前。

信号供应商的重要信息：

  • 如何注册为一个信号供应商
  • 如何添加一个信号
  • 如何管理你的信号

作为卖家注册

为了能够注册您的交易帐户成为一个有偿信号供应商，您应该注册为一个卖家。

卖方的状态只需要提供有偿信号。如果你要免费提供信号，你可以跳过这一步。

移动到您个人资料的“卖家”部分在MQL5.community 网站。

点击“注册”。注册表格将会出现：

尽可能准确的在表格中写明您的个人数据：

  • 名 — 您真正的名。
  • 姓 — 您真实的姓氏。
  • 公司 —如果您想要注册为一家公司（法人），启用“注册为公司”选项和指定公司名。如果你作为一个公司注册，所有进一步的数据应该属于指定的公司。
  • 国家 — 居住国。
  • 地址 — 完整的地址，包括街道名称，房子或公寓号。
  • 市/镇 — 居住的城市/镇。
  • 州 — 州名。
  • 邮政编码
  • 电话 — 电话号。
  • 手机 — 手机号，以便于我们联系您。
  • 扫描 — 如果您作为个人注册，您需要上传您个人身份证明文件的扫描件（例如，护照或驾照）。如果您作为法人实体注册，您应该上传您公司注册证书的扫描件。

填好全部数据后，检查使用 信号的规则 和 市场服务。如果您同意规则，打勾的选项“我同意市场和信号服务规则”。如果您不同意规则，不注册为信号供应商。

点击“注册”，完成注册过程。在那之后，您的申请将被发送到该网站的管理。决定将会在几个工作日内做出。

您可以在MQL5.community个人资料的“卖方”标签上，跟踪您的注册状态。

此页面上，你就会知道结果（批准或拒绝）。您将通过个人信息得到通知。

如果您有任何疑问，在“评论”标签上给管理写条信息。

添加一个信号

您已经注册为信号供应商以后，MQL5.community上的信号，您将看到“添加信号”按钮替换了“信号”标签上的“注册”。

点击后，您会移动到账户注册表，这里您应该指定用于发送交易信号的账户。

要快速创建信号，在程序端的 "导航" 中选择所需的账户，然后在其快捷菜单中执行"注册为信号"的命令。 然后您将转到MQL5.community的信号注册页面。选定的账户和正确的交易商服务器将会在注册表中自动确定。

输入以下数据添加信号：

  • 启用 — 只要这个选项没有被打勾，您的信号不会提供给其他用户。
  • 名称 — 交易信号名称。
  • 程序端 — 在这个字段应该选择第四个版本的交易程序端 。
  • 登录 — 账户号码，交易信号将从这里发送。
  • 密码 — 这里指定您的只读密码。此密码在只读模式下提供访问该帐户，但不可以进行交易操作。未指定主密码和供应商帐户仍然完全安全。
  • 交易商 — 交易商服务器名称。当你开始输入第一个字符，可能名称的列表将显示给你。
  • 认购价 — 启用“免费”选项，如果您想免费提供您的信号。
  • 每月价格 — 如果你提供有偿的基础上的信号，指定每月的认购价。用户可以订阅一个月或一个星期信号。在第二种情况下，订阅成本的设置等于一个月的四分之一。
    认购价可以之后指定。在这种情况下，将从新的认购期开始收取付款（下周或下个月）。
  • 通知 — 通过您的手机，您可以接收MQL5.community网站上各种变化的通知（新个人信息，卖方个人资料中与版主的通信或文章部分等等）。到达您手机号码的通知可以换成更多的日期和可靠的 推送通知。指定您唯一的MetaQuotes ID（可以在移动交易端中找到 iPhone 和 Android）和接收即时和免费通知有关所有重要的MQL5.community事件。

指定全部参数后点击“添加”。

  • 指定账户类型，例如演示或竞赛或真实，自动定义。新创建的信号将被录取到相应的类别。
  • 超过1:500杠杆的帐户将无法使用 订阅。此限制实施，以保护订阅人，防止带有太冒险交易过程的账户产生的信号。
  • 供应商不需要在客户端与供应信号使用的账户永远保持连接。使用注册期提供的只读密码，交易操作可以被信号服务器读取，然后提供给订阅人。

管理信号

移动到“我的信号”部分来管理您的信号。

在这里显示您信号的基本信息：

  • 名称 — 信号名称。>
  • 类别 —信号类别（演示，竞赛或真实）。
  • 增长/净值 — 当前利润和净值水平。
  • 发布 —信号发布日期（通过测试周期，成为可供订阅信号的时候）。.
  • 等级 — 其他用户定义的信号等级。
  • 订阅人 — 当前订阅信号的用户数量。>
  • >连接< — 信号连接状态。
  • 价格 — 每月的认购费。

点击信号来编辑它。

移动到信号监控和点击右上角的“编辑”。填写表格这时 添加 信号将会显示。只有以下参数可以改变：

  • 启用/禁用信号
  • 信号名称
  • 账户密码
  • 认购价。


信号订阅人

开始使用 / 信号 / 信号订阅人

信号订阅人

信号订阅人就是一个交易人，他订阅供应商交易信号，以在他或她自己的交易账户上复制之后的交易操作。每周或每月收取订阅费。

要成为一个信号订阅人，用户应该有一个活动的MQL5.community账户。如果您还没有帐号，请 注册。

您的活动账户应该被指定在客户端设置的"Community" 标签。

  • 请务必阅读 规则，在使用信号服务之前。
  • 要复制信号，交易程序端必须始终连接到服务器，使用认购信号的帐户。只有当程序端被连接到服务器时，程序端接收有关供应商账户上执行的交易的信号，并自动复制交易到订阅人帐户。

信号订阅人的重要信息：

  • 如何选择一个信号和订阅它
  • 如何配置客户端来使用信号
  • 如何才能使供应商和订阅人的账户同步
  • 如何延长订阅
  • 如何取消订阅

选择信号及认购

您可以通过MQL5.community网站和客户端选择一个信号并订阅它。

Watch video: Trading signals showcase

Watch video: Trading signals showcase

How to choose a trading signals and subscribe to it for a couple of clicks? Its easy! Watch the video and you will know everything about trading signals.

MQL5.community上的信号

所有可供订阅信号可以找到在MQL5.community网站的“信号”部分。

选择页面左侧的可用信号类别：

  • 演示 — 来自模拟账户的信号。请注意模拟账户允许交易人承担真实账户可能不会接受的风险。
  • 真实 — 来自真实账户的信号。

请注意，模拟账户允许交易人承受真实账户可能不可接受的风险。

点击信号名称，打开您感兴趣的信号。帐户监控 页面会出现。

该页面显示了完整的帐户交易统计，包括交易操作历史记录和交易持仓的当前状态。

如果您满意信号（包括价格），你就可以订阅它。点击左上角的“订阅”。认购设置窗口将出现：

下面认购参数显示在这里：

  • 信号 — 信号名称。
  • 长度 — 订阅周期：一个月或一周。如果选择按周订阅，订阅费将是指定的月认购费的1/4。
  • 价格 — 认购费。
  • 开始日期 — 订阅开始日期。您现在就可以订阅，从第二天或下一周开始。
  • 周期 — 根据选定的开始日期，实际订阅周期将显示在这里。
  • 程序端 — 交易程序端版本。
  • 交易商 — 您交易商的服务器名称。当你开始输入第一个字符，可能名称的列表将显示给你。
  • 登录 — 您的交易账户号码，在这里复制供应商的信号。

如果您同意认购交易信号的规则，勾选下面的选项。

要复制交易操作到一个帐户，您需要在客户端使用该帐户始终连接（授权）。

不匹配的交易条件

订阅信号前，系统会检查订阅人和供应商账户上的一些交易条件：

  • 交易品种允许的最低和最高交易量 — 如果这些设置不匹配，供应商交易操作的交易量和复制到订阅人账户操作的交易量可能会严重不同。
  • 订阅人账户上供应商使用的交易品种的可用性— 如果供应商使用的交易品种至少有一个不可用，那么复制信号就不可能。

如果检测出了不匹配，那么订阅窗口中就会显示相应的警告。推荐使用匹配交易条件的信号。

  • 没有交易将会复制到您的账户，直到您激活您交易程序端中的“启用实时信号订阅”选项。
  • 你不能认购使用超过1:500杠杆的帐户创建的一个信号。此限制实施，以保护订阅人，防止带有太冒险交易过程的账户产生的信号。
  • 推荐使用 匹配交易条件的信号。否则，您可能会由于无法复制交易信号而浪费您的钱。

点击“订阅”来添加订阅到您的程序端。

在客户端的交易信号

您可以选择一个 信号，并通过客户端直接订阅它。打开“工具箱”窗口的“信号”标签。

Watch video: Detailed statistics of a trading signal

Watch video: Detailed statistics of a trading signal

For your convenience, the most valuable parameters of trading signals are placed in a separate block. From this video you will find out where to find them and what to pay attention to.

信号类型，由用来创建信号的账户类型决定，通过图标显示：

  • 演示信号 — 模拟账户基础上创建的信号。
  • 真实信号 — 真实帐户基础上创建的信号。

双击信号，查看关于它的详细信息。

Watch video: Subscribe to a trading signal

Watch video: Subscribe to a trading signal

How to subscribe to a signal and what parameters to set up: should you copy the stop levels, what part of your deposit will take part in copying and what slippage to choose?

如果您满意信号（包括价格），你就可以订阅它。点击“ 订阅 订阅”在工具栏的顶部。订阅确认窗口将出现：

基本信号数据显示在这里

  • 信号 — 信号的名字。当点击一个名字，你将移动到MQL5.community上信号的描述。
  • 供应商 — 信号供应商的名字。当点击它时，您将移动到供应商的MQL5.community个人资料。
  • 交易商 — 供应商所使用的交易商服务器的名称。
  • 增长 — 信号注册那一刻起，供应商账户的入金增长。以初始值百分比指定的值。
  • 价格 — 积分计算每月的订阅价格。

通过勾选相应的选项，你也应该同意使用信号服务的条款。

要复制交易操作到一个帐户，您需要在客户端使用该帐户始终连接（授权）。

不匹配的交易条件

订阅信号前，系统会检查订阅人和供应商账户上的一些交易条件：

  • 交易品种允许的最低和最高交易量 — 如果这些设置不匹配，供应商交易操作的交易量和复制到订阅人账户操作的交易量可能会严重不同。
  • 订阅人账户上供应商使用的交易品种的可用性— 如果供应商使用的交易品种至少有一个不可用，那么复制信号就不可能。

如果检测出了不匹配，那么订阅窗口中就会显示相应的警告。推荐使用匹配交易条件的信号。

  • 没有交易将会复制到您的账户，直到您激活您交易程序端中的“启用实时信号订阅”选项。
  • 推荐使用 匹配交易条件的信号。否则，您可能会由于无法复制交易信号而浪费您的钱。

订阅后，移动到客户端设置。

客户端设置

要在客户端配置的信号，打开设置窗口，并移动到“信号” 标签。

配置下列参数：

  • 同意使用信号服务的条款 — 同意开始使用服务的条款。请仔细阅读规则。如果您同意，请勾选选项旁边的方框。如果您不同意规则，请不要使用信号服务。
  • 启用实时信号订阅 — 只在该选项启用后，交易操作才将被复制到您的账户。 如果禁用此选项，没有操作可以复制到账户。只有启用该选项，下面设置才可以编辑。
  • 复制止损和获利水平 — 置于供应商账户的止损 和获利 也将置于您的交易账户上，如果启用该选项。这些订单以交易商身份实施。它意味着无论客户端是否启动，它们都可以实施。此外，实施可以在完全不同的经纪公司进行（如果订阅人和供应商有不同的交易商）。
    因此，这会保证当复制止损订单时进行平仓，如果到达指定损益水平的情况下。
  • 无确认的同步持仓 — 没有确认请求的自动同步。当订阅信号时，订阅人和供应商的账户的交易状态是周期性 同步 的。这可以成为一个激活订阅时的初始同步或检测到订阅人和供应商账户之间有差异时的定期同步。
    如果同步过程中在订阅人帐户检测到挂单或无信号持仓(手动或通过EA交易打开)，会显示提供平仓和删除订单的对话框。如果同步过程中在供应商账户检测到获利持仓，而订阅人账户却没有（例如，由于网络连接丢失或程序端关闭），那么请求确认复制此持仓的对话框会展示给用户。在这两种情况下，不会执行同步化并且会停止信号复制直到用户点击相应的对话框按钮作出决定。
    如果程序端没有持续的外部控制而昼夜不停地工作（例如，在VPS启动程序端），执行同步的手动确认请求则无应答并且因此可以防止信号被复制。当启用该选项时，同步总是自动执行而不需要订阅人的确认。< / t7 >
  • 使用不超过[A] % — 您入金的百分比值，可以用于下面供应商的信号。例如，如果您的结余是10 000 USD，这里指定90%，那么9 000 USD将用于下面的信号。当遵循信号时，这会影响进行交易的交易量的计算。交易量按比例计算。见“信号订阅人” 部分获取更多信息。
  • 如果净值少于[B]停止 — 该参数允许您限制损失，当使用交易信号时。如果净值低于指定水平，将会自动终止交易信号的复制，全部平仓和移除所有挂单。0 表示没有限制。
  • 偏差/滑移[C]点差 — 此设置类似于偏差设置当从程序端下单 时。这是当复制交易操作时，来自客户端请求初始价的已实施订单价的允许偏差值。该值的显示，作为交易操作中使用的交易品种的当前点差的一部分。
    如果偏差小于或等于指定参数，则该订单被执行。如果偏差超过规定值时，那么程序端将增加0.5点差可接受的偏差，并再次尝试执行交易操作。如果再次收到重新报价，那么订阅人和供应商的账户将变得不同步。之后，程序端将会尝试再次同步。

在所有的参数已经设置并且允许订阅之后，您的交易账户会开始与供应商账户同步。

与供应商帐户同步

同步订阅人和供应商账户是必须的，以将他们的交易操作带到统一的初始状态。激活订阅以及信号复制期间定期性执行同步。

执行同步需要满足许多要求：

  • 订阅人不应持仓和激活挂单。
  • 所有供应商持仓的总浮动利润应是负值。这允许订阅人以不逊于供应商的价格进入市场。

直到两个要求都得到满足，才能完成同步和复制交易操作。

当订阅信号时，不能执行任何交易操作，无论是手动还是通过MQL5应用程序。这将会导致订阅人和供应商的账户无法同步。因此，如果发现持仓或挂单不同的话，系统将会尝试同步订阅人和供应商的账户。

如果订阅人持仓或挂单，尝试订阅信号的情况下会出现下面的窗口：

仔细阅读对话框窗口中描述的建议。如果您想要通过市场价格自动关闭全部持仓和删除挂单，勾选“我意识到了风险，我同意立即同步持仓和订单”。然后点击“现在平仓和同步”按钮。

如果你不想该程序平仓和删除挂单，点击“我将手动检查”或关闭该窗口。

如果供应商所有持仓的总浮动（不固定）利润为正值，您将会看到以下窗口：

仔细阅读对话框窗口中描述的建议。如果即使正值浮动利润，您也想要同步您和供应商的账户，勾选“我意识到了风险，我同意立即同步交易持仓”。

如果您想推迟同步和等待供应商的浮盈变为负数，点击“等待更好的市场条件”。直到供应商的浮动利润变成负值，程序端才会同步账户，才会开始复制交易操作。

复制交易操作，计算交易量

订阅人和供应商账户成功同步以后，开始复制交易操作。这是自动完成。

供应商账户上的挂单 不会复制到订阅人账户。触发挂单时交易操作被复制：当触发限价买入或买入止损订单时，买入信号被复制；当触发限价卖出或卖出止损订单时，卖出信号被复制。

订阅人账户开始复制供应商交易操作后，不建议手动交易操作（以及使用EA交易）。否则，订阅人和供应商的账户将无法同步。如果发现持仓或挂单不同的话，系统将会尝试同步订阅人和供应商的账户。

订阅人账户上执行的交易操作的交易量是以订阅人和供应商可用资金为基础的。该计算是在几个阶段进行。

交易量乘以，考虑入金货币和 程序端设置中指定的允许入金负载的订阅人和供应商的结余比例。

假设订阅人结余8 000 欧元，允许负载是 - 50%，而供应商的结余是10 000 美元。目前欧元兑美元的汇率是1.20000。如果供应商执行一手交易量的交易，同样的交易在订阅人账户就是0.48手交易量。考虑到允许负载，订阅人结余包括 4 000 欧元或4 800美元。因此，交易量比率为4 800 / 10 000 = 0.48。

考虑结余后，订阅人和供应商的杠杆也在考虑范围内。如果认购的杠杆超过信号供应商的一个杠杆，它不会影响复制交易的交易量。否则，交易量会根据信号供应商杠杆和订阅人杠杆相关的直接比例而变化。

例如，如果1:100杠杆的信号供应商持有1手交易，那么在100%复制和入金大小和货币完全匹配的情况下，1:500杠杆的订阅人将打开1手交易。在相似条件下，1:10杠杆的订阅人将打开0.1手交易。

交易量计算显示在程序端的 “日志” 标签。示例条目如下图：

根据结余和杠杆比例选定的百分比 为 交易量转换 ， 新 值24%
信号 信号供应商有10 000.00美元的结余，杠杆1:200；订阅人有8 000.00美元结余，杠杆1:100
信号 资金管理：使用50%入金，净值限制：0.00欧元，偏差/滑移：0.5 点差

Balance Operations on Subscriber's Account During Copying

The total amount of subscriber's funds is changed after a balance/credit operation is performed. If the percentage value of signals copying has decreased by more 1% afterwards (the volume of copied trades is calculated considering the ratio of the subscriber's and provider's balance), the subscriber's account is forcedly synchronized with the provider's one. This is done to correct the subscriber's current positions according to the new copying percentage value.

If the subscriber's funds have increased due to the balance or credit operation, no forced synchronization is performed.

重新报价

程序端在复制供应商交易操作时，可以获取重新报价（服务器返回新价格，作为指定价格的交易请求反馈）。

如果新价格的偏差超出设置中指定的 “偏差/滑移[C] 点差” 值，那么程序端将会增加0.5点差可接受的偏差，并再次尝试执行交易操作。如果再次收到重新报价，那么订阅人和供应商的账户将变得不同步。之后，程序端将会再次尝试同步它们。

Watch video: The report on the copied trades

Watch video: The report on the copied trades

Detailed information on complete and active subscriptions will help you to estimate the effectiveness of every single provider. These reports will show you the profit gained from money spent for subscription.

延长订阅

如果订阅期限临近，而您想要继续使用它，您应该延长它的使用。这可以在MQL5.community或直接在客户端来完成。

MQL5.community

连接您的MQL5.community账户的订阅列表提供在“我的订阅”部分在“信号”部分：

要延长订阅，请点击按钮 延长认购 ：

然后，您将会进入下面的页面：

检查是否所有信息都正确。如果您同意认购条款，包括其价格，点击“续订”。

客户端

要管理客户端的认购，点击按钮 " 我的订阅 我的订阅"在"信号"标签的快捷菜单。当前订阅周期显示在信号名称的下面：

要延长订阅，请点击按钮" 续订 续订"。然后，会出现下面的窗口：

检查是否所有信息都正确。如果您同意订阅条款，请勾选"我同意信号服务使用条款" 并点击 "OK"。

使用客户端您可以从当前订阅结束延长一个月的订阅。如果您想要延长一周订阅，如上所述使用MQL5.community 网站的界面。

退订

如果您不想根据订阅复制信号，它可以取消。

订阅取消后，锁定在您的MQL5.community 账户的付款额 将会无法挽回的转到信号供应商。如果您遇到接收信号的问题，不用取消订阅而是要申请 服务台通过您的MQL5.community 个人资料。

订阅可以在MQL5.community 或客户端取消。

MQL5.community

连接您的MQL5.community账户的订阅列表提供在“我的订阅”部分在“信号”部分：

要取消信号订阅，点击按钮 退订 ：

如果您想暂时停止复制交易，不要退订信号。而是，暂停订阅通过点击 暂停 信号。将来，您将能够在位于订阅列表上方的“暂停”标签重新开始订阅。

一旦您点击 退订 ，您将会转到您需要确认取消订阅的页面：

检查所有的信息并仔细阅读从账户收取订阅费的警告。

订阅取消后，锁定在您的MQL5.community 账户的付款额 将会无法挽回的转到信号供应商。如果您遇到接收信号的问题，不用取消订阅而是要申请 服务台通过您的MQL5.community 个人资料。

如果您真的想要退订，勾选"我同意退订信号并付款给信号供应商"，然后点击"退订"。

客户端

要管理客户端的认购，点击按钮 " 我的订阅 我的订阅"在"信号"标签的快捷菜单。当前订阅周期显示在信号名称的下面：

如果您想暂时停止复制交易，不要退订信号。而是，通过禁用客户端设置中的“启用实时信号订阅”的选项来暂停订阅。将来，您将能够通过启用该选项重新开始订阅。

要退订信号，点击按钮" 退订 退订"。然后，您需要确认取消订阅的窗口将会打开：

检查所有的信息并仔细阅读从账户收取订阅费的警告。

订阅取消后，锁定在您的MQL5.community 账户的付款额 将会无法挽回的转到信号供应商。如果您遇到接收信号的问题，不用取消订阅而是要申请服务台通过您的MQL5.community 个人资料。

如果您真的想要退订，勾选"我同意退订信号并付款给信号供应商"，然后点击"OK"。


账户监控

开始使用 / 信号 / 账户监控

账户监控

交易账户监控系统是“信号”服务的一部分。在任何可用信号上都可以接到一份详细的报告。

交易账户可以通过MQL5.community网站和直接通过客户端进行监控。移动到“信号”部分在网站上，选择任何信号，以查看其参数：

Watch video: Visualize a signal on a chart

Watch video: Visualize a signal on a chart

The effectiveness of the entry points and the unrealized profit can be easily assessed with the visualized chart of provider's deals.

如果您想通过客户端找到信号数据，在 程序端 窗口的信号标签上打开它。

交易账户上的数据被划分成若干块。

基本数据

基本数据位于页面的左侧。

  • 增长 — 仅基于交易操作，以百分比计算的入金的增长，没有考虑账户的入金和出金。
  • 初始入金 — 开立账户时存入账户的金额。
  • 利润 — 账户使用期间得到的利润/损失。
  • 入金 — 账户使用期间，账户上的入金金额。评估信号盈利能力时，要始终考虑这个参数。定期入金支持结余曲线。
  • 出金 — 账户使用期间，账户上的出金金额。
  • 结余 — 账户上的资金，不计算当前持仓的浮动利润。
  • 净值 — 入金资金，计算当前持仓结果（浮动利润/损失）。
  • 当前跌幅 — 该框以资金和百分比形式显示当前跌幅（净值和结余的差异）。
  • Abs. 跌幅 — 结余低于初始入金值。
  • 最大 — 相对于本地最大入金货币的最大结余降低。
  • 相对 — 相对于百分比计算本地最大值的最大结余降低。
  • 交易商 —账户注册所在的交易商服务器的名称。
  • 杠杆 — 杠杆值。
  • 类型 — 交易类型：模拟交易，竞赛交易（例如，参加自动交易大赛的账户）或者真实交易。请注意模拟账户允许交易人承担真实账户可能不会接受的风险。。
  • 开始 — 信号注册日期（预测试开始日期）。
  • 更新 — 账户交易状态的最近更新日期和时间。
  • 上次交易 — 自信号供应商上次交易操作过去的时间。
  • 每周交易 — 每周交易的平均数。
  • 作者 — 作者（MQL5.community账户）名字。
  • 订阅人 — 此刻订阅人的数量。

Watch video: Trade statistics, growth, equity & balance graphs

Watch video: Trade statistics, growth, equity & balance graphs

Trade statistics is a detailed information on a signal, that will help you to make a wise decision. Growth, equity & balance graphs allow you to visually estimate a successful provider.

图形

在监控系统中可以得到以下图形：

结余增长

图形中的垂直线表示交易账户连接监控系统的时刻。

图形下面，您可以看到包含月度和年度回报的表格。要在图表上查看指定月份的增长，点击相应的返回值。

结余图形

图形中的垂直线表示交易账户连接监控系统的时刻。

净值图形

图形中的垂直线表示交易账户连接监控系统的时刻。

该图提供在 MQL5.community仅仅。

Watch video: Risks, distribution, news and reviews of trading signals

Watch video: Risks, distribution, news and reviews of trading signals

How risky your provider trades and what other subscriber think of that? Watch this video and we will answer your questions.

风险

这部分显示了MFE 和MAE的分布点图。

每个持仓订单的整个使用期会记录最大盈利(MFE) 和最大亏损 (MAE) 值。另外这些参数用最大未实现潜力和最大许可风险的值描述了每个关闭订单。MFE /获利和MAE/获利分布图，每个订单显示为一个点，沿着X轴绘制收到的获利/亏损值，而显示潜在获利(MFE)和潜在亏损(MAE)的最大值，沿着y轴绘制。

如果您把光标置于图上的持仓点，相同的持仓点将会在另一个图上突出显示。因此您可以分析每个持仓的潜在利润和亏损。

图形下显示以下统计率：

  • 最佳交易 — 在所有获利交易中拥有最高利润的交易。
  • 最差交易 — 在所有亏损交易中拥有最大亏损的交易。
  • 最大连胜 — 在最长获利连续及其总利润中的交易数。
  • 最大连败 — 在最长亏损连续及其总亏损中的交易数。
  • 最大连续利润 — 在持续获利连续和相应获利交易额中的最大获利。
  • 最大连续亏损 — 在持续亏损连续和相应亏损交易额中的最大亏损。

如果您将光标放在一个等级上，相应的交易将会在图上突出显示。

  • 该标签提供在 MQL5.community仅仅。
  • 您可以在文章中找到更多有关MAE和MFE分布的信息，文章交易数学：如何评估交易结果。

分布

在“分布”标签上您可以找到根据交易品种和交易类型（买入和卖出）显示的交易操作数量：

评论

在“评论”标签，MQL5.community成员可以表达他们对信号的看法。

该标签提供在 MQL5.community仅仅。

交易统计数据

以下图表可以看到详细的账户交易统计数据。

  • 交易 — 交易总数（用来固定利润或损失的交易）。
  • 交易利润 — 获利交易数及其在交易总量中的百分比份额。
  • 亏损交易 — 损失交易数及其在交易总量中的百分比份额。
  • 买入交易 — 买入交易的固定利润交易数和买入交易获利额的百分比。
  • 卖出交易 — 卖出交易的固定利润交易数和卖出交易获利额的百分比。
  • 最佳交易 — 在所有获利交易中拥有最高利润的交易。
  • 最差交易 — 在所有亏损交易中拥有最大亏损的交易。
  • 利润因子 — 毛利和毛损间的百分率。1，意味着利润与亏损相等。
  • 毛利 — 以货币计算的交易利润总和。
  • 毛损 — 以货币计算的交易亏损总和。
  • 平均利润 — 所有获利交易的平均利润。
  • 平均亏损 — 所有亏损交易的平均亏损。
  • 采收率— 该参数显示了策略风险 水平（把风险所获得的利润来赚取资金）。计算为所获利润和最大跌幅比率。
  • 夏普比率 — 该参数显示了策略的有效性和稳定性。它显示了持仓时间的算术平均数利润和标准偏差的比率。这里也被认为是无风险利率，这是从相应的银行入金资金获得的利润。
  • 预期收益 这是显示一次交易的平均利润/损失的统计计算值。此外，它被认为是显示下一次交易的预期利润/无盈利。
  • 最大连胜 — 在最长获利连续及其总利润中的交易数。
  • 最大连败 — 在最长亏损连续及其总亏损中的交易数。
  • 最大连续利润 — 在持续获利连续和相应获利交易额中的最大获利。
  • 最大连续亏损 — 在持续亏损连续和相应亏损交易额中的最大亏损。
  • 年度预测 — 根据监控周期结果，预测一年的入金增长。
  • 月度增长 — 百分比值计算最近一个月的入金增长。
  • 周增长 — 百分比值计算最近一周的入金增长。

交易操作

监控页面的底部，显示账户交易操作的全部详细信息。

持仓

当前持仓显示在带有以下字段的表格中：

  • 订单 — 订单的报价号（此号唯一）。
  • 时间 — 持仓时间。此记录表示为 YYYY.MM.DD HH:MM (年.月.日 小时:分钟)。
  • 类型 — 持仓类型：“买入” — 长，“卖出”— 短。
  • 交易量 — 交易操作量（手数）。最小交易量及它变化阶段受到经纪公司的限制，最大交易量 - 受入金大小限制。
  • 交易品种 — 持仓的金融工具。
  • 价格 — 持仓的价格。。
  • S/L — 当前持仓的 止损水平。如果该订单没有下单，那么零值会显示在字段中。
  • T/P — 当前持仓 盈利水平。如果该订单没有下单，那么零值会显示在字段中。
  • 价格 — 金融交易品种的当前价格。卖价显示为卖出持仓，而买价用于买入持仓。。
  • 手续费 — 交易商为交易操作收取手续费。
  • 库存费 — 收取的库存费金额。
  • 利润 — 当前价位写入该字段的交易账户的金融结果。正数表示交易赢利，负数表示亏损。

下挂单显示如下：

  • 订单 — 挂单的报价号（此号唯一）。
  • 时间 — 下挂单的时间。此记录表示为 YYYY.MM.DD HH:MM (年.月.日 小时:分钟)；
  • 类型 — 挂单类型：“卖出止损”，“卖出限价”，“买入止损”，“买入限价”。
  • 交易量 — 挂单需要的交易量（手数）。
  • 交易品种 — 挂单的金融工具。
  • 价格 — 挂单激活的价格。
  • S/L —下止损订单的水平。如果该订单没有下单，那么零值会显示在字段中。
  • T/P — 设置 盈利 订单的水平。如果该订单没有下单，那么零值会显示在字段中。
  • 价格 — 金融交易品种的当前价格。卖价显示为卖出订单，而买价用于买入订单。最新执行的交易价（收盘价）显示为包含交易所交易品种的订单（两个方向）。

历史记录

该标签显示了交易账户上的订单历史记录。订单历史记录也显示在带有如下字段的表格里：

  • 订单 — 订单的报价号（此号唯一） 。
  • 时间 — 订单时间。此记录表示为 YYYY.MM.DD HH:MM (年.月.日 小时:分钟)。
  • 类型 — 交易操作类型： "买入" — 一笔买入交易，, "卖出" — 一笔卖出交易。
  • 交易量 — 执行交易的交易量（手数）。
  • 交易品种 — 订单的金融工具。
  • 价格 — 订单价格被执行在。
  • S/L —下止损订单的水平。如果该订单没有下单，那么零值会显示在字段中。
  • T/P — 设置 盈利 订单的水平。如果该订单没有下单，那么零值会显示在字段中。
  • 时间 —平仓时间 。此记录表示为 YYYY.MM.DD HH:MM (年.月.日 小时:分钟)。
  • 手续费 — 交易商为交易操作收取手续费。
  • 库存费 — 收取的库存费金额。
  • 利润 — 平仓的金融结果。
  • 评论 — 交易操作的评论。


市场

开始使用 / 市场

市场

市场标签连接了客户端的用户与MQL5.community的MQL4程序商店。在这里他们可以为程序端下载免费或购买自动交易，指标和其他应用程序。商店也包括有关交易和金融的杂志和书籍。

Discover in 10 Minutes: Video on Market

Watch the below tutorial videos to learn about the Market. Click on the video image to watch it.

Watch video: How to purchase a robot or an indicator in Market? Watch video: How to search and choose applications Watch video: Free-of-charge testing of Expert Advisors and Indicators before purchase Watch video: How to update, renew the rental period and reinstall products

基本信息

  • 使用市场服务之前请仔细阅读规则。这些规则发表于MQL5.community网站。
  • 要使用“市场”服务，您应该有一个有效帐户在MQL5.community网站。帐户数据可以在程序端设置指定。如果设置中没有指定数据，那么您每次下载/购买产品时都会要求提供。
  • 所有计算均使用MQL5.community内部支付系统。
  • 每个产品都绑定购自于的PC机的配置。购买产品后对于买家在其他PC机上有效的产品激活数由卖家决定。这种激活最少为4次。

购买应用程序之前，你可以下载它的演示版。演示版本有一定的局限性：

  • 演示版本的EA交易 不能在客户端的在线图表上启用。其交易部分只能在策略测试中测试。
  • 演示版本的指标 不能启用和看见于在线图表上。它的行为只能在 策略测试的可视化测试模式中看到。

应用程序分类和搜索

Watch video: How to search and choose applications

Watch video: How to search and choose applications

The Market features a well-developed product filtration and sorting systems. Each product has a detailed description and screenshots. Moreover, robots and indicators have demo versions, while books have previews. Watch our video to know how to use all that functions and make the right choice.

标签上部是为通过类型和分类搜索应用程序而设计。

  • 主要 — 所有应用程序，书籍和杂志。
  • 应用程序 — 只有交易程序端的应用程序。
  • 杂志 — 有关交易和金融的杂志。
  • 书籍 — 有关交易和金融的书籍。
  • 购买 — 产品列表 由用户购买/下载。
  • 积分 — 当前账户结余在 MQL5.community。如果程序端设置中没有指定MQL5.community账户，那么注册链接会代替结余而显现。

当用户移动到确定的分类时（应用程序，书籍或杂志）其他搜索工具会出现在标签的上部：

  • 分类 — 在这里您可以选择其他类别过滤应用程序（专家，指标，程序库等）。
  • 搜索 —搜索应用程序的字段，通过名称或说明。在搜索字段中输入单词，然后点击 搜索 。

查看，下载和购买应用程序

应用程序列表中显示其成本及用户评价的评级。“免费”标签意味着应用程序在免费的基础上进行分布。

点击应用程序的标志，以浏览，下载或购买：

上部包含切换应用程序之间的数据标签的工具栏：

  • 返回 — 返回应用程序列表。
  • 应用程序 — 在这里可以查看应用程序的详细说明。
  • 截图 — 在这里可以查看应用程序截图。
  • 评论 — 在这里可以查看有关应用程序的用户评价。如果没有评论，该标签不显示。

购买

Watch video: How to purchase a robot or an indicator in Market?

Watch video: How to purchase a robot or an indicator in Market?

Any trader will find thousands of trading robots, indicators, financial magazines and books in the Market. All of that can be purchased directly in the platform and it's much easier than you think.

要购买应用程序，点击它，然后点击“买入”按钮。

要购买产品，在您的MQL5.community帐户上你必须有足够数量的积分。标志下面显示产品的成本。

点击“买入”按钮后，会出现购买确认窗口：

要确认购买，您需要同意市场服务使用规则和指定您的MQL5.community 账户密码。然后点击"OK"。

如果购买之前还没有在程序端设置中指定MQL5.community账户详情，您将需要指定它们。

  • 点击“买入”按钮后，相应的积分就会从您账户中扣除。下载到程序端的产品将启动。
  • 所有购买和下载都显示在“购买”标签。
  • 该产品被下载到 /MQL4/program_type/Market/ terminal 文件夹，其中program_type是一种应用程序类型。例如，EA交易将下载到 /MQL4/Experts/Market/。

下载以前购买的应用程序

Watch video: How to update, renew the rental period and reinstall products

Watch video: How to update, renew the rental period and reinstall products

All your products are tied to your mql5.com account or to your computer and available for you at any time. You will always know about updates, will be able to renew the rent or download a previously purchased product. Watch the video to find out how easy that is.

您可能需要将先前购买的应用程序移动到另一个程序端。例如，您可以在一个或多个PC上使用多个客户端。

如果您在一台PC上使用多个程序端，复制应用程序的ex5文件到目标程序端的类似文件夹。例如，你应该复制一个文件从[[original client terminal]\MQL4\Indicators\Market 到 [target client terminal]\MQL4\Indicators\Market。

如果你需要移动以前购买的产品到另一台PC，做到以下几点：

  • 指定您MQL5.community的帐户数据在目标程序端的 "Community" 标签 。
  • 打开“市场”选项卡并移动到“购买” 部分。接下来，点击已购产品附近的“安装”：

每个产品都绑定购自于的PC机的配置。根据“市场”服务规则购买产品后对于买家在其他PC机上有效的免费产品激活数由卖家决定。这种激活最少为4次。然后，用户将不得不再次购买它们。

演示版本

Watch video: Free-of-charge testing of Expert Advisors and Indicators before purchase

Watch video: Free-of-charge testing of Expert Advisors and Indicators before purchase

Before making a purchase it's recommended to test desired robots and indicators. It's an easy and free-of-charge operation that will give you more confidence in a product. Watch the video for details.

购买应用程序之前，你可以下载它的演示版。要做到这一点，点击产品，然后点击“下载演示”。

演示版本有一定的局限性：

  • 演示版本的EA交易 不能在客户端的在线图表上启用。其交易部分只能在策略测试中测试。
  • 演示版本的 指标 不能启用和看见于在线图表上。它的行为只能在 策略测试的可视化测试模式中看到。

更新应用程序

卖家可能会不时地发布其产品的更新版本以提高其可靠性和扩展功能。

  • 以前购买的产品的所有更新都是免费的
  • 产品更新经过短暂的延迟显示在客户端中，在其发布在Market on MQL5.community市场上以后。。

要检查您先前购买或下载的产品是否有新版本，可以去“购买”选项卡。

如果一个产品有新版本，你会看到相应的消息以及“更新”的按钮（或者支付产品演示版的“更新演示”按钮）。

一旦按下这个按钮，新版本将被下载。新文件取代旧文件。因此，如果需要，以不同的名字或在目录 [terminal data folder]\MQL4\Market\以外保存旧版文件。

购买和查看杂志和书籍

杂志和书籍可以用应用程序相同的方式进行购买。在杂志或书籍页面点击买入。购买确认对话框会出现：

要继续，同意市场服务使用规则并输入您的MQL5.community密码。然后，指定金额将会从您的账户扣除而杂志将被下载。买入按钮被打开按钮代替。

杂志文件下载到My Documents\MQL5 Market\Magazines\[Magazine name]\[Issue name]。下载可以按两种格式执行：

  • MQB — 这种受保护的格式用于付费杂志。当购买和下载杂志文件时，会进行编码以便于只能在下载它的PC机上打开它。生成编码副本成为激活。每个杂志都可以在不同的硬件上至少激活5次。杂志卖家可以自主决定的提高激活次数。
  • PDF — 该格式用于免费杂志。下载以后，这种文件可以在其他设备上移动和查看。

称为MetaViewer的特殊组件已经提供在程序端，它允许用户查看MQB文件。当您在已下载杂志页面点击打开时，该应用就会启动。如果用户帐户控制 系统在用户的PC机上启用，在第一次启动时，用户将得到提示是否允许程序端关联MQB文件和MetaViewer。关联后，当从Windows文件浏览器启动时MetaViewer会自动打开MQB文件。

如果单击ОК，即会关联文件并且MetaViewer会立即打开选择的杂志刊号。如果您单击取消，只有杂志刊号被打开。

MetaViewer 是一个便捷的应用程序，用于查看MQB和PDF格式的书籍和杂志。键盘箭头用来翻页：左右箭头 - 为逐页导航，而上下箭头 - 是滚动页面。有关MetaViewer的更多详情可以在相应的部分找到。

购买/下载

"购买"标签显示了使用当前 MQL5.community 账户下载和购买的所有产品。如果程序端设置中没有指定MQL5.community 账户数据，标签名称改为"下载"。它显示了无论哪个账户，当前客户端中的全部下载和购买。

这里会显示以下信息：

  • 名称 — 产品名称。演示版本的产品都标有 演示 标签。
  • 类别 — 产品类别，如EA，指标等。如果您点击产品类别，它会选择在 "导航" 窗口。
  • 价格，积分 — 产品成本积分。
  • 日期 — 产品下载/购买日期。


MetaViewer

开始使用 / 市场 / MetaViewer

MetaViewer

MetaViewer是一个便捷的应用程序，用于查看在市场购买的MQB和PDF格式的书籍和杂志。

键盘箭头用来翻页：左右箭头 - 为逐页导航，而上下箭头 - 是滚动页面。MetaViewer菜单和控制面板包含用于设置日志查看和导航的额外命令。

首次启动

如果用户帐户控制系统在用户的PC机上启用，在第一次启动时，用户将得到提示是否允许程序端关联MQB文件和MetaViewer。关联后，当从Windows文件浏览器启动时MetaViewer会自动打开MQB文件。

如果单击ОК，即会关联文件并且MetaViewer会立即打开选择的杂志刊号。如果您单击取消，只有杂志刊号被打开。

菜单

菜单

命令

文件
  • 打开数据文件夹 打开 — 打开杂志/书籍文件。
  • *.mqb/*.pdf —当前文件
  • 退出—退出MetaViewer

查看
  • 语言 — 切换MetaViewer界面语言。
  • 单页 单页 — 书籍/杂志逐页显示。MetaViewer窗口只显示一个页面。
  • 双面 双面 —在MetaViewer窗口双页显示书籍/杂志。 该模式最适合大屏显示器。
  • 书籍视图 书籍视图 — 启用书籍视图。页面显示为侧转印刷的杂志/书籍。
  • 启用滚动模式 启用滚动模式 — 如果启用，那么页面随着鼠标滑轮滚动或上下箭头缓慢翻页移动。如果禁用，那么鼠标滑轮的每次滚动/按下箭头键都会前后整页的翻页。
  • 目录 目录— 显示/隐藏目录。
  • 工具栏 — 显示/隐藏工具栏。
  • 状态栏 — 显示/隐藏 状态栏。
  • 向左旋转 向左旋转— 向左旋转90度。
  • 向右旋转 向右旋转— 向右旋转90度。

导航
  • 首页 首页 —转到首页。
  • 上一页 上一页 — 转到杂志/书籍的上一页。
  • 下一页 下一页 — 转到杂志/书籍的下一页。
  • 尾页 尾页 — 转到尾页。
  • 页面 页面 — go to specifying the page number to switch to on the toolbar.
  • 返回 返回— 返回上一页。
  • 前进 前进 — 从上一页返回到下一页。

缩放
  • 放大 放大。
  • 缩小。 缩小。
  • 适合页面 适合页面 —使页面适合MetaViewer当前窗口大小。
  • 实际大小 实际大小 — 切换到页面的实际大小。
  • 适合宽度 适合宽度 — 使页面适合MetaViewer窗口宽度。
  • 适合高度 适合高度— 使页面适合MetaViewer窗口高度。

帮助
  • MQL5.community — 打开MQL5开发者社区 网站 部分的链接菜单： 文档，文章，代码库，工作，论坛， 市场 和信号。
  • 关于MetaViewer 关于MetaViewer — 打开有关公司信息，联系方式和MetaViewer版本的窗口。.

工具条

命令 | 描述
打开 | 打开杂志/书籍文件。
目录 | 显示/隐藏联系人列表。
单页 | 逐页显示书籍/杂志。MetaViewer窗口只显示一个页面。
双页视图 | 在MetaViewer 窗口双页显示书籍/杂志。该模式最适合大屏显示器。
书籍视图 | 启用书籍视图页面显示为侧转印刷的杂志/书籍。
启用滚动模式 | 如果启用，那么页面随着鼠标滑轮滚动或上下箭头缓慢翻页移动。如果禁用，那么鼠标滑轮的每次滚动/按下箭头键都会前后整页的翻页。
向左旋转 | 向左旋转90度。
向右旋转 | 向右旋转90度。
适合页面 | 使页面适合MetaViewer当前窗口大小。
首页 | 转到首页。
上一页 | 转到杂志/书籍的上一页。
页码 | 转到指定页面。指定页码后，按下Enter。
下一页 | 转到杂志/书籍的下一页。
尾页 | 转到尾页。
返回 | 返回上一页。
前进 | 从上一页返回到下一页。
缩小。 | 缩小。
缩放 | 设置缩放水平。指定缩放百分比水平并按下Enter键或从下拉列表中选择需要的值。
放大 | 放大。

状态栏

状态栏位于MetaViewer窗口的底部。它包括菜单和工具栏命令的提示。您可以使用查看 菜单中的“状态栏”命令来显示/隐藏状态栏。


Virtual Hosting

开始使用 / Virtual Hosting

Virtual Hosting

Virtual hosting is a service providing the round-the-clock operation of the client terminal. That may be necessary in the following cases:

  • a trader has a trading robot developed by his or her efforts or ordered from programmers;
  • a trader has an Expert Advisor purchased in the Market;
  • a trader has subscribed to a Signal.

All these cases require constant connection to a trade server and uninterrupted power supply. Using a home PC is not always possible and convenient.

The trading platform offers convenient and quick solution to all traders — you can rent a virtual server for your trading account right from the client terminal.

Discover in 6 Minutes: Video on Virtual Hosting

Watch the below tutorial videos to learn about the virtual hosting. Click on the video image to watch it.

Watch video: How to Rent A Virtual Platform Watch video: Preparing to Migrate Robots and Signals Watch video: How to Control Resources and Manage Subscriptions

Unlike renting ordinary VDS or VPS from third-party companies, you are able to select the server that is the closest to your broker minimizing the network latency when sending orders from the terminal to the trade server.

The payment for using the service is conveniently performed via MQL5.community account. If you do not have an account yet, please register. The account should be specified in the terminal settings.

The subsections describe all stages of working with the Virtual Hosting service:

  • Registering Server — selecting the virtual server that is the closest to the broker in order to provide the minimum network latency, choosing the service plan.
  • Migration — preparing the terminal environment for migration to the virtual server: selecting charts, indicators, Expert Advisors, as well as configuring signals, email and FTP.
  • Working with Terminal — managing the terminal operation on the virtual server: viewing terminal and Expert Advisor operation journals, as well as viewing resource consumption statistics.


Registering Server

开始使用 / Virtual Hosting / Registering Server

Registering Server

To receive a virtual terminal, connect by the appropriate trading account, open the context window of the Navigator and execute " Register a Virtual Server Register a Virtual Server" command.

Watch video: How to Rent A Virtual Platform

Watch video: How to Rent A Virtual Platform

Detailed how-to description that will help to rent a virtual hosting directly from a trading platform. Its simple: choose nearest server and payment plan in order to let your robots and signals work for 24 hours a day.

Registering a virtual server

Virtual Hosting Wizard window appears. It shows how the virtual hosting network works.

Virtual hosting structure

At the next stage, you are informed on how to prepare the terminal for migration and how the process itself is performed.

Migration description and the checkbox of the virtual hosting usage rules

You should also read the article "How to Prepare a Trading Account for Migration to Virtual Hosting" at this stage. If you have read the article and you are satisfied with how the service works, check the box and continue the process.

At the next stage, you need to select the most suitable server.

Selecting a server

It is recommended that you select the server with the minimum ping (network latency). The hosting company name and rental price in USD per month are specified for each server. Select the server and click Next.

After that, you need to select the service plan.

Selecting the service plan

Service plan conditions are defined by hosting companies. A free test period may be provided to try out the service.

You can change the selected service plan after the rental period expires.

To continue, you should agree with the Virtual Hosting service rules. Read them carefully.

If you want the rental period to be renewed after its expiration with the same service plan, enable the option "Automatically renew subscription with sufficient funds and terminal activity". The renewal can be performed only if there are enough funds on your MQL5.community account to pay for the rent and the rented server is running.

After clicking Next, the server rent process is finished and the appropriate payment is deducted from your account.

If the rent is canceled by a user, no refund is made.

Completion of the server registration

You can move the terminal environment to the virtual server immediately. Select the necessary migration type and click "Migrate now". If the terminal is not prepared yet, click Finish to perform migration later.


Migration

开始使用 / Virtual Hosting / Migration

Migration

Migration is transferring the current active environment from the client terminal to the virtual one. This is a simple and straightforward way to change the set of launched programs, open charts and subscription parameters in the virtual terminal.

Preparing for Migration

Before launching the virtual terminal, you should prepare an active environment for it — charts, launched indicators and Expert Advisors, Signal copying parameters and the terminal settings.

Watch video: Preparing to Migrate Robots and Signals

Watch video: Preparing to Migrate Robots and Signals

How to setup a trading environment, in order to execute your trading robots and signals on a virtual platform for 24 hours a day?

Charts and Market Watch

In the Market Watch window, set up the list of symbols critical for your Expert Advisors' operation. We recommend that you remove all unnecessary symbols to decrease the tick traffic received by the terminal. There is no point in keeping hundreds of symbols in the Market Watch if only a couple of them are used for trading.

Open only the charts that you really need. Although there are no limitations on the number of open charts, there is no point in opening unnecessary ones. Color settings do not matter.

Set "Max bars in chart" parameter in Charts tab of the terminal settings. Some custom indicators are developed in a wasteful way and perform calculations on all history available on the chart. In that case, the lesser the specified value, the better. However, make sure that the indicator works correctly with these settings by restarting the terminal after changing this parameter.

The virtual terminal has been designed so that it automatically downloads all available history from a trade server, but not more than 500 000 bars are available on a chart.

Indicators and Expert Advisors

Apply to the charts all indicators and Expert Advisors that are necessary for the terminal's autonomous operation. Most trading robots do not refer to indicators on the charts, so check out and decide what you really need.

Products purchased on the Market and launched on the chart are also moved during migration. They remain completely functional, and the number of available activations is not decreased. Automatic licensing of purchased products without spending available activations is provided only for the virtual terminal.

DLL calls are completely forbidden in the virtual terminal. During the first attempt to call a function from DLL, the launched program is stopped with the critical error.

All external parameters of indicators and Expert Advisors should be set correctly. Check them once again before launching synchronization.

Scripts cannot be moved during migration even if they have been launched in an endless loop on the chart at the time of synchronization.

Configuring Email, FTP and Signals

If an Expert Advisor is to send emails, upload data via FTP or copy Signal trades, make sure to specify all necessary settings. Set correct login and password of your MQL5.community account in Community tab. This is necessary for Signal copying.

Permission to Trade and Signal Copying

The automated trading is always allowed in the virtual terminal. Therefore, any Expert Advisor with trading functions launched during synchronization can trade on the virtual terminal after the migration. Do not launch the Expert Advisors you are not sure about.

When migrating Expert Advisors, autotrading function is automatically disabled in the local terminal. This is done is order to prevent the situation when two terminals connected with the same account trade with the same Expert Advisor.

Regardless of whether autotrading is allowed or forbidden in your client terminal or in the properties of a launched Expert Advisor, any trading robot is allowed to trade after being moved to the virtual terminal.

Set necessary trade copying parameters in Signals tab. If a trading account has an active subscription and trade copying is allowed, permission to copy signals is disabled in the client terminal during migration. This is done in order to prevent the situation when two terminals connected to the same account copy the same trades simultaneously. It is not necessary to turn on signal copying on the local terminal when migrating to a virtual terminal where the signal is already running.

Trade copying is automatically enabled on the virtual terminal when migration is complete. Message about copy cancelation in the client terminal is also repeated in the journal.

Setting WebRequest

If a program that is to operate in the virtual terminal uses WebRequest function for sending HTTP requests, you should set permission and list all trusted URLs in Expert Advisors tab.

Migration

Migration is performed during each synchronization of the client terminal. Synchronization is always a one-direction process — the client terminal's environment is moved to the virtual terminal but never vice versa. The virtual terminal status can be monitored via requesting the terminal's and Expert Advisors' logs as well as virtual server's monitoring data.

To perform synchronization, open the context menu and select migration type. There are several types of migration that should be used depending on the objective:

  • All — complete migration is necessary if you want to simultaneously launch Expert Advisors/indicators and trade copying. In this mode, account connection data, as well as all open charts, signal copying parameters, launched Expert Advisors and indicators, FTP and email settings are moved to the virtual server.
  • Experts — only Expert Advisors and indicators are moved, if subscription to Signals is not required. Unlike the complete migration, signal subscription parameters are not transferred in this mode.
  • Signal — only Signal copying settings (no charts or programs) are moved. In this mode, account connection data, signal copying parameters, FTP and email settings are moved to the virtual server.

Thus, you always can change the number of charts and the list of symbols in the Data Window, the set of launched programs and their input parameters, the terminal settings and Signal subscription.

All available history concerning the open charts is automatically uploaded during the first synchronization. Uploading history from a trade server can take some time, and all programs launched on the charts should process the updated data correctly during the synchronization.

When performing migration, all data is recorded in the client terminal's log.

Logging migration process

After the synchronization, open the virtual terminal's main journal to examine the actions performed on it.

Requesting the Journal from the Virtual Terminal

In the newly opened log window, you can set a piece of text the journal entries are to be filtered by and a desired interval. After that, click Request to download the found logs.

Viewing Journal logs

The virtual terminal's logs are updated during each request and saved to [terminal data folder]\logs\hosting.*.terminal\.

Migration Features

The migration process has a number of features:

  • Automated trading is always allowed in the Virtual terminal even if it has been forbidden by the terminal settings or in the launched Expert Advisor's parameters.
  • Scripts are not moved during migration even if they have been launched in an endless loop on the chart at the time of synchronization.
  • Charts with non-standard timeframes and symbols are not moved.


Working with Terminal

开始使用 / Virtual Hosting / Working with Terminal

Working with the Virtual Terminal

The rented virtual server status can also be easily monitored from the client terminal. The server's context menu in Navigator window allows you to:

  • View the virtual server data.
  • Synchronize the environment by performing the immediate migration.
  • Request terminal and Expert Advisor operation journal.
  • Stop the server.
  • Cancel the hosting.

Viewing the virtual server data

Watch video: How to Control Resources and Manage Subscriptions

Watch video: How to Control Resources and Manage Subscriptions

How to analyze the virtual hosting resources report and how to control your subscriptions - we show you in this video.

Details

To view the virtual server data, click Details Details in its context menu. The information is presented in several tabs.

Details

The following information is displayed here:

  • Hosting server name and your virtual terminal ID.
  • Ping in milliseconds displaying the network delay between the virtual server and a trade server of your broker.
  • Virtual server status: started, stopped. Here you can also enable/disable the virtual server and cancel the rent.
  • The service plan selected when registering the server.
  • Registration date, MQL5.community account registration is performed to and the account's current balance.
  • Last synchronization date and its type. Here you can also perform immediate synchronization of the current terminal environment.

CPU Usage

CPU usage graph

CPU usage graph is displayed here in percentage terms.

Memory Usage

Memory usage graph

Memory usage graph is displayed here.

Hard Disk Usage

Hard disk space usage graph

Hard disk space usage is displayed here.

Virtual Terminal Journal

You can view the virtual terminal's journal to control its operation.

Requesting the Journal from the Virtual Terminal

In the newly opened log window, you can set a piece of text the journal entries are to be filtered by and a desired interval. After that, click Request to download the found logs. Here you can also select the journal type:

  • Terminal — logs about all events taking place in the terminal including trade operations.
  • Experts — data on Expert Advisor and indicator operation.

Viewing Journal logs

The virtual terminal's logs are updated during each request and saved to [terminal data folder]\logs\hosting.*.terminal\.

If a user requests too many records, then only part of the first logs for the specified period will be downloaded. This prevents performance degradation resulting from large logs. If you want to download further logs, you don't need to change the request period. Simply select the last line in the log viewer window and press PgDn.

Stopping the Server

Stopping the server means the temporary shutdown of the virtual terminal. This action is similar to closing the terminal on PC. It is performed by Stop Server "Stop Server" command in the server context menu of the Navigator window.

To launch the terminal, execute Start Server "Start Server" command.

Canceling the Hosting

Hosting cancelation means the virtual server is no longer provided and the virtual terminal is completely deleted with all data moved to it during the migration

No refund is made. The rental pay can be returned only within 24 hours after the virtual server has been registered.

To cancel the hosting, execute Cancel Hosting "Cancel Hosting" command in the server context menu of the Navigator window.


新程序端

开始使用 / 新程序端

新程序端

第五版交易程序端自2007年开始进行开发。构思其成为一款革新性的，服务于多市场的平台，它可以在外汇市场运行，也可以在其他任何金融市场运行。从那时起许多工作已经完成，工作成果就是其成为为交易人提供无限机会的多种服务的基础设施。

这部分包含第四和第五版交易程序端主要不同之处的列表。

  • 交易
    新的持仓账户系统，单击交易，新订单类型，移动图表上的交易水平和访问交易所。
  • 图表
    增加内置指标和技术分析工具的数量；时间表的数量也提升到21种。
  • MQL5
    与MQL4相比，操作速度提升至20倍，支持OOP和开发非常复杂程序的能力，类似于C++。
  • 市场
    拥有大量付费免费程序的MQL5市场应用程序商店实现到程序端。
  • 工具
    在程序端直接显示宏观经济指标的市场事件评论能够在图表上显示。代码库中发布的任何代码都能够通过程序端直接下载。
  • 策略测试器
    策略测试器现在是一个支持MQL5云网络的多货币，多线程功能。另外，也已经实现测试结果的3D可视化。测试报告更加详细，实现更多的统计值。
  • MetaEditor
    源代码调试，分析，MQL5网上存储库的内置版，以及允许没有编程技巧的用户生成现成EA交易的MQL5向导。


交易

开始使用 / 新程序端 / 交易

交易功能

第五代程序端，交易机制较第四代发生了显著地变化。所有的这些变化都是为了强化交易平台的使用。随着新程序端的发布，交易人可以在任何证券交易所和通过任何ECN进行交易。交易平台已经得到许多证券交易所的独立软件供应商（ISV）的身份，包括SMX，GBOT，CitiBank，Currenex，DGCX，Integral等等。下一步计划就是整合全球的主要证券交易所。

新交易系统

第四代交易程序端使用了买卖盘为基础的制度，允许交易人一个交易品种拥有几个持仓，包括反向持仓。为每个打开订单都可以设置保护性止损和获利水平。这些水平只能用于特定订单。每个持仓订单收取单独的库存费。库存费取决于交易量和说明。

第五版本使用持仓基础系统。对于每个交易品种，在任何给定的时刻只有一个持仓（买入或卖出持仓）。因此，如果您持仓买了1手金融工具，并出售一手工具，则将被平仓。如果您持仓买了1手金融工具，并又多买一手，那么您将有2手持仓。

保护性止损和获利水平可以设置为持仓和挂单。但与之前版本不同的是，当一个挂单被激活时，其止损和获利水平将设置在该交易品种持仓。换句话说，持仓指定的SL / TP值将被挂单重写。

六种挂单类型

除了市场，限制和止损订单外，第五版交易平台支持更多两种挂单类型 - 购买止损限价和出售止损限价。这样的订单触发时，适当的限价订单类型即被下单。新类型的订单提高执行交易策略的可能性。

单击交易

交易中进行交易操作的速度是非常重要的。新程序端提供单击即时交易的可能性。这个特性提供在市场报价窗口：

此外，交易人还可以从工具箱窗口平仓和删除挂单。

修改图表上的交易水平

MetaTrader 5提供了直接在图表上更改挂单价格，以及止损和获利订单的机会。现在，看市场现状，您可以很容易地拖拽交易水平在所需的地区，然后更准确地调整其值：

自客户端build 600 开始，从图表单击交易和用图表特性管理交易水平已成为可能。


图表

开始使用 / 新程序端 / 图表

图表

第五代平台的一个显著优势在于其分析部分。真实价格图表提供相当广泛的功能。

自定义和21种时间表

平台的图表有多种不同的设置，以便于交易人可以自定义来适应他们的需要。交易程序端支持三种类型的图表：虚线，系列柱和日式蜡烛。您可以在图表上为每个条目设置单独的颜色，来为长期工作创建最舒服的工作区。与第四代平台相比，MetaTrader 5支持许多图表周期的两倍以上。 现在21种时间表可供使用。

指标

交易程序端的标准交付包含有38种技术指标。基于它们的类型，方便在导航中分组：趋势指标，震荡指标，交易量指标，和比尔 威廉姆斯指标。可用指标包括Bollinger Bands，Envelopes，Moving Average，Parabolic SAR，Standard Deviation， Ichimoku Kinko Hyo，MACD，Bulls Power，Bears Power，Alligator，Awesome Oscillator，和许多其他指标。

第三方指标的数量几乎没有限制。大量的指标从 代码库供于下载 并且可以购买于 市场只需单击。

分析工具

可用分析工具的列表已经得以扩展。现在第五代程序端提供46种物件，包括埃利奥特工具，斐波纳契工具和江恩工具，图解物件（包括与MQL5程序交互的物件），图形，通道，线性等等。


MQL5

开始使用 / 新程序端 / MQL5

MQL5

MQL5语言更加强大并允许用户开发复杂的程序。

更大的运行速度

与MQL4相比，MQL5代码的执行速度提高了4-20倍！执行速度几乎已经达到了C + +语言的水平，所以用MQL5您不需要使用第三方DLL来加快计算。反过来，缺乏DLL提高了应用程序的安全性。

相似于С+ +

MQL5语言的语法与最流行的编程语言之一C + +非常相似。因此很容易学，您可以很容易地从其他现代编程语言将程序翻译成MQL5。MQL5是一种面向对象的语言语言，它允许您利用这个编程方法——类型的封装和可扩展性，继承性，多态性，重载和虚函数。

OpenCL支持

MQL5 本地支持OpenCL只需单击。要使用所有益处，您无需第三方程序库。只是使用专用的MQL5函数。OpenCL语言用于在支持OpenCL1.1或更高版本的视频卡上执行计算。

现代视频卡包含数百家小型专用处理器，它们可以使用传入的数据流同时进行简单的数学运算。OpenCL语言组织平行计算并为某一类任务提供更大的速度。

600版客户端对MQL4语言引入了一个巨大的更新，带来了MQL5水平的能力，速度和安全性。


市场

开始使用 / 新程序端 / 市场

市场

交易程序端与为交易人准备的MQL5.community服务紧密集成在一起。市场是MQL5应用程序商店，在这里任何人都可以使用程序端购买产品。为了您的方便，市场服务集成于客户端。

市场Market - MetaTrader 5应用程序商店

在工具箱窗口，交易人可以看到市场中可用的所有范围的应用程序。购买之前，交易人可以下载试用版并在策略测试器中进行测试。此外，许多免费应用程序也可以从市场下载。

购买和下载列表方便地表现在购买标签中。下载/购买的应用程序根据其类型会在您可以运行它们的导航中自动排序。

从客户端build600开始，即可使用MQL4 应用程序市场。


工具

开始使用 / 新程序端 / 工具

工具

在第四代程序端可供使用的工具窗口，现在甚至提供更多的功能。

市场评论

第五代程序端的新功能之一就是市场评论，它允许执行市场的基本分析。宏观经济指标可以实时更新。另外，市场评论事件可以轻松地显示在价格图表上。

从代码库下载

由于交易程序端 MQL5.community紧密集成 服务，只需单击您就可以从导航窗口的代码库开始下载EA交易，指标或脚本。在每个应用程序类别都有一个特殊的“更多”命令。命令旁边的数字表示可下载应用程序的数量：


策略测试器

开始使用 / 新程序端 / 策略测试器

策略测试器

第五代程序端最重要也是最值得期待的更新之一就是多货币策略测试器。现在，交易人拥有无限的可能性，可以测试和优化交易几个交易品种的EA交易。

高级测试报告

EA测试结果报告得到显著扩充。它包括额外统计，允许更好地评估交易策略。现在，交易人可以分析采收率，夏普比率，持仓时间等诸多特点。测试报告中提供超过40个特点。

测试报告的图形组件还扩大了很多。除了结余和净值的图表，测试器可观察到持仓进入和盈利/亏损（每小时，每周，每月）的时间分布：

此外，它产生利润和MAE / MFE分布图，以及利润和持仓时间分布。

MQL5云网络

MQL5云网络 允许在需要和提供电脑空闲CPU时间的人们之间组织计算资源的交流。随着MQL5云网络的出现，交易人可以利用成千上万的世界各地代理商的计算能力。如果只用一台电脑需要花费几年时间的优化，现在只需运行几个小时。

要使用网络，只需打开策略测试并启用云代理。

除了使用MQL5云网络，在网络中您还可以提供您的CPU计算能力，并从中获利。要做到这一点，您甚至不需要安装MetaTrader 5客户端。下载专门创建的安装程序，让您可以快速，轻松地安装 MetaTester，在电脑上管理远程代理的应用程序。

一个简单的设置后，您加入MQL5云网络，并开始盈利。对网络使用和您提供CPU能力的盈利的统计非常方便地收集在您MQL5.community的个人资料上 只需单击。关于代理的信息在它们完成第一个任务后将马上出现在您的个人资料中。

优化结果的2D和3D可视化

有人说，一张图片胜过千言万语。在策略测试器中您可以在可视模式下分析优化结果。这是优化的二维可视化。绿色阴影越深，优化标准越高：


MetaEditor

开始使用 / 新程序端 / MetaEditor Previous

MetaEditor

内置编程语言始终是MetaTrader 交易平台最重要的组成部分之一。应用程序开发不只是MQL5编程语言，其毋庸置疑的优势将在下面得到证明，但它还是editor，通过它您可以从事源代码工作。新MetaEditor提供许多之前版本的用户所没有的新功能。

MQL5 存储的个人代码存储库

MQL5存储是专为存储版本文件和直接从MetaTrader 5手动管理全部项目而设计的个人MQL5源代码存储。

源代码存储在安全远程的存储库，可以通过您的 MQL5.community账户访问这里。如果硬盘失败，用户代码的本地副本可以快速地从存储库恢复。

交易人可以从任何电脑访问他们的存储库。他们只需在MetaEditor用MQL5.community账户登录。他们使用导航窗口的便捷快捷菜单进行存储。

存储库中的每次更改都会得到记录。过后用户可以查看更改的全部历史记录，比较文件版本 使用特殊工具，并恢复到以前的任何版本。只需单击。

MQL5存储库选项将会不断扩展。它将通过授权所需的MQL5.community账户使用存储库启用项目协作。

调试

毫不夸张，使用MetaEditor 4的每个人都想要调试功能。第五代版本中调试器的出现使MQL5应用程序的开发提升到一个新的水平。所有标准功能都可用于调试应用程序：

  • 断点：在源代码行设置断点，在这里必须中断程序执行的过程以便学习程序的行为。
  • 观察表达式：跟随工具箱中一个单独标签调试时的任何表达式的值。
  • 堆栈调用：在调试过程中观察调用堆栈。
  • 逐步调试：使用逐步调试命令 - 进入，跳过和跳出。

代码分析

调试大大简化了程序员的工作。但MetaEditor 5还有一个功能强大的源代码优化的工具。代码分析器检测到所有应用程序的瓶颈。

代码分析器分析应用程序的单个源代码片断的执行速度。分析结果都是由各个功能和线条提交给程序员。因此，现在有可能找到代码的最慢部分和优化MQL5的程序操作。

MQL向导

MetaEditor 4包括一个向导，用于创建允许生成用于开发各种应用程序模板的EA交易。在第五版的MetaEditor中此组件已经显著地重新设计。它新名字是MQL向导。它仍然允许您创建那些已经正确设计并包含必要事件处理程序的模板。然而，主要的新功能是产生随时可以使用的EA交易的可能性。交易人必须选择EA交易将使用哪些信号，其资金管理策略以及它得到保护免受损失（追踪止损类型）的方式。

现在，交易人并不一定需要知道如何用MQL5编程，来得到一个现成的EA交易。几个简单的步骤就可生成一个EA。然后您就可以开始在策略测试器中优化您的EA交易。

自从build600，第四版的客户端已经被切换到使用来自第五版交易平台的MetaEditor。统一的MetaEditor现在用于两个版本的客户端。